Forum Clubic

Débuts en vrac (page 7)

mon hackintosh en P4 SSE2 à 1,2GHz met aussi une trentaine de secondes à arriver à la fenêtre de login, écran de bios inclus :ane:

Même réflexion que Philouvb : tu as vraiment un méchant problème.
Mon pauv’ PPC 1,5ghz a complètement démarré le système (tout le bureau chargé, toute la barre du finder, dont le réseau wi-fi, tout fonctionnel) en un peu plus d’une minute (1mn6, je viens de compter pour être précis). J’ai l’aide-mémoire qui se charge aussi entre-temps.
Donc, ton MacBook, pour ce que j’ai vu de ces machines jusqu’ici, devrait m’exploser complètement.
Je vois que deux solutions :

  • tu as un programme hyper complexe comme tu sembles les affectionner qui te pourrit complètement ton démarrage (c’est quoi le Windows server, là ???)
  • tu as carrément un gros problème matériel (je trouve très suspect la taille de ta mémoire résidente, vue si je me rappelle bien dans un autre post).

Bref ! Ou tu as chargé ton Mac comme un mulet avec des programmes vraiment très spéciaux (et vu comment tu sembles bricoler avec un peu tout ce qui te tombe sous la main, c’est pas impossible) ou tu as un sérieux problème matériel, qu’il faudrait peut-être songer à faire constater)…

Je ne les affectionne nullement. Je n’en ai trouvé que sur Mac pour l’instant.
Et WindowServer, c’est un processus OSX, lié au dashboard d’après ce que j’ai constaté.

Et comment on constate ce genre de défaut sur OSX ? Comment prouver au fournisseur que la machine est foireuse ?

Non

Vu la flexibilité d’OSX, toute tentative d’installer un logiciel autre que Mac, ce qui se fait sans problème sur WIndows et Linux, passe forcément par du bricolage sur OSX…
Et puis quand on est habitué à OSX et Windows et qu’on voit une personne qui essaye de faire des choses en ligne de commande, on pense tout de suite à du bricolage…
Oui, je bricole, pour essayer de régler les put**** de problèmes que j’ai sur OSX, comme de nombreuses personnes, sauf qu’il n’y a jamais de solution.
La seule différence, c’est que tous les problèmes d’OSX, moi je tombe dessus et ils me gênent…

J’avais déjà demandé ça sur le forum. Comment détecter et constater un défaut matériel (moi je pencherais plutôt vers le disque dur) sur OSX ? Je n’ai eu aucune réponse…

Je dois avouer que plus je travaille dessus, et plus j’ai une mauvaise impression… OSX est sûrement très bien pour ceux qui ont très peu de besoins, mais moi j’en ai, je suis exigeant, et je n’excuse pas les erreurs, encore moins quand aucune solution n’est fournie, que ce soit par l’éditeur ou un tiers.

WindowsServer est comme son nom l’indique le service qui s’occuper de gérer l’affichage des fenêtres.

C’est mal connaître ce système que de dire ça :wink: Mais pour étayer mon affirmation, je devrais faire la comparaison par rapport à W****** mais on me tomberait encore dessus à coup sûr :smiley:

Bon par contre dire ça ne résoud pas ton problème, faudrait que s’y pencher plus sérieusement en direct par chat par exemple.

Je ne demande que ça. Et si j’ai effectivement un problème matériel, plusieurs points négatifs d’OSX que j’ai constatés pourraient en être des symptômes (lenteur de démarrage, freeze répétés ne serait-ce que pour lancer un menu contextuel…). Mais plus je trouve d’autres personnes qui ont mes problèmes, et plus je me rends compte qu’on est nombreux, et je trouve toujours quelqu’un qui constate les mêmes soucis que moi.
Et j’ai appris sur un site aujourd’hui que OSX avait son “BSOD” : la Spinning Wheel Of Death :paf:

Je suis en train de faire un compte-rendu de mon “expérience” sur OSX… Je dois dire que pour l’instant j’ai du mal à voir les côtés positifs de la chose… Ce n’est pas forcément gênant, car mon avis est forcément subjectif et sujet à modération de la part d’autres personnes qui ne sont pas d’accord, ou qui ont une vision différente, mais ça montre bien que je suis au bord de la crise de nerf, ce qui ne m’était jamais arrivé sur un autre système…

Les Mac à base Intel étant justement réputés pour démarrer en un temps record…

Tu n’as donc encore jamais eu de Kernel Panic :ane:
Et la Spinning Wheel infinie est souvent le résultat du blocage du bousesque Finder, un pomme-alt-esc suffisant souvent à le relancer.

Si, j’en ai eu un l’autre jour, mais pour l’instant, je dois dire que je suis tranquille de ce point de vue.

Pomme-ALT-Esc, je n’ai pas encore complètement intégré ce raccourci. Il est moins connu que son alter-ego :slight_smile:

Sinon je suis toujours (et surtout) intéressé par une méthode, un lien, des logiciels, qui me permettraient de mettre en lumière un problème matériel…

La logique voudrait que l’on recherche d’abord une cause logicielle, surtout avec ton histoire de processus fous.

Une petite recherche sur Google, et on trouve bien vite tout un tas de problèmes de consommation CPU autour de mds et coreservicesd. Il s’agit de Spotlight…
Si le disque est défectueux, ça peut être une explication. Mais de nombreuses personnes ont des soucis avec ces processus. Et bien sûr, aucune solution, ce serait trop facile :slight_smile:
Autre point qui peut aussi confirmer un défaut de disque dur : le lancement d’appli Java est très, très lent… Notamment les applets.

Au niveau logiciel, comme je l’ai déjà dit, je n’ai rien d’exceptionnel… J’ai bien des applis consommatrices, comme Parallels ou Office, mais elles ne sont pas en cause, car les problèmes surviennent même entre le boot et le lancement d’une de ces applis…

De plus, ça n’explique pas le boot très lent. cf. les applis que je lance au démarrage, et qui sont peu nombreuses (Growl, Adium, et le driver pour mon pack clavier/souris Logitech)

Ce message n’était pas conforme aux règles d’utilisation du nouveau forum :

MP :wink:

C’est cool les MP, mais je me dis que les essais pour trouver le problème peuvent servir à d’autres… Peut être un sujet dédié ? Il en pense quoi Frank ? :smiley:

Tu n’as pas essayé de voir le problème avec Apple ? Je ne sais plus si tu es encore dans les trois mois de support. Si c’est encore le cas essaie. Le problème c’est que pour ce que j’en ai vu tu tombe d’abord sur des types qui n’y connaissent rien et tu n’as les techniciens chevronnés qu’après. D’où l’intérêt de noter le numéro d’intervention pour pouvoir reprendre où tu en étais et “grimper” dans le niveau des types que tu as au téléphone.
J’avais téléphoné pour un problème d’incompatibilité de mon graveur avec mon lecteur CD auto mais j’ai laissé tomber au premier stade… Mais ça peut valoir le coup de faire un petit parcours du combattant chez Apple pour un vrai problème comme le tien.
Parce que là tu dis OSX finalement c’est pas terrible, mais je t’assure que peu d’OSX fonctionnent comme le tien. Il y a peu d’être d’autres problèmes, mais ils sont sans doute liés eux aussi à un gros problème.

Déjà il faudrait voir si ton système, “à vide” avait ce genre de symptômes. Si c’est le cas je ne vois qu’un problème matériel ou une OSX défectueux (mais est-ce seulement possible ? le DVD est vérifié à l’installation, donc je ne vois pas trop).
Ensuite installer un à un tes programmes et prendre le temps de les utiliser pour voir si les symptômes réapparaissent… Je suis conscient que tout ça demande du temps, mais j’ai eu pour ma part pas mal de plans de ce genre sous Windows où je cherchais désespérément LE programme fautif. Comme souvent c’était un problème d’interaction entre deux programmes, j’avais le temps de m’amuser.
Or, là avec mes 369 programmes dans mon dossier application, je n’ai même pas vraiment de problème d’interaction. Peut-être un ou deux, mais rien de grave, et surtout ça ne joue que sur le programme en lui-même, pas sur le système.

Ah si ! J’ai ce "$*D :grrr: de Word qui ne supporte pas le mixte mise à jour + modules complémentaires sans devenir un plantodrome.
Encore un programme de chez Microtruc…

Oui, certains problèmes peuvent venir de là, mais d’autres non…
Pour le service, je compte bien y aller, mais j’ai pris pour habitude, justement pour éviter les boulets, d’y aller avec des billes techniques, pour bien leur faire comprendre que je suis pas monsieur Bobo… D’ailleurs, mon revendeur croit toujours que je suis avocat… Allez comprendre…

Déjà fait, déjà annoncé… Je n’utilise aucun logiciel bizarre, je ne lance rien d’exceptionnel au démarrage, et il est même très lent, d’après vos expérience, avant l’écran de connexion. Hors, il ne fait rien entre le démarrage et cet écran (sauf les services systèmes, qui à priori n’ont pas changé depuis l’install).

Non. Logiciels hors de cause car même sans les lancer, les symptômes apparaissent. Ou alors je comprends plus car même avec seulement Mail de lancé, j’ai un problème.

Bon, je le dis une dernière fois, car j’ai beau le dire, personne ne semble le voir…
Les problèmes de lenteur apparaissent avant même le chargement des applications.
Les problèmes apparaissent même avec seulement les applis Apple (Mail) et 2 autres applis à priori fiables (Firefox et Thunderbird). Même avec seulement Mail je suis convaincu de voir apparaître les problèmes. Pour plus de sûreté, je peux couper le lancement d’Adium et Growl, mais encore une fois, ça n’explique pas la lenteur du démarrage.
Ensuite je n’ai aucune application exotique. J’ai des applications gourmandes (Eclipse, Office, Parallels), mais les problèmes apparaissent avant même de lancer ces applis.
SVN pourrait aussi être une cause, en lien avec Spotlight. Mais j’ai eu les problèmes avant d’installer SVN.
Et puis au cas où, je le répète, d’après vos infos, le problème de lenteur apparait au chargement du système, et non au chargement des applications une fois loggé.

Bien sûr je peux me tromper, mais j’ai traqué assez de défauts de matériels pour avoir une bonne idée de quand un logiciel n’est pas en cause.

Pour moi il y a 3 possibilités :

  • C’est l’état normal du système, et dans ce cas, OSX est bien plus lent qu’un Windows sur une machine plus légère
  • Le disque dur est trop lent. Pourtant c’est un 5400 RPM, disque classique d’un portable, et je n’ai jamais eu de problème de lenteur sur d’autres portables avec ces mêmes disques
  • Le disque est défecteux. Si c’est le cas, ça peut expliquer pas mal de choses. Cependant, ce ne sera pas facile à vérifier sans logiciel prévu pour, car il ne fait aucun bruit bizarre.
  • La mémoire est défectueuse. Dans ce cas, une hypothèse (simple hypothèse, je n’ai aucune connaissance de la façon dont OSX gère la mémoire) pourrait qu’au lieu de prévenir qu’il y a un défaut, OSX va utiliser silencieusement le SWAP pour corriger le défaut, et les accès disques répétés peuvent ralentir le système, même si le disque est en bon état. Connaissant la politique d’Apple, mon hypothèse peut se tenir… Mieux vaut se taire que de devoir remplacer une barrette :wink:

Dans tous les cas, il faut un logiciel qui teste le matériel, au moins le disque et la mémoire. Il en existe des tonnes pour Linux et Windows, en existe-il pour OSX ?

PS : oui je sais, ça fait 4, mais je suis fatigué…

Le problème c’est qu’au premier appel, c’est toi qui risque de tomber sur monsieur Bobo, justement C’est pour ça que je me dis qu’autant voir ça carrément avec eux, parce qu’essayer de comprendre et ensuite d’expliquer ce que tu a compris, c’est franchement galère, j’ai déjà donné avec un Compaq, dans le temps. Il faut juste garder dans l’idée que ce n’est pas normal et que ça doit se régler. A eux de trouver la solution donc.

Ben je t’avouerais que je trouve déjà ça “exotique” Eclipse, SVN et même Parallels (avec un peu de mauvais esprit je pourrais même en dire autant d’Office). J’ai toujours peur qu’un truc comme Parallel te lance des trucs dans le dos pour pouvoir charger son winchose.

Ca j’y crois pas une seconde, pour ce que j’en ai vu chez moi, et maintenant chez ma copine sur son Ibook.

J’ai du mal à le croire aussi. Je pense que le Powerbook et l’Ibook de la maison sont aussi des 5400 et on a rien constaté de tel.

Ca serait possible.

Là aussi, ce serait possible.

C’est vrai que je ne sais pas où trouver ça. Je me demande si OSX n’a pas des outils pour vérifier ça par lui-même. Pour le disque en tout cas, s’il était défectueux tu aurais peut-être des erreurs disque (à vérifier avec l’utilitaire disque ou en redémarrant sur le DVD d’OSX carrément et en lancant l’utilitaire disque depuis le DVD.

Et si tu retires la barrette de ram que tu as ajoutée ?

En même temps on peut pas dire que tu sois du genre objectif dès qu’il s’agit de Microsoft…
Et Parallels moi je m’en sers pour lancer Linux… :o

Un disque défectueux n’entraine par forcément des erreurs disque. Les systèmes actuels savent récupérer un bon nombre d’erreurs. Sur Windows par exemple, il faut vraiment un sacré problème de disque pour que ça se voit. Et en général, ça se voit dans l’état SMART aussi…

J’ai éteint mon Mac en partant du taff.
Fermeture de la session : 40"
Roue qui tourne : 40"
Total : 1’20"

Et redémarrage. J’ai désactivé le lancement auto de Growl et Adium pour voir :
Chargement du système (jusqu’à l’écran de connexion) : 45".
Première connexion : 32". Je me suis ensuite retrouvé à l’écran de connexion sans raison
Seconde connexion : 8". Y’a eu des vibration de l’interface (pas du matériel, vraiment l’interface)
Troisième connexion : 20". Plus rapide que l’ancienne, mais total de 1’
Arrête de grattage du disque : 1’08"
DashBoard : 15"…

Ça me divise la RAM par 2… :ane:

J’ai pas essayé ça. Ça me pose toujours un problème de le faire, s’il existe un indicateur qui peut faire sauter la garantie…

Ah ? Tu l’as eu avec deux barrettes direct (Applestore donc)…
Pour ce qui est de diviser la ram par deux je peux te dire que l’Ibook de ma copine démarrait à une vitesse tout à fait correcte avec seulement 512 de Ram (ensuite je lui ai fait manger une deuxième barrette de 512 et il est très content :wink: ). En fait je ne pense pas que ça joue sur le démarrage tant qu’on ne tombe pas encore plus bas.

Sinon j’ai trouvé un programme qui peut, entre autre, tester la mémoire apparemment dans OSXFacile.
Voilà le lien de téléchargement. D’après OSXFacile il est valable pendant 30 jours à l’essai.

Nouvel arrêt après seulement 10 minutes d’usage : 20" au total.

Et nouveau démarrage :
Chargement du système : 45"
Chargement de la session : 35"
Grattage du HDD : 1’30"

L’arrêt d’Adium et Growl semblent avoir un sacré effet… Mais en même temps, 3’ pour charger un système, mais sans aucune appli qui se lance automatiquement, c’est loin d’être exceptionnel.

Pour la RAM, j’ai regardé sous la batterie, il faut dévisser un bloc non ?
Je préfèrerai un logiciel de bench par exemple, pour comparer à des tests similaires avant d’essayer les modifs matérielles.