Forum Clubic

Débuts en vrac (page 12)

Petit rappel, les portables sont rarements fournis avec des disques dur 2"1/2 de 7200 Tours/mins.

Notamment dans le cas d’un MacBook, c’est un disque dur de 5400 tours/minutes, à technologie perpendiculaire. Je précises ce dernier point car les benchmarks de ces nouveaux types de disques ont montrés qu’ils sont moins performats que les disques classique, mais (malheureusement?) c’est “l’avenir” du fait que ca permet d’augmenter considerablement la densité par plateau et donc la capacité des disques portables à nombre de plateaux égal.

Bref, il est donc parfaitement logique de constater une nette amélioration des performances avec un disque externe, surtout si ce dernier (je penses que cela doit être ton cas), est un 7200 tours/min, et encore plus s’il n’utilise pas la technologie perpendiculaire, mais l’ancienne (plus performantes, mais offrant une moins bonne densité).

EDIT: pistes pour regler ton problème mises dans le post suivant finalement.

Merci pour ces infos :slight_smile:
Encore faut-il que je trouve un pool non négligeable de personnes qui ont le même temps. Pour l’instant, je n’en ai trouvé aucune…
Pourtant, les benchs de mon disque sont équivalents aux autres…

Il y a plein de contradictions dans les réactions de mon Mac. Je n’arrive pas à trouver une hypothèse qui se tient par rapport à tous les symptômes…

J’ai regardé ta video, et ton temps de boot est anormal, surtout l’ecran gris avant l’apparition de la pomme, normalement il ne dure pas plus que quelques secondes (moins de 10 secondes).

Voici des pistes pour que tu résolves ton problème:

Tu as visiblement une erreur de configuration de démarrage… On a l’impression que ton ordi cherche à démarrer sur un autre disque ou en réseau avant de booter réellement sur le disque dur.
Vérifis donc de bien selectionner ta partition de boot de ton disque interne dans “démarrage” des préférences système et de redémarrer.

A noter que si cela ne résoud pas ton problèmes, et que le reset de la PMU, et de la NVRAM non plus, il se peut que ton disque soit corrompu (soit au niveau du filesystem, soit au niveau de la table de partition, soit physiquement, soit une combinaison de cela).
Dans ce cas:

  1. Verifie l’etat du filesystem. Le mieux pour ca est encore de demarrer en single user (maintenir Pomme + S à l’allumage de l’ordi, jusqu’a voir un ecran de boot style demarrage d’un Linux en mode console), et de faire un “fsck” (les instruction pour realiser cette operation son indiqué dans la console de boot en single user une fois le boot terminé et que cela te donne la main)
  2. Essayes de réinstaller le système en reformatant et reinstallant proprement (faire un backup avant).
    Si malgré cela le problème persiste, alors c’est plus grave, et cela necessitera un retour en SAV.

Avant de réessayer le redémarrage depuis le disque interne depuis les préférences, je vais donner des précisions :

J’ai fait un reset de la PMU, on me l’avait conseillé plus haut.
J’ai fait un clone de mon système, puis j’ai formaté le disque dur (formatage bas niveau), puis j’ai remis le système dessus. Aucune amélioration.

La suite toute à l’heure après les deux trucs à tester, le choix du disque (d’après la config, ça m’a l’air bon pourtant) et le fsck…

Un autre truc aussi, verifis que tu as toutes les mises à jour ddu firmware EFI et SMC d’effectuées.

Une question egalement, avec un système tout propre (et non une recopie de ton installes actuelles), installé après repartitionnement et reformatage du disque, ca le fait aussi?

Si après toutes les verifs que j’ai listé, ca fait toujours ca, alors y’a un truc qui deconne au niveau materiel je penses, et dans ce cas donc retour SAV.

Ta manip a bel et bien accéléré l’affichage de la pomme. Merci :slight_smile:
Pour le reste, rien n’a changé.
Au niveau des mises à jour, la seule que je n’ai pas faite, c’est une MAJ pour Airport…
À moins que les MAJ dont tu parles ne soient pas automatiques, auquel cas je ne sais absolument pas comment les faire, ni même comment savoir si elles existent… :confused:

Et pour le retour SAV, j’aimerais avoir des choses à leur dire quand même. Si j’arrive avec juste une impression, ils peuvent très bien répondre qu’il s’agit de l’état normal du système, et je ne pourrai pas les contredire… :frowning:

J’ai également regardé la vidéo . Le temps avant l’apparition de la pomme (c’est à dire l’initialisation) est beaucoup trop long c’est totalement anormal . Tu dois avoir un problème matériel.

Ton ordinateur met quasi une minute de plus pour arriver à l’écran de login que le mien alors que les processeurs sont identiques et que tu as plus de ram que moi.

[pensée à haute voix]
J’en viens à me demander si ce ne serais pas un problème dans la ram, car le temps d’initialisation est beaucoup trop long.
-Est ce possible d’enlever une barrette de ram sur un mac pro ou sont elles soudées ?
-As tu essayé de démarrer avec un cd quelconque ; n’importe lequel ; dans le lecteur dvd de ton Mac pour voir s’il y a une différence ? car j’ai eu une fois le cas d’un ordinateur qui avait du mal à l’initialisation car le lecteur dvd répondait mal (il bloquait le démarrage une bonne vingtaine de secondes) par contre je ne sais pourquoi quand il y avait un dvd dedans au démarage le problème disparaissait.
[/pensée à haute voix]

Bon non à mon avis y’a pas besoin de retour SAV avec ce que tu viens de me dire. Enfin si tu me confirme que la pomme grise s’affiche bien maintenant en quelques secondes (moins de 10 secondes).

Sinon pour accelerer l’autre periode un peu lente que j’ai detecté, qui est celle avant l’apparition du fond bleu puis de la gauge de chargement (chargement de MacOS X…). Tu peux essayer celà:

  1. Aller dans /Système/Bibliotheque (/System/Library sous le terminal)
  2. Effacer les fichiers: "Extensions.kextcache" et "Extensions.mkext"
  3. Redemarrer

Après cela, le premier boot immediatement apres l’effacement des fichiers sera plus long, car il doit reconstruire les caches des extensions noyaux.
Mais les boot suivants devraient ensuite être au moins égaux sinon plus rapide (esperons le) à ce que tu constate actuellement.

Pour les mises à jours des firmware, voici les versions que tu devrais avoir (je donnes pour tous les MacBook Pro ne sachant pas si tu as un CoreDuo ou Core2Duo (et j’ai pas trp fait gaffe si c’etait un 15" ou un 17")):

MacBook Pro CoreDuo 15":

  • Version de la ROM de démarrage (firmware EFI): >= MBP11.0055.B08
  • Version SMC: >= 1.2f10

MacBook Pro CoreDuo 17":

  • Version de la ROM de démarrage (firmware EFI): >= MBP12.0061.B03
  • Version SMC: >= 1.5f10

MacBook Pro Core2Duo 15":

  • Version de la ROM de démarrage (firmware EFI): >= MBP22.00A5.B00
  • Version SMC: >= 1.12f5

MacBook Pro Core2Duo 17":

  • Version de la ROM de démarrage (firmware EFI): >= MBP21.00A5.B01
  • Version SMC: >= 1.14f5

Pour voir les versions que tu as, il faut aller dans:

  1. Menu Pomme -> A propos de ce Mac
  2. Cliquer sur “Plus d’informations”
  3. Dans la fenetre d’Informations Système qui s’affiche, selectionner “Materiel” dans la liste à gauche
  4. Regarder les lignes "Version de la ROM de démarrage" et "Version SMC".

Si tu preferes, donnes moi tes versions ici, et je te dirai si c’est bon.
Cela dit, si tu as un MacBook Pro Core2Duo, il n’y a pas eu à ma connaissance de mises à jour firmware.

Ce truc là je le note quelque part ça peut toujours servir :ane:

J’ai les bonnes versions de firmware… :frowning:
J’ai fait la manip, mais je n’ai pas encore eu l’occasion de tester les effets. Je le ferai tout à l’heure.
Merci en tout cas, j’apprends beaucoup de choses… :smiley:

Très bien, moi je mettrais plutôt ce smiley dans ce cas: :slight_smile:

Et tu m’as pas dis si effectivement maintenant la pomme grise apparait en quelques secondes? Car tu devrais déjà avoir gagné 30 secondes environ si je ne m’abuse au vu de la vidéo. Ce qui fait une différence loin d’être négligeable.

Un petit commentaire sur ton temps de boot, à partir du fond bleu (peu avant le “Demarrage de MacOS X…” avec la gauge), il me semble parfaitement normal. C’est avant que je trouve cela anormal (l’ecran gris sans pomme qui tardait (visiblement c’est resolu maintenant), et l’ecran gris avec la pomme qui tarde également un peu (mais c’est moins pire que le prob precedent que nous avons résolu)).

Bon alors la première manip m’a fait gagner 15 secondes…
La seconde manip n’a rien changé :frowning:

Au lieu d’arriver au bureau en 1’55", il y arrive en 1’40"…
On est loin des 30" dont on me parle souvent ici… :frowning:

Un dernier test serait de tester avec un OS fraichement installé, sans aucune appli lancé au demarrage de la session, ni application tierces d’installer, voir s’il met 30" (apres 2 ou 3 boot, car le premier boot apres l’install y’a toujours la generation des caches).

Si cela met toujours longtemps à démarrer, alors y’a certainement un problème materiel quelque part, sinon, c’est un problème soft.

Ça, ça va pas être facile… :confused:
Sauf si on peut repartitionner un disque Mac sans perdre de données ?

Non. Mais fait un backup complet avant.

Bon, ben ce sera pas pour tout de suite alors…
Merci pour ton aide en tout cas :slight_smile:

Une autre piste que tu peux explorer est de démarrer en mode Verbose, c’est à dire qu’il t’affiche tous ce qu’il fait en démarrant (démarrage en mode console dans ce cas). Et ainsi tu peux eventuellement detecté sur quoi il “perd” son temps.

Pour démarrer dans ce mode, il faut maintenir les touches Pomme et V (Pomme+V) au démarrage du Mac (juste après l’allumage donc).

Avec un GUI et gratuitement, non, mais il y a des sharware pour ça
iPartition notamment qui a fait parler de lui dans le Hack de l’Apple TV
Bien entendu pour ça il faut que tu aie une faible occupation de la partition unique pour repartitionner sans gros risque,
mais effectivement vaut mieux faire un backup
le mode verbose oui, mais tant qu’à faire autant passer en mode single user (Pomme-S au boot)
et effectuer la réparation du disque dur depuis ce mode

/!\ attention clavier QWERTY /!\
Pomme-S
Base OS Boot
Prompt pour un fsck qui bouclera jusqu’à ce qu’il n’y ait plus de soucis
prompt pour le mount
et pour continuer le boot vers OSX GUI un ou deux Control-D

par la suite quand tu reviendras en mode single user, tant que tu n’auras pas réinstallé l’OS, l’historique des commandes sera conservé (historique du Shell Root en fait)
Donc le plus naturellement du monde tu pourra utiliser la flèche vers le haut pour remonter dans les commandes précédemment saisies
Pratique justement à cause du clavier QWERTY

Mon conseil, ce serait de backuper puis calmement de faire une clean install de zéro en évitant d’installer les composants bas niveau dans un premier temps

une fois que tu as tous tes softs “haut niveau” installées (Photoshop, Word, smultron, mais pas le composant svn que j’ai vus évoqué plus haut, par exemple car il touche déjà aux couches proches du système)
Backup (c’est un peu le souci dans ton cas : avoir des disques durs (même partitionnés)) pour faire des backups propres

Ensuite à chaque fois que tu installes un composant qui te demande une autorisation (installeur, copie dans les dossiers systèmes, effacement de fichiers système, comme des kext, des fichiers caches, etc.)
d’effectuer une réparation des autorisations

Donc en suivant cette règle du backup clean install test, backup de ce qui marche ou retour en arrière tu devrais trouver ce qui cloche.

mais globalement ce sera souvent dans ton cas un problème de composants PPC only qui se doivent de lancer Rosetta, ou des composants qui sont obsolètes (compilés avant 10.4 qui à cassé pas mal de compatibilité)

Trucs de geek :
Megazoomer[/url] pour maximiser les fenêtres des applications cocoa “à la windows” (Pas Finder, pas FireFox, pas Prefpane, pasiTunes, mais QT, [url=http://www.clubic.com/telecharger-fiche38283-safari.html]Safari et plein d’autres apps)
GeekBind pour déplacer les fenêtres sans se soucier du focus (déjà possible en click maintenu avec Pomme) mais surtout sans avoir à viser ou accès à “la zone haute” de la fenêtre
le déclencheur étant une combinaison de touches configurable.
=>pratique pour des comparaisons côte à côte.
TinkerTools pour activer des options présentes, mais inactives dans OSX (quitter le Finder, désactiver les effets, afficher les fichiers cachés, etc.) (gratos)
TinkerTools System version avancée et payante qui s’occupe de fonction plus sensible et de nettoyage optimisation en tout genre.
il y a Onyx, mais je n’ai jamais trop eu confiance

je continuerais plus tard

c’est pas pomme+s pour le single user ?

Ah oui m**de t’as raison…
chui vraiment à l’ouest faut que j’arrête de pas dormir moi