Forum Clubic

Un débutant vous demande de l'aide ! - Carte WIFI D-LINK récalcitrante

Allez, hop ! je me lance dans l’aventure Linux pour ne pas mourir idiot… Après une install sans problème avec un Dual-boot XP/Mandrake 10.1, j’arrive sous KDE.

Mon problème est le suivant : Ma carte wifi DLink est reconnu par le système (dans HardDrake) mais quand je veux configurer le réseau sans fil, Mandrake me demande d’installer manuellement les pilotes.

Après quelques reboot sous XP pour chercher la solution, je tombe nez-à-nez avec ndiswrapper. Décidé à persévérer, je suis la procédure indiquée : Installation du kernel qui va bien, installation de ndiswrapper. Impec… Là où çà coince c’est quand je lance la commande

ndiswrapper -i gplus.inf

le programme me retourne le message suivant :

Il a bien créé un répertoire sous etc/ndiswrapper qui s’appelle gplus… Mais rien dedans… J’ai également essayé avec les drivers Win2000 (airplus) dispo sur le site de d-link… Rien à faire…

Auriez-vous une solution à me proposer ? Merci d’avance.

il faut que tu sois dans le répertoire qui contient ton ficier gplus.inf et que dans ta ligne de commande tu tapes bien le nom entier :

ndiswrapper -i gplus.inf

J’ai avancé : en fait, je tapais le nom du pilote (.inf) en minuscule au lieu de le taper en majuscules… Comme quoi, il suffit de pas grand chose…

Ensuite, j’ai fait

$ modprobe ndiswrapper

Malheureusement, quand je tape iwconfig, wlan0 n’apparaît toujours pas… Est-ce normal ? Ais-je manqué quelque chose ? Merci pour vos réponses.

tape dmesg et regarde si ndiswrapper a bien chargé ta carte
ndiswrapper -l te donne quoi ?
Quel est le nom exact de la carte ?

après dmesg, la ligne à rechercher ressemble à quoi ??? Parce que franchement, çà commence à devenir du chinois… :frowning:

ndiswrapper -l m’indique que le driver est correctement installé.

Le nom exact de la carte est D-Link DWL-G520+…

Merci encore pour votre aide !

Un truc du genre :

wlan0: ndiswrapper ethernet device xx:xx:xx:xx:xx:xx

ifconfig wlan0 up
iwlist etc…
A une époque, il y avait un post recherchant des outil graphique pour configurer le wireless. Mais je ne sais pas trop ce qu’il est devenu.
Faudrait faire une recherche un de ces 4 :slight_smile:

Allez, je progresse un peu (désolé pour le retard… Les vacances m’ont éloignées de mon PC chéri)…

quand je tape ndiswrapper -l, le message suivant est renvoyé :

gplus driver present, materiel present

Cool ! Maintenant, je fais modprobe ndiswrapper… No problemo… Je passe à l’étape suivante : dmesg. Là, après tout un baratin, je localise la ligne correspondant à mon matos à l’aide du numéro 00:0c.0. Mais une erreur est affiché un peu plus bas. J’essaierai de récupérer l’historique de la console pour la recopier ici mais vu la difficulté de passer de EXT3 à NTFS…

Sinon, si je fais ifconfig, il me renvoie les interfaces lo, eth0, eth1 et e1394… J’essaierai aussi de vous donner de plus amples infos un peu plus tard. Enfin, après avoir fait iwconfig, il renvoie les mêmes interfaces lo, eth0, etc… en me disant qu’aucun périférique wireless n’a été identifié. Et bien entendu, je n’ai pas de wlan0…

Je me suis servi de cette page pour faire les manip : http://forum.hardware.fr/hardwarefr/OSAlte…jet-44336-1.htm

Merci encore pour votre aide !

Le pilote madwifi ne fonctionne pas ??? Il me semble que Dlink utilise une puce Atheros non ? Si c’est le cas, je ne comprends pas pourquoi tu cherches à utiliser ndiswrapper au lieu du pilote Linux.

je crois bien que t’as raison http://lea-linux.org/drivers/rub.111.html

non, le chipset de la carte réseau (DWL-G520+) est le acx111 de Texas Instruments… :neutre:

http://www.gentoo-portage.com/net-wireless/acx100

Bah çà existe aussi pour l’acx111 apparement.

Cool je teste çà ce soir et je vous dis quoi !

Merci pour votre aide !!! :bounce:

Yop ! j’ai dû manquer un épisode, là !! :pt1cable:

Je suppose que le lien que tu m’as donné contient les sources des drivers… Mais… mais… comment je fais pour les installer sous Linux ???

Bah, oui, je vous avais prévenu : je suis un ignare en la matière !!! :paf:

à tout hasard essaie “modprobe acx100” ptetre que c’est déjà compilé

Sur une Mandrake, il faut déjà commencer par récupérer les sources du noyau.

Ensuite tu télécharges les sources du pilote :
http://rhlx01.fht-esslingen.de/~andi/acx100/

Et tu lis le readme pour l’install.

Très souvent çà ressemble à çà :

./configure
make

+1
Ou il existe p-ê un paquet rpm mdk tout prêt aussi.

Yop ! Merci beaucoup de votre aide mais…

finalement, je suis passé sous Mepis3.3 et vous savez quoi ? Ma carte WIFI a été reconnu directement par le live-CD et idem après installation ! Me voilà donc un heureux utilisateur de Nunux !! :wink:
:bounce:

Bon maintenant les choses sérieuses, tu vires tout et tu installes une Gentoo :paf:

edit : Je déconne :wink:

Ouais ou alors Debian on est sympas on te laisse le choix :o :slight_smile: