Forum Clubic

Probleme sortie HDMI carte graphique

Bonsoir a tous et a toutes,

Je possède un ampli DENON AVR-1911 avec un kit FOCAL SIB & CUB 5.1, que j’ai relié a mon PC, via la sortie optique de ma carte mère (une ASUS P7P55D). J’ai appris que je pouvais faire passer le son par la sortie HDMI de ma carte graphique (une Sapphire HD 5770 1Go Vapor-X). Cependant, j’ai un problème, lorsque je branche ma carte graphique a mon écran PC en HDMI, en passant par mon ampli ou non, je ne peux pas avoir une résolution de 1920x1080. La n’est pas le problème car je suis actuellement connecté a mon écran en DVI Dual Link, et je peux bénéficier du 1080p. Je voudrais simplement faire passer juste l’audio par mon ampli, avec la sortie HDMI, mais le problème, c’est que lorsque je branche mon écran en DVI et mon cable HDMI a ma CG, tout plante, je n’ai accès qu’a mon fond d’écran et au clic droit (je précise que rien ne se passe), tout redeviens fonctionnel lors de la déconnexion de l’un des câbles.
Je voudrais faire passez la vidéo en DVI et l’audio en HDMI. Les avantage du HDMI ne sont pas négligeables par rapport à l’optique (192kHz au lieu de 96, et la détection de TOUS mes haut parleurs, pas juste du stéréo, comme c’est en cas en optique). Quand j’aurais les moyens, je me prendrai une ASUS Xonar HDAV 1.3, mais pour l’instant, je ne peux pas (je précise que je suis étudiant).

Comment pourrais-je désactiver la vidéo en HDMI, pour ne garder que l’audio ? J’ai déjà fait des recherches, mais je n’ai rien trouvé. Ou peut être que quelqu’un a une autre solution ? Un réglage dans l’ampli ?

Je vous remercie beaucoup. Bonne soirée a tous et a toutes.

Rodgers.

Bonjour,

Comme je te l’ai déjà dit, à mon avis il vaudrait mieux commencer par régler ton problème d’affichage, ça t’éviterait de faire toutes ces manipalakon qui ne servent à rien. Mais bon, c’est vous qui voyez… :wink:

A mon avis c’est normal :
Si tu branches deux câbles vidéos, ta carte graphique croit être connectée à deux écrans, et elle doit donc passer en mode “étendu”, d’où l’affichage du fond d’écran sans Barre des tâches ni icônes.
Il faudrait donc essayer de passer en mode “clone”.

Le DVI ou le HDMI, sur un PC, c’est exactement la même chose donc, encore une fois (la dernière ;)), je pense que tu te compliques grave la vie pour rien. :neutre:
Edité le 02/12/2011 à 01:15

Ça fait plus d’un an et demis que j’essaie, je ne peux absolument rien faire, je tout essayé. Ça doit être un problème matériel a mon avis, donc je ne peux absolument rien y faire, et c’est bien dommage, car ça me simplifierai bien la vie, comme tu l’as dis.

Je vois très bien ce que tu veux dire, mais je n’ai accès a rien du tout. De plus, je ne pense pas que se soit le probleme, car quand je branche mon câble HDMI directement a mon écran, le rendu en étendu est différent.

Et que puis-je faire alors ?
Message edité le 02/12/2011 à 01:16

Perso, à ta place, je commencerai par tenter encore une fois de régler le problème d’affichage.
C’est-à-dire téléchargement du dernier driver pour la CG, désinstallation du driver actuellement installé, reboot, deux ou trois passages de Ccleaner, installation du dernier driver pour la CG téléchargé précédemment.
Après ça, tu devrais enfin pouvoir passer du 1080p60 sur la sortie HDMI, et donc connecter la sortie HDMI sur une des entrées HDMI de l’ampli et la sortie HDMI de l’ampli sur l’entrée HDMI du moniteur.
Edité le 25/11/2011 à 21:47

J’ai deja fait tout ça, mais je vais réessayer quand j’aurais le temps.
Sinon, peut etre qu’en désactivant la video en HDMI sur mon ampli, ca fonctionnerai.
Merci de tes conseils.

D’autres idees ? Merci

Rodgers
Edité le 25/11/2011 à 21:58

Si tu as un adaptateur DVI/HDMI, tu peux essayer de brancher la sortie DVI de ta CG sur une des entrées HDMI de ton ampli, et la sortie HDMI de l’ampli vers le moniteur.
Edité le 25/11/2011 à 22:04

Il me semble que l’audio ne passe pas par le DVI, mais peut être que je me trompe ?

Oui.

Non il ne se trompe pas, il n’y a pas de son par le DVI-D.

C’est pas compliqué : branche tout en HDMI (voir avec un HDMI-DVI entre l’ampli et le moniteur si besoin est).
Et règle ton écran…

Note : et ça ne sert toujours à rien de prendre une carte son supplémentaire vu que tu l’as déjà sur ta carte graphique.
Edité le 01/12/2011 à 10:53

Les cartes graphiques savent sortir du son par le port DVI (en fait elles sortent un signal HDMI sur le connecteur DVI, pas très dur sachant que la seule différence entre HDMI et DVI c’est la forme du connecteur)

C’est pas plutôt l’inverse ?
Le DVI-D et l’HDMI ont le même signal vidéo, l’HDMI a quelques broches en plus pour le son. Pas très dur de comprendre pourquoi les constructeurs ont ajouté des connecteurs HDMI sur leur carte graphique au lieu de mettre des adaptateurs DVI-D>HDMI comme ils l’ont fait avec les adaptateurs DVI-A>VGA à une certaine époque.

Ex : www.materiel.net…

Exact, pas de son sur les DVI de toutes sortes ( www.hardwarebook.info… )

Son et vidéo sont véhiculés par les même signaux.
Sur DVI et HDMI le signal est numérique et transmis en série (les bits à la suite les uns des autres) sur 3 paires différentielles (ou 6 pour le DVI dual-link).
A la base le DVI ne transmet que la vidéo sous forme de paquets de données avec des pauses entre chaque ligne (horizontal blanking, un peu comme en analogique en fait). Quand le HDMI est sorti l’idée a été d’exploiter ces “trous” pour y mettre des infos supplémentaires comme le son, garantissant en théorie une certaine compatibilité avec le DVI (sauf que certains écran DVI anciens supportent mal d’avoir autre chose que de la vidéo dans les paquets de données, sans doute dûe à une implémentation un peu “rapide” du protocole DVI).
Edité le 01/12/2011 à 15:43

En attendant, y a toujours pas de son quand on utilise un câble DVI vers HDMI (qui d’ailleurs est normalement interdit à la vente vu qu’il ne respecte pas la norme prévue).

PS : j’ai quand même quelques petites notions de transmissions de signaux, merci :whistle:

Ben si, les CG sortent bien du son sur la sortie DVI, sinon je n’aurais pas proposé d’utiliser un adaptateur DVI/HDMI. :wink:

Bien sûr que si !
Et heureusement car c’est le seul moyen qu’il me reste pour avoir du son sur mon PC vu que Windows refuse d’installer les drivers du chipset audio de ma carte mère. :frowning:


[quote="Palou"] Exact, pas de son sur les DVI de toutes sortes ( [www.hardwarebook.info...](http://www.hardwarebook.info/Digital_Visual_Interface_%28DVI%29) ) [/quote] L'audio et la vidéo étant véhiculés par les mêmes broches du connecteur DVI, on ne peut pas savoir avec le brochage du connecteur si la CG transporte ou non le son sur sa sortie DVI. Pour cela il faut regarder les caractéristiques de la CG elle-même données par le fabricant. ;) Edité le 02/12/2011 à 01:25

Et vu qu’au bout de ce câble avec prise DVI il y a un écran qui ne comprend pas le langage audio …

Apres vérification, le DVI ne transporte pas de signal audio, uniquement un signal vidéo numérique

Rodgers

Sauf que d’une part c’est faux puisque cet écran comporte des haut-parleurs et accepte tout à fait le son sur son entée HDMI, et d’autre part il est ici question de passer par l’ampli audio/vidéo avant d’attaquer l’écran en question…


[quote="Rodgers95"] Apres vérification, le DVI ne transporte pas de signal audio, uniquement un signal vidéo numérique

Rodgers
[/quote]
OK

Bonne chance pour la suite.
:hello:
Edité le 02/12/2011 à 01:50

En parlant de la suite, j’ai réussis a faire passer mon son par la sortie HDMI de ma CG. Il y avait effectivement un probleme, les sources etaient étendus, mais de manière différente qu’avec deux écrans (j’ai fais le test). En jouant avec les touches Windows + P, j’ai réussis a passer les deux sources en duplication. Je reste toujours avec la vidéo en DVI et l’audio en HDMI connecté a mon ampli (une pure merveille pour les jeux !!). Tout est nickel, je verrais quand j’aurais les moyens pour peut etre me prendre une carte son histoire d’avoir une meilleur qualitée audio (si ça en vaut la peine aussi). Reste plus qu’a me prendre une petite platine blu-ray ^^

merci a tous en tout cas et bonne soirée.

Rodgers

Et on retombe sur le même sujet que ton premier post…

Marre de tourner en rond des fois ?

www.clubic.com…
Edité le 02/12/2011 à 00:09