Forum Clubic

Problème RSS - Doublons

Abonné au flux RSS “Jeux Vidéos”, je reçois en une 50aine d’exemplaires (ou plus) chaque mise à jour qui concerne le jeu “Ankh, une aventure égyptienne”.

Y’a-t-il d’autres personnes confrontées à ce bug, voire mieux, une solution connue ?

Je précise bien entendu que c’est le seul jeu qui pose problème et ça marche impec aussi pour les autres flux, sinon ça ne serait pas aussi bizarre.

Merci d’avance

Blop, un ptit up, personne ne saurait ?

j’ai le meme prob sur le(s) meme article

Petite précision, au cas où ça puisse aider :

Win XP SP2, firewall désactivé
Thundebird version 1.5 (20051201)

Je suppute une incompatibilité entre la version de flux RSS utilisé et Thunderbird car il me semble avoir lu quelque chose à ce sujet sur les forums Mozillazine, mais ça reste bizarre que ça ne concerne qu’un seul sujet tout de même…

Une réaction de la team serait bienvenue ?

J’ai aussi des soucis avec cette news et quelques autres. La dernière en date étant a fin d’un joint-venture sur des écrans OLED. Là depuis 2 petites heures je recois à chaque fois les 23 dernieres news. Je ne sais pas vraiment d’où est ce que ca peut venir.

Pour info j’utilise aussi thunderbird 1.5.

En espérant que ces maigres infos puissent vous être utiles pour localiser la source du problème. :slight_smile:

Je suis abonné à une dixaine de flux RSS, et les autres n’ont pas ce problème.
( XP, thunderbird 1.5 )

Effectivement, la précision n’est pas inutile : je consulte également d’autres flux RSS qui fonctionnent sans problème.

Petit ajout au passage :
Les flux Clubic apparaissent en double (+ un flux “fantôme”)
De plus, il m’est impossible de supprimer les flux “Actualité”. Le bouton “supprimer” ne fait tout simplement rien.

http://img210.imageshack.us/img210/362/probrss4bv.th.jpg

C’est bizarre çà. De mon coté, pas de flux en double et je peux supprimer le flux sans aucun problème.
A noter que j’ai l’impression que la situation s’améliore par rapport à hier. :slight_smile:

Bon, suite à quelques lectures supplémentaires sur les forums Mozilla, j’ai mis de côté les articles qui m’intéressaient, supprimé le compte “Nouvelles et Blogs”, puis l’ai recréé.

J’ai ensuite remis les flux RSS, et les flux Clubic en trop ont effectivement disparu.

Je vous tiendrai au courant concernant les éventuels doublons, en espérant avoir résolu le problème.

Encore une petite note pour l’occasion : mes flux RSS (pas seulement ceux de Clubic) ne sont mis à jour qu’à l’ouverture de Thunderbird et pendant quelques temps ensuite.
Au bout d’un moment, je cesse de recevoir les mises à jour.

J’espère que ça va aussi arranger ça.

Je préciserai ici-même l’évolution de la situation, afin de clarifier si le problème vient de Clubic ou Thunderbird (puisque apparemment les forums Mozillazine recensent pas mal de soucis similaires).

Je confirme aussi, c’est un cas isolé parmi tous les flux rss que je reçois.

Par contre, il arrive parfois de recevoir deux versions d’un même flux rss (après correction d’un mot dans le titre), mais il est vrai que pour le jeu “Ankh, une aventure égyptienne”, j’en ai reçu un certain nombre, ainsi que le sujet suivant : http://www.clubic.com/forum/index.php?show…dpost&p=6319815

Re-belote avec Übersoldier…

faut que Clubic se reveille stout :slight_smile:

Est-ce que l’actu apparait en double dans le flux (celui qu’on vous envoit) ou est-ce un bug de Thunderbird ?

WiP :nico:

C’est une question pertinente… comment peut-on le vérifier ?

Regardez en cliquant sur le logo “RSS” (sur la page http://www.clubic.com/divers/partner.php
) du flux incriminé si l’information apparait deux fois. Si elle apparait deux fois, le problème vient de nous. Si elle apparait qu’une fois, de Thunderbird.

WiP :nico:

Donc Thunderbird, vraisemblablement… dammit

Même problème avec plusieurs sujets, régulièrement (ce matin ça commence avec "Faces Of War décalé aux États-Unis ?").

Pour info, Thunderbird 1.0.7 sous Linux-Gentoo. Grumpf.

++

Visiblement c’est un problème lié à Thunderbird étant donné que les doublons ne se présentent pas dans le flux RSS “brut”.

ça pourrait pas venir de l’encodage du fichier XML ?

C’est vrai que ça le fait sous thunderbird, mais ça ne le fait QUE sur clubic, et pas sur pcinpact, par exemple (désolé de comparer avec la concurrence :wink:

headers xml :

Clubic :

<?xml version="1.0" encoding="UTF-8" standalone="yes"?> <?xml-stylesheet title="XSL_formatting" type="text/xsl" href="/divers/rss/xslt.php" ?> ...

PCi :

<?xml version="1.0" encoding="iso-8859-1"?>

Quelqu’un confirme ?

K.

Pour info, nos flux sont valides : feedvalidator.org…

Dans nos entêtes, nous utilisons UTF-8 car tous les caractères spéciaux sont encodés au format unicode (la norme prenant en charge un peu toutes les langues du globe et assurant, théoriquement, la meilleure compatibilité) et nous avons une feuille de style pour que l’affichage soit plus sympa pour ceux qui n’utilisent pas un navigateur appliquant par défaut une feuille de style à lui (contrairement à Firefox par exemple).

WiP :nico: