Forum Clubic

Probleme partition magic 8

bonjour,

j’avais un DD en 3 partitions : E, F et H. ma partition E etait pleine, j’ai donc libéré de l’espace sur une autre partition. apres impossible de la rajouter sur E. j’ai donc fini par deplacer les donnees de F de la gauche vers la droite pour que la partie libre de la partition F soit a coté de la partition E. puis fusion des partitions E et F. ça a pris des heures a deplacer les données et faire tout ça puis terminé sans probleme d’apres partition magic 8. je le ferme, j’ouvre l’explorateur et là …
quand je clique sur E, il me dit qu’il faut le formater, donc plus d’acces aux donnees et si je formate encore moins. F lui n’a pas changé sauf que le disque est plein, c’est a dire qu’il a bien deplacé l’espace libre mais où ? bref la cata, je ne sais plus quoi faire pour recuperer mes données, mes partitions et mon espace vide qui n’est plus formaté… help !

merci par avance

laurent

Salut,

tu bootes avec une knoppix live,
knoppix-fr.org…

et tu verras déjà si tu peux accéder à tes fichiers.

Si c’est OK, je te conseille de brancher un DD externe et de tout copier dessus,
avant de faire des manipulations pour remettre au propre tes partitions d’origine,
avec Partition Magic ou le gestionnaire de disque Windows.
Au fait, tu es sous quel Windows ?

salut Murmel,

et d’abord, merci pour ta reponse. j’ai telecharger et graver knoppix et j’ai pas dû choisir le bon lien, c’est en allemand !

et sinon comment ça s’utilise pour voir l’arborescence de mes disques repertoires et fichiers ?

pour info, je suis sous xp

merci

Salut,

je suis en tain de télécharger la 6.0.1 en anglais (DE = Deutsch = Allemand, EN = English)

ftp.free.fr…

je la grave, je boote et regarde comment elle se comporte
(j’ai la version 5.1, actuellement), Pour cette version 5.1
Il faut appuyer sur Enter à la fin de l’écran de boot qui se termine par : (deux points, en bas de l’écran, mais c’est vrai que c’est mieux en anglais…)
Tu arrives sur le bureau Knoppix avec une fenêtre que tu peux fermer.
en bas à droite, près de l’horloge, tu cliques sur le petit drapeau jusqu’à mettre celui de la France.
Sur le bureau, tu vas voir des icônes de DD avec des noms style hda1 et/ou sda1, sda2, sdb1 etc…etc…
Ce sont les noms des partitions visibles.

tu cliques droit sur chacune pour choisir monter

Une fois qu’elles sont montées (une petite flèche verte apparait sur l’icone)
tu peux double-cliquer pour voir ce qu’elles contiennent.

J’espère que tu pourras voir tes anciennes partitions E et F et H

Bon, j’ai fini le téléchargement, je vais graver la 6.0.1

A+
Edité le 25/04/2010 à 17:12

oula !
pour info, au hasard, j’ai telechargé le fichier suivant “ADRIANE-KNOPPIX_V6.2.1CD-2010-01-31-DE.iso”
et ça doit pas etre pareil du tout. quand je boote dessus, je laises aller au bout, et j’arrive sur un menu en allemand comme un menu dos. mais pas de bureau avec icone, et je ne voi pas la barre avec l’horloge…

je suis un peu paumé en fait !

Bon, j’ai testé la 6.0.1, pas terrible

télécharge la 5.1.1 anglaise ici

iso.linuxquestions.org…

c’est parti, telechargement en cours…

Il fonctionne,

écran de boot, il faut appuyer sur ENTER
http://img638.imageshack.us/img638/9192/accueilg.th.jpg

puis la séquence d’initialisation se déroule.
La mis en place des pilotes graphiques pour l’affichage du bureau peut provoquer
des passages par des écrans noirs (ça m’en fait 3 ou 4)

puis tu as le chargement de l’interface du bureau KDE

http://img696.imageshack.us/img696/1528/kdeh.th.jpg

enfin, le bureau après avoir viré la fenêtre qui s’ouvre au milieu

http://img293.imageshack.us/img293/667/bureauh.th.png

donc, le drapeau français en bas à droite (pour mettre le clavier en azerty pour le mode console,
mais la langue du bureau est toujours l’anglais)
et toutes mes partitions sda1, sda3, sda5 et sdb1visibles à gauche.
clic droit sur chacune pour les monter, ou double-clic direct (une flèche verte apparait alors en bas de l’icone)

en bas, la partition sdc1 est une clef USB

http://img46.imageshack.us/img46/7286/mountp.th.jpg
Edité le 25/04/2010 à 18:51

super, j’ai fini de graver apres un plantage ! je test…

a+

et me revoilà !!!

alors avec la chance qui me caracterise, l’ecran noir dont tu parles cree une coupure definitive chez moi : le logo de mon LG flatron est affiché avec dessous “coupure” puis fini le cd arrete toute activité …

je craque ! c’est dommage c’etait bien parti comme sur tes captures d’ecran…

C’est sans doute dû à cette version déjà ancienne.
Ta CG ne doit pas être incluse pour les pilotes.
Mon PC est ancien (5 ans déjà)

au premier écran, au lieu de taper Enter, tu peux accéder à des options avec F3

Je te conseille d’aller voir par là s’il n’y a pas un truc du style mode sans échec,
ou avec basse résolution style 800x600

Sinon, il y a des tas de Linux Live
cherche linux live sur google et Clubic
Celle-ci doit être sympa
www.clubic.com…

Elle est sympa : je vois mes 3 partitions, 2 en NTFS et 1 en FAT32 plus une clef USB Kingston.
Faut cliquer sur la maison, c’est l’explorateur.

http://img443.imageshack.us/img443/2310/snapshot1r.th.png
Edité le 26/04/2010 à 08:47

salut,

alors j’ai testé et ja’i effectivement pu demarer en 800 x 600, donc pas de probleme acces à mes disques dont mes 3 partitioons invisibles sous XP. j’ai donc voulu copier mon repertoire de photos sur un autre DD pour les sauver avant un formatage, la copie s’est faite.

retour sous XP : aucun repertoire photo dans le DD où j’ai copié !!! aurais-je fais une fausse manoeuvre ? bizarre…

Cela veut sans doute dire que le format de tes partitions n’est pas reconnu par XP.
Mais c’est bizarre pour un DD externe.
Par exemple, si c’est du format LINUX pur, tu ne les verras pas sans passer par un utilitaire.

Peux-tu ouvrir tes images sous knoppix ou Mandriva ?

Es-tu allé dans Poste de Travail, Gérer
puis gestion des disques ?
Peut-être suffit-il d’attribuer ou changer la lettre du ou des partitions
que tu ne vois pas.
Edité le 26/04/2010 à 12:26

ja n’ai pas encore essayer d’ouvrir une image sous knoppix.

dans la gestion des disdues de Xp, je vois ceci pour mon DD invisible (donc en fait il le reconnait toujours !)

E: 31,92 Go sain et actif (c’est la fameuse partition où se trouve mes données)
F: 9,68 Go fat32 sain
28,79 G0 partition inconnue (c’est l’espace libre que je voulais rajouter à la partition E:)
H: 4,13 Go fat32 sain

je pense que cette parttition qu’il ne reconnait pas pose probleme et empeche de voir le disque entier…

tu ne peux pas supprimer la partition inconnue ?

Le problème, c’est que E n’a pas de format, alors que F et H semblent être en FAT32.

Essaie de changer les lettres de E,F et H pour voir l’effet dans l’explorateur

la partition inconnue est en vert maintenant (espace libre) et les lecteurs ont tous changé de nom mais pareil, quand j’essaie d’acceder au premier (ancien E) il demande si je veux formater…

E est visible sous Linux ?

mais quand tu copies les fichiers sur un autre disque dur sous knoppix,
tu ne vois pas non plus cet autre disque dur ?

Essaie de copier sous knoppix quelques fichiers sur une clé USB, pour voir ensuite sous XP.

Tu peux aussi installer et essaiyer explore2fs sous XP.

si si je vois l’autre disque sous knoppix et meme dessus le repertoire que j’ai copié !
c’est pour ça, je croyais que c’etait bon !

je vais essayerde copier sur une clé et essayer d’ouvrir une image aussi…

a tout à l’heure…

bon me revoila !

j’arrive à voir et a ouvrir une image sous knoppix sans probleme
par contre, j’ai copié 3 photos sur une cle usb, je les voyais bien sur la clé et sous xp, rien !

pour info, j’ai essayé avec des photo provenant du disque invisible et d’un autre disque sans probleme, les 2 fonctionnait.

il y aurait pas une commande pour confirmer ou valider ce qui a ete fait avant de quitter sous knoppix ?
d’autant que je sais pas comment on le quitte et que je reboote a chaque fois pour retoutner sous XP…


j'ai essayer expore2fs sous xp, quand je le demarre, l'explorateur est vide, je vais chercher des fichiers et repertoires mais si j'essaie d'acceder a la partition : voulez vous formater ? ...

normalement, tu as un bouton bleu en bas à gauche sur lequel tu cliques
(un K avec une roue crantée) avec une option Turn Off Computer ou quelque chose comme ça.
Là, c’est propre.

Il est fort probable que cette histoire de reboot à l’arrache ait des conséquences.
Il faut au moins faire clic droit puis umount sur les partitions et clés avant (ça équivaut à “Enlever en toute sécurité”)
Edité le 26/04/2010 à 14:08