Forum Clubic

Probleme avec une image - Enregistrement sous photoshop

Bonjour,

Alors moi enfaite j’ai un ptit probleme que j’arrive pas trop a comprendre. Je vous explique.

J’ai crée une image avec un fond transparent, un cadre avec les bout arrondi ( pour une page web ) quand j’enregistre l’image j’ai l’impression qu’elle a perdu de la couleur, et une fois inserer sur la page, le fond transparent et beige/brun

http://xtaz67.free.fr/

C’est pour cette raison que je demande de l’aide car je comprend pas trop… merci beaucoup d’avance !

Steve

:jap:

tu l’enregistres sous quel format?

Je l’enregistre en PNG, vu que le fond est transparent.

Ce message n’était pas conforme aux règles d’utilisation du nouveau forum :

:??: :??: :??: :??: :??:

Est ce que tu utilises la fonction "enregistrer pour le web"?

Oui et ca change rien :frowning:

Ca vient de quoi ?

Merci

:clap: Enfaite je l’ai enregistrer en GIF et al ca fonctionne, mais avec photo impact, parseque photo shop me propose pas en PNG lorsque je cree un fichier avec transparence !

C’est normal ?

:jap:

Non, ce n’est pas normal… Si tu fais “enregistrer sous”, tu as le format PNG qui t’est proposé, de même pour “enregistrer pour le web” :wink:
Si tu ne l’as pas, c’est que ton image n’est sûrement pas en RVB je pense.

Yes ! Merci beaucoup ca a marcher !

Parcontre il y a du blanc au arrondi… :o j’ai vraiment pa de chance

http://xtaz67.free.fr/

C’est sûrement parce que tu as converti ton GIF en PNG :wink:
Attends une seconde, je vais retirer ça.

Non je l’ai aps converti car le fichier GIF je l’ai fai avec ULEAD PHOTO IMPACT, et apres j’ai cree un nouveau fichier PNG comme vous avez dit avec PHOTOSHOp mais la ya du blanc sur les arrondi…

Ton PNG est en couleurs indexées, il faut que tu le mettes en RVB :oui:
Tu as toujours ton image originale ?

Bon, finalement je l’ai refaite :smiley:

http://delvin.chez.tiscali.fr/stock/logo6.png

Je l’avais pas mi en RVB c’etait bien en Indexé, je l’ai mi en RVB mais alors il y le fond beige a la place du transparent :stuck_out_tongue:

comme a votre que vous avez poster :slight_smile: :neutre: :neutre:

Je peux te garantir qu’il n’y a aucun souci de transparence alors :oui:
C’est à cause de IE qui ne gère pas la transparence des PNG, il faut attendre IE 7.0 pour qu’i le soit.
Avec Firefox, aucun souci :slight_smile:

Ah oui la votre marche parfaitement bien avec FireFox :slight_smile:

Donc enfaite il faut cree une nouvelle image et faut qu’elle soir en RVB ? et non en Indexeé ? et l’enregistrer en tant que image pour le web ?

Sinon en voilà une autre en GIF avec la transparence convertie en dégradé d’une couleur proche de ton fond:

http://delvin.chez.tiscali.fr/stock/logo8.gif

Voilà le résultat comparé à l’ancien:

http://delvin.chez.tiscali.fr/stock/logo8.jpg

Oui pour le format PNG pour concerver le dégradé de transparence. Pour “enregistrer pour le web”, c’est plutôt pour optimiser les GIF et les JPG, le PNG en 24 bits n’ayant pas d’options pour ça.

Vous avez fait qu’elle manoevre exactement pour cree logo6.png ?

car moi j’ai recree un nouveau fichier, et c’etait deja sur RVB et non en indexé mais il y a tjr les bord blanc :frowning:

Merci, dsl de vous deranger !