Forum Clubic

Paramétrage de samba

Bonjour,
Je viens d’installer Ubuntu server 13.10 pour me faire un petit serveur de partage de fichier, contrôleur de domaine pour la maison. J’ai donc installé Samba 3.6.18. Jusqu’ici, tout va bien.
Là où tout se corse, c’est lors du paramétrage du dit Samba. Il me semblait l’avoir correctement paramétré mais c’est marqué "Etat: inactive servers:winbindd Activé.
Je ne comprends pas. Du coup, y aurait-il quelqu’un pour m’aider svp?

En vous remerciant

Pas de panique!

source: web.mit.edu…

Donc c’est normal que winbind soit actif alors que l’état de samba soit à inactif.

Pour le reste as-tu appuyé sur le bouton vert ou as-tu pensé à allumer le serveur! Avec le luxe d’informations que tu donnes je ne vois que ça que tu aurais pu oublier de faire.

Cordialement


Peut-être que si tu nous indiques le tutoriel que tu as suivis pour configurer samba et ce que tu as fais , ton fichier de conf , ou les erreurs concernant samba signalés dans un fichier log , peut-être, je dis bien peut-être , que ça pourrait aider quelqu'un à t'aider.

Bonjour,

Alors, merci pour la réponse. Alors oui, j’ai bien appuyé sur le bouton vert :(.
Voilà ma configuration

[global]
netbios name = Serveur
server string = Samba file and print server
workgroup = maison.local
security = domain
hosts allow = 127. 192.168.1.
interfaces = 127.0.0.1/8 192.168.1.0/24
bind interfaces only = yes
remote announce = 192.168.1.255
remote browse sync = 192.168.1.255
printcap name = cups
load printers = yes
cups options = raw
printing = cups
guest account = smbguest
log file = /var/log/samba/samba.log
max log size = 1000
null passwords = no
username level = 6
password level = 6
encrypt passwords = yes
unix password sync = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
local master = yes
domain master = yes
preferred master = yes
domain logons = yes
os level = 80
logon drive = m:
logon home = %Lhomes%u
logon path = %Lprofiles%u
logon script = %G.bat
time server = yes
name resolve order = wins lmhosts bcast
wins support = yes
wins proxy = yes
dns proxy = no
preserve case = yes
short preserve case = yes
client use spnego = no
client signing = no
client schannel = no
server signing = no
server schannel = no
nt pipe support = yes
nt status support = yes
allow trusted domains = no
obey pam restrictions = yes
enable spoolss = yes
client plaintext auth = no
disable netbios = no
follow symlinks = no
update encrypted = yes
pam password change = no
passwd chat timeout = 120
hostname lookups = no
username map = /etc/samba/smbusers
passdb backend = tdbsam
passwd program = /usr/bin/passwd ‘%u’
passwd chat = Newpassword* %nn ReTypenewpassword %nn passwdchanged*n
add user script = /usr/sbin/useradd -d /dev/null -c ‘Samba User Account’ -s /dev/null ‘%u’
add user to group script = /usr/sbin/useradd -d /dev/null -c ‘Samba User Account’ -s /dev/null -g ‘%g’ ‘%u’
add group script = /usr/sbin/groupadd ‘%g’
delete user script = /usr/sbin/userdel ‘%u’
delete user from group script = /usr/sbin/userdel ‘%u’ ‘%g’
delete group script = /usr/sbin/groupdel ‘%g’
add machine script = /usr/sbin/useradd -d /dev/null -g sambamachines -c ‘Samba Machine Account’ -s /dev/null -M ‘%u’
machine password timeout = 120
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
template shell = /dev/null
winbind use default domain = yes
winbind separator = @
winbind cache time = 360
winbind trusted domains only = yes
winbind nested groups = no
winbind nss info = no
winbind refresh tickets = no
winbind offline logon = no

[homes]
comment = Home Directories
path = /home
valid users = %U
read only = no
available = yes
browseable = yes
writable = yes
guest ok = no
public = no
printable = no
locking = no
strict locking = no

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
read only = no
available = yes
browseable = yes
writable = no
guest ok = no
public = no
printable = no
locking = no
strict locking = no

[profiles]
comment = User Profiles
path = /var/lib/samba/profiles
read only = no
available = yes
browseable = yes
writable = yes
guest ok = no
public = no
printable = no
create mode = 0600
directory mask = 0700
locking = no
strict locking = no

[printers]
comment = All Printers
path = /var/spool/samba
browseable = yes
writable = no
guest ok = no
public = no
printable = yes
locking = no
strict locking = no

[pdf-documents]
path = /var/lib/samba/pdf-documents
comment = Converted PDF Documents
admin users = %U
available = yes
browseable = yes
writeable = yes
guest ok = yes
locking = no
strict locking = no

[pdf-printer]
path = /tmp
comment = PDF Printer Service
printable = yes
guest ok = yes
use client driver = yes
printing = bsd
print command = /usr/bin/gadmin-samba-pdf %s %u
lpq command =
lprm command =

Je cherche désepérement un tuto sans ligne de code si possible (vu que Samba a une interface graphique) qui soit simple mais c’est dur à trouver :-(:

Bonjour,

Il semble bien complexe ton smb.conf pour débuter avec Samba. :-(:

As tu reellement besoin d’un controleur de domaine @home ? Un ensemble de partages ne suffirait pas ? Au moins le temps de comprendre une bonne partie des options que tu as injectées ?

Pourquoi ne pas partir de modèles plus simples ? Exemple ici, mais il y en a d’autres sur la toile…

Sinon, un lien vers le tuto que tu as suivi, comme le demandait Nebuchadnezzar ?
Edité le 07/01/2014 à 16:22

Merci pour ta réponse.
Effectivement, n’utilisant que peu mon PC bureau maintenant, un contrôleur de domaine n’est plus important. Ce qui m’importe réellement, c’est le partage de fichier et le bureau à distance (même si Samba ne sert pas pour ce dernier :wink: )
Je suis en train de lire ton tuto, et je vais l’essayer
J’ai suivi plusieurs tuto mais celui là www.youtube.com… me paraissait pas mal
J’avais suivi un super tuto il y a 2-3 ans mais il n’existe plus hélas www.teletuto.fr…

Bon, je dois être une vraie quiche, mais je n’y arrive pas :’(

Arf…

Essayons de voir au point par point. A partir de quelle moment ça ne fonctionne pas lorsque tu suis le lien que je t’ai donné ?

Alors, j’ai toujours le même message :/. Je rame rame…
Le problème de ton tuto, c’est que ce ne sont pas les mêmes lignes de commande que sous Ubuntu :confused: du coup, je galère. Je débute sous linux :frowning:

Bon, si j’essaie de partir du début, sous Ubuntu 13.10, en gestion via l’interface graphique (que je ne connais pas), tu as par exemple ce tuto.

A priori, il te faut impérativement :

sudo apt-get install samba samba-common

sudo apt-get install python-glade2

sudo apt-get install system-config-samba

Puis tu définis les droits sur les dossiers (voir les images du lien).

Il ne le précise pas, mais un redémarrage de samba doit être necessaire après les modifs :

sudo /etc/init.d/samba restart

Si tu as un message d’erreur suite à cette commande, dis nous lequel stp…

Conseil : Pour le premier dossier que tu partageras, donne l’accès à tout le monde le temps de vérifier le bon fonctionnement. Ensuite tu pourras le limiter aux utilisateurs de ton choix.

& dis nous ce qu’il en est…

Alors, j’ai essayé ton tuto
Sur mon mac, le serveur apparaît bien, je m’y connecte car tous mes dossiers partagés sont présents mais une fois que je vais dessus, je n’ai accès à rien comme si le partage n’était pas monté. Je ne pige rien
Par ailleurs, sur Samba, toujours “Etat: inactive servers:winbindd Activé”

Bon, si tu vois les dossiers partagés, c’est déjà un début…

Qu’entends tu par “je n’ai accès à rien” ? Depuis le Mac tu peux rentrer dans un dossier partagé ou pas ? Y copier un fichier ?

Il te demande un nom d’utilisateur et un mot de passe ?

Tu partage quels dossiers ? Avec quels droits ?

Alors, je voies tous les fichiers du serveur sur mon mac de “home” à des dd et des dossiers sur le bureau. Mais je ne peux rien y faire: je ne voies aucun fichier, je ne peux rien y mettre et les dossiers apparaissent comme “non montés”. Je me connecte sur le serveur comme invité ou avec l’identifiant et le mot de passe que j’ai créée :frowning:
Les dossiers que j’ai partagés, j’ai donné tous les droits au partage (lecture, écriture…)

Je comprends plus rien. Ton premier post parlait d’un controleur de domaine via Samba, donc à priori pour des postes Windows, et là tu causes d’un client MAC ??

Ceci mis à part, ce n’est pas logique que tu puisses voir tout ça à travers Samba. On dirait presque du NFS… Je ne sais si ça vient d’Ubuntu ou des partages/manips que tu as effectués…

Essaie de procéder par étapes, comme déjà indiqué :

Un seul partage Samba simple et totalement ouvert, par exemple un dossier créé spécialement pour la circonstance. vire tous les autres. Connexion avec identifiant et mot de passe (évite l’invité pour commencer) depuis le client.

Voir repartir d’un système server (ubuntu) propre au besoin…

En fait, à la maison j’ai:
1 PC sous Windows XP
1 portable sous windows 7
1 macbook
1 macbook pro (les 2 mac sous Mavericks)
1 serveur sous Ubuntu (qui me pose soucis grrrr)

J’ai retiré tous les partages que j’avais crées pour n’en créer qu’un seul avec 1 identifiant et 1 mot de passe mais toujours pareil. Et le message “Etat: inactive servers:winbindd Activé” sur Samba apparaît toujours.

Bon… Bein j’ai pas de réponse là de suite.

J’ai pas l’habitude de Ubuntu donc je me fais une machine virtuelle dès que j’ai un moment et j’essaie de reproduire ton partage… et le problème que tu rencontres…

Sauf si un Ubuntero passe dans le coin…

:slight_smile:

Je te remercie Woolf. Je me suis commandé des magazines sur Ubuntu, Samba et Serveur linux pour voir, qui sait :wink:

Salut Titban95,

Désolé de ne pas avoir déposé un post avant, mais pas des masses de dispo… :slight_smile:

Bon pour faire court, j’ai installé une Ubuntu Desktop standard 32 bits, avec une ip 192.168.0.49 sur mon réseau local.

Pour le principe, j’accroche pas Unity, j’ai collé la pseudo interface Gnome, mais c’est sans importance dans le cas qui nous occupe :

sudo apt-get install gnome-session-fallback

Puis les pré-requis pour Samba :

sudo apt-get install samba samba-common

sudo apt-get install python-glade2 system-config-samba

J’ai créé, depuis un terminal, un dossier destiné à être partagé :

sudo mkdir /partage

Je dézingue tout éventuel problème de droits pour le principe (c’est un test n’est ce pas) :

sudo chmod 777 /partage

J’installe l’outil de gestion samba en mode interface graphique :

sudo apt-get install system-config-samba

Puis je le lance :

sudo system-config-samba

Dans la fenêtre, le clique sur le sigle “+” et je navigue jusqu’au dossier “/partage” ou pour faire plus court :

“/partage” sans les guillemets dans la fenetre “répertoire”
“partage” sans les guillemets dans la fenetre “nom du partage”
Cases “visible” et “inscriptible” cochées
Onglet “Acces”, je coche “autoriser l’accès à tous les utilisateurs” et je valide…

Depuis un Windows, je tape dans un explorateur, l’adresse ip de la machine Ubuntu dans une barre d’adresse :

note: double antislash qui se transforme en simple antislash sur ce forum (sic) puis l’ip, mets l’ip de ton ubuntu

et je vois, sans utilisateur particulier, le dossier “partage” que j’ai créé et les imprimantes (il n’y en a aucune dans ce cas précis, mais l’icone est bien là)…

Bref, pas de prob particulier, je n’ai rien fait d’autre que les lignes ci dessus. Peux tu reproduire et confirmer que tu arrives au même résultat à ce niveau ?

@+

:wink:
Edité le 28/01/2014 à 22:54

Salut Woolf

J’ai réinstallé Ubuntu server et j’ai suivi ta démarche. Et tu sais quoi? Mon dossier “partage” apparaît et est utilisable sur mon Mac (je peux y lire et y mettre des documents dedans)
Sur le PC sous Windows 7, c’est pareil: le serveur apparaît dans le réseau ainsi que le dossier partage :slight_smile:

Par contre, j’ai suivi ta démarche pour partager d’autres dossiers que j’avais mais sur d’autres DD que celui du système et ceux là, ne fonctionnent pas.
Par ailleurs, j’essaie de formater un DD et il ne veut pas. Est-ce parce qu’il y Ubuntu 12.10 dessus?

Good for you :super: pour le partage. Avant d’aller plus loin et d’ajouter d’autres partages, essaie de définir les utilisateurs et leurs mots de passe.


[quote="titben95"] Par contre, j'ai suivi ta démarche pour partager d'autres dossiers que j'avais mais sur d'autres DD que celui du système et ceux là, ne fonctionnent pas. Par ailleurs, j'essaie de formater un DD et il ne veut pas. Est-ce parce qu'il y Ubuntu 12.10 dessus? [/quote]

partages sur disques usb ? Attention aux points de montage sur l’Ubuntu avant de partager. De mémoire c’est dans /media… Il faut aussi t’assurer que les droits Linux ne bloquent pas l’accès (le fameux “chmod 777” de notre test a permis de contourner le problème, mais n’est pas vraiment sécure…).

Avec quel outil essaies tu de formater ? Gparted devrait répondre à ton besoin, penses à cliquer sur le bouton (vert) appliquer, après avoir défini les infos de la nouvelle partition.
Edité le 30/01/2014 à 14:27