Forum Clubic

Le DHCP donne une mauvaise IP. - Neuf box, ip reservé par adresse eth

Voila j’ai rentré dans ma Neuf box certainne association d4ip et d’adresse ethernet. seulement des fois ca marche pas tres bien.

Donc j’ai rentré l’adresse ethernet 192.168.1.100 et je l’ai associer a l’adresse ethernet de mon pc. La premiere fois tous marche bien. mais arrivé a l’expiration du bail mon pc renouvelle son IP et la la neuf box lui donne 192.168.1.103 … (sachant que 101 et 102 sont prise par ma divx box et decodeur Neuf TV). si je desactive ma carte reseau et que la reactive 5 minute plus tard elle reprend l’IP attribué (c’est à dire 100)

Ce probeme n’apparait que sur mon pc principal Ubuntu 6.10. il n’apparait pas sous ma divx-box (win XP) ni sur mon serveur Ubuntu server 5.04, ni sur mon portable ubuntu 6.06. je pense que c’est probleme entre ubuntu 6.10 et la neuf box.

Car meme si le server DHCP possede déjà une entré active avec l’adresse mac elle devrai redonner la même vue que c’est la même adresse mac.

quelqu’un a une solution ?

Je ne connais pas le neufbox mais en regle general dans les options du dhcp, tu peux fixer une ip en fonctione d’une adresse MAC, donc recupere l’adresse mac de ton PC, renseigne correctement les champ et ton PC aura toujours la meme ip… Cepandant, passer en ip fixe pour assurer des regles de routage correcte est beaucoiup plus simple a mettre en oeuvre… :smiley:

Bon amusement

c’est exactement ce que j’ai fait (et ce que j’ai dis)… :slight_smile: et justement des fois la neuf box donne la bonne ip et des fois non. il semblerai que des fois elle est déjà et prise et refuse de la redonner à mon pc …

Salut,

Pourquoi t’embetter avec un DHCP alors que tu as 3 PCs qui ne changent jamais d’IP ?

Désactive le ou configure le sur une plage autre que les IPs fixes souhaitées … , configure manuellement les IPs souhaitées sur les machines ensuite et voila …

parce que sur le routeur de la neuf box on ne peu pas router les ports sur des adresse qui ne sont pas dans la plage du DHCP… Et que un server DHCP ca permet justement d’atribué les IPs …

Ton adresse MAC est bien rentrée dans le serveur DHCP?
J’avais eu le même problème (mais pas sur la neufbox, sur un autre routeur), parce qu’en fait il fallait des séparateur “;” au lieu de “:” …

apres renseignement pris, la neufbox route sur des ip fixe… Mon collègue l’a fait sans aucun problème et Emule (entre autre) fonctione tres bien… :smiley:

oui elle est bien rentrée. j’ai pas le choix des séparateurs, il y a une case pour chaque chiffre.

mon probleme n’est pas la…

Mon probleme c’est que des fois la neuf box donne la bonne et des fois non.

Peut etre que mon pc ne libere pas l’IP avant de la renouveller… c’est peut être ca le probleme… non ?

Bizarre. Et si tu restreins la plage d’attribution du serveur DHCP?
Si j’ai bien compris, de 100 à 102? Comme ça il ne pourra pas attribuer une autre adresse IP…

Mais déjà, c’est bizarre que ton bail arrive à expiration… Normalement, il est renouvelé avant… (tentative à 1/2, 1/4 et 1/8 de la fin du bail il me semble)…

Peux tu enviyer des screen de la page de ta config, ca sera plus clair pour t’aider…

exactement ! c’st à la tentaive 1/2 (du bail) que le renouvellement de l’ip se fait et c’est la que ca merde !

edit : c’est à dire qu’à la premiere tentative j’ai la bonne IP et au renouvellement à 1/2 du bail, hop la ça me redonne une mauvais IP…

pour les screens ce soir la je suis coincer :stuck_out_tongue:

Ok, tu pourras essayer de restreindre la plage d’attribution du serveur DHCP?
De 100 à 102?

Ton problème est d’avoir toujours la meme ip, c’est ce que tu as écris. Il n’existe que 2 solutions:

  • IP Fixe
  • DCHP verouillé sur adresse MAC

Donc puisque tu n’arrives pas a régler ton DHCP (envoie les screens, ca sera plus facile pour nous), passe en ip fixe (ton réseau te remerciera).
L’ip fixe n’est pas une maladie mais un vieux remede quand on veut un reseau fluidie et stable… :stuck_out_tongue:

donc voila la fameuse inteferface…

http://shionn.dyndns.org/file/forum/bidon/neuf-capture-dhcp.png
(dites moi si vous la voyer bien, moi je peu pas verifier)

j’ai essaillé de restreindre la zone du server dhcp … resultat je me retrouve avec un message d’erreur lors du renouvelle de mon ip comme quoi y a plus d’adresse libre …

comme je l’ai déjà dis j’ai pas envie de passer en ip fixe. c’est plus simple pour moi de paramettré toutes mes IPs au même endroit…

Je pense que je vais attendre de recevoir ma nouvelle neuf box plutot que de continuer a me prendre la tete…

Au fait j’ai aussi des soucis avec UPNP … si vous savez pourquoi mes port se bind pas je suis preneur…

image impécable
ton adresse MAC est-elle bonne ? (ipconfig/all)
es-tu sur que l’ip n’est pas attribuée sur un autre périphérique réseau ?
tout est en attribution DHCP ou as-tu des périphérique en ip fixe ???

essayer de voir s 'il n’existe pas une mise a jour du soft du modem a tout hasard…
essaye aussi de mettre les adr MAC en majuscule, j’a idéjà eu des trucs de ce genre !!!

Après a froid, j’ai plus d’idée…
AS-tu les utre copie d’ecran SVP !!! :pt1cable:

alors voila le resultat d’un ifconfig eth1 -a : (l’eth0 est la carte reseau de la carte mere mais elle merdouille alors j’utilise une RT8139 10/100 des plus répendu)

eth1      Lien encap:Ethernet  HWaddr 00:50:22:40:0A:F6  
          inet adr:192.168.1.103  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::250:22ff:fe40:af6/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:55668505 erreurs:0 :0 overruns:0 frame:0
          TX packets:63824547 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:2626218147 (2.4 GiB) Octets transmis:908321054 (866.2 MiB)
          Interruption:225 

l’ip n’est pas attribué sur un autre periferique (aucune reponse au ping), j’ai meme verifier avec le decodeur Neuf TV.
Tous mes pc sont en DHCP. mais il n’ont pas tous une ip attribuer en fonction de l’adresse ethernet dans le DHCP
La neuf box se met a jour toute seule, et la derniere mise a jour date de deux semaine je crois.
On ne peu pas entré de majuscule elles sont tous suite changer par des minuscules.

Ce probleme ne se pose pas sur ma divx box avec windows XP, ni avec mon serveur qui est sous ubuntu 5.04 serveur.

Edit : tu voudrais quel autre capture d’écran ?

Edit 2 : apres reverification de mon fichier de config de la carte reseau (/etc/network/interfaces) voila ce que je vois :ouch:

iface eth1 inet dhcp
address 192.168.1.121
netmask 255.255.255.0
gateway 192.168.1.1
auto eth1

normalement ca gene pas surtous que de toute maniere l’ip qui m’est donner c’est la 103 et non la 121. j’avais mis ca a cause du co###rd de la hotline de neuf. bon je l’ai viré mais ca ne resoudra certainement pas le probleme…

Je suppose que 192.18.1.100 est le debut de ta plage d’attribution DHCP, as-tu essayer avec une ip au milieu de la plage ???

non bonne idée !!!
effectivement puisque ca marche parfaitement pour mes deux autres pc qui sont en 135 et 101… je vais en essayer une delirente pour tester

Alors c’etait ca ???

et non c’etait une fausse joie. j’ai mis l’ip 115 à la place de 100. Je me suis retrouvé jusqu’à maintenant avec la bonne ip (115) et la hop surprise j’ai une autre ip, la premiere libre, ici la 100.

par contre :clap: car c’etait une trés bonne idée.