Forum Clubic

Installation Debian Etch - quelques questions

Donc j’ai choisi d’installer une debian etch, et au moment de choisir les paquets, j’ai tout déselectionné :paf: au moins, je saurais ce que j’installe :oui:

jusqu’à présent, j’ai suivi les instructions de http://people.via.ecp.fr/~alexis/formation-linux/xfree.html

j’ai installé x.org (qui va avec la debian etch) et les drivers nvidia (les proprio, ch’ui pas fou) ainsi que kde-core et kde-i18n-fr

mais au moment de faire startx, il me dit que mon utilisateur n’a pas le droit
et en root, j’ai
Failed to load module “glx” (a required submodule could not be loaded, 0)
Failed to load module “nvidia” (module does not exist, 0)
No drivers available

je dois faire quoi ? :frowning: j’aimerai bien avoiir un serveur X, c’est quand même plus convivial :confused:

edit : si dans xorg.conf, je mets les drivers nv, ça marche en root, mais pas en simple user

As tu bien donné le droit "video" à ton utilisateur ? genre :

usermod -G users,wheel,slocate,audio,optical,floppy,storage,scanner,video < nom_utilisateur >

Sinon, es-tu en Debian Etch (Testing) ou en Debian Sid (Unstable) ? Car Debian Etch Unstable n’existe pas ;).

Sinon pour nvidia et glx, les modules des pilotes ne sont visiblement pas ou mal installé. Je ne peux pas t’aider plus que sa, je n’utilise pas Debian et je n’ai pas de car Nvidia.

Voila, test et reviens ici ;).

euh oui, désolé, je suis en testing (je confonds toujours les 2)
par contre, j’avais bien donné le droit vidéo à mon utilisateur

le message est xauth : creating new authority file /home/flanker/.serverauth.6571
X: unable to open wrapper new config file /etc/X11/Wwrapper.config
X: user not authorized to run the X server, aborting.

le souci, c’est que je n’ai pas eu d’erreur quand j’ai installé ledriver nvidia, et quand je le réinstalle, il me dit qu’il est déjà installé

il te manque peut-être la partie xorg du driver :

sinon, même avec ça tu n’auras pas grand chose, pour un environnement kde minimal, il faut kdelibs4 et kdebase sous debian

maintenant, j’arrive à lancer kde, mais seulement en root, je n’ai toujours pas le droit en tant que simple user :confused:

Bizarre … Quels sont les droits de ton utilisateur ? "video" et … ?

bon, bah je crois que le problème est réglé : je n’arrive même plus à booter correctement
j’ai lejoli message :

can't access tty; job control turned off

et j’ai une console root (sans avoir à entrer le password, of course) avec 3 instructions qui se battent en duel :confused: même pas qqc pour rebooter l’ordi proprement.
je me dis que j’en ai marre de ça, je formate et je réinstalle proprement ma etch en sélectionnant les paquets de bureautique. et là
j’ai

/dev/hda7 doesn't exist , dropping to a shell
can't access tty; job control turned off

c’est cool, linux, surtout les distribs stables comme debian :super:

etch n’est pas debian stable, etch c’est testing… en dehors de debian stable, RIEN n’est garanti.
Alors tes trolls tu te les gardes et soit tu retournes faire le jojo sous windows, soit tu remballes ta condescendance et tu utilises une distrib adaptee a ton niveau car visiblement, debian semble etre au dessus de tes moyens actuels.
on a pas specialement besoin de types qui font des erreurs et qui n’assument rien.

euh faudra que tu m’expliques où j’ai fait une erreur, j’ai juste rebooté entre la fin d’installation et la tentative du login :neutre:

etch n’est pas une version stable mais de dévelopement et debian n’est pas une distrib adaptée aux débutants !

si tu veux un sytème simple à installer, je te conseille plutot kubuntu, mandriva, suse ou fedora.

maintenant, pour ton problème, je pense que :

  1. tu as fait une erruer au moment de l’installation, debian n’étant pas entièrement automatisée et guidée comme certaines autres distributions, il est encore possible de faire des errerus et de se retrouver avec un système inutilisable.
  2. tu as installé etch au movais moment, etch étant la version de développement prévue pour devenir la prochaine version stable de débian, il arrive parfois, pendant la mise en place ou l’évolution d’un logiciel que des problèmes la rendent inutilisable pensant quelques temps, pire même, tu peux te retrouver avec une version que tu ne pourras même pas mettre à jour automatiquement vers une version fonctionnelle à l’aide des outils génériques debian (ça m’est arrivé une fois, j’ai installé une sid au movais moment avec un paquet de base défectueux dans les répos, du coup, pas possible de le mettre à jour, ni de l’enlever pour le réinstaller parce que c’est un paquet de base de la distrib !)

j’en ai déjà installé deux sans problème, une sur mon serveur qui tourne sans problème (mais sans X :p) et l’autre, j’avais besoin du disque dur, alors je l’ai virée.
et franchement, je vois pas trop où on peut se tromper dans l’installeur debian (après, quand on commence à faire joujou tout seul, ok, mais vu que dès le premier reboot ça foire …)
d’ailleurs, la seule différence entre mes deux installes successives, c’était la sélection des paquets tout faits (genre bureautique, serveur mail, toussa), faudrait que je refasse l’essai.
accessoirement, j’avais déjà utilisé l’ancienne testing (sarge je crois), je n’avais pas eu de problème :confused:

t’as fait plusieurs erreurs :

  • le choix de la distrib : tu connais mal linux et a fortiori debian. Or debian n’a jamais specialement adaptee aux debutants.
  • tu veux du stable et tu choisis la version testing qui comme son nom l’indique est une version de TEST. autrement dit, ceux qui utilisent testing sont cense deja bien connaitre debian et etre capables de regles les problemes triviaux (install de serveur X et drivers externes) que tu rencontres seuls ou presque.
  • tu utilises une doc qui est adaptee a debian stable et pas a testing
  • tu essayes d’installer des drivers proprio non adpates a la distrib avant meme d’avoir essayer le driver Libre bien integre et qui suffit tres largement pour decouvrir linux.
  • visiblement, tu as fait une erreur technique (a vue de nez, bien plus grave que le simple “oubli” de cocher des paquets) que tu ne souhaites pas (ou ne penses pas) nous reveler. On probleme comme le tiens n’arrive jamais sous debian meme en testing et meme en install ultra minimale.
  • tu fais le malin alors qu’il faut etre humble pour utiliser linux car on se retrouve tres vite confronte a son incompetence.
  • tu enerves les seuls gens qui peuvent t’aider avec des trolls gros comme des montagnes en plein dans OSA : c’est de la provocation.

euh j’ai quand même une certaine habitude des outils linux / unix, je bosse sous linux (des debian justement) et sur mon mac, j’utilise très souvent les outils *bsd

je veux surtout un truc qui marche un minimum, et des outils dont j’ai besoin sont dans la testing mais pas la stable

y a pas franchement besoin de doc pour l’installe d’une debian :neutre: au moins jusqu’au premier reboot

non, hors de question d’avoir un linux inutilisable pour moi, donc sans vrais drivers 3D

bin faudra que tu changes d’avis, j’irai pas demander de l’aide en ne donnant pas tous les détails :sleep:
d’ailleurs, j’ai refait une installe pour voir si ça se produit, en sélectionnant le paquets outils de base, et ça refoire

lol

^^

bon, je vais détailler l’installe
français, français, français > je pense pas avoir fait d’erreur là
carte réseau, je choisis la bonne tant qu’à faire
nom de l’ordi, je devrais y arriver
nom de domaine, je laisse vide
de nouveau français, puis ftp2.debian.org je crois, j’ai gardé le premier de la liste
proxy > vide, j’en utilise pas
partitionnement :
2 en ntfs
une en ext2 de 100Mb pour /boot
une en ext3 de 20Go pour le reste (oui, je sais, c’est mal, toussa, mais flemme de faire plus compliqué
une de swap de 1Go
password root, nom user, password user, je devrais y arriver tout seul comme un grand :smiley:
utilisation du truc pour le concours de popularité des paquets debian, j’ai mis non
sélection des meta-paquets, cette fois j’ai mis aucun
installer grub sur le secteur d’amorçage > oui
retirer le cd > ok, ça devrait être possible

où est mon erreur ?

pour le partitionnement, la carte mère est assez récente, les disques aussi, donc je ne pense pas que ça gêne que le /boot soit assez loin (il me semble qu’avant il fallait qu’il soit au début du disque)

ben visiblement t’as encore du boulot…

si tu veux un truc qui marche alors n’utilises pas testing, c’est pas plus complique
et si tu as besoin d’une distrib proche de debian, possedant des paquets plus recents et entant consideree comme stable par ceux qui la font alors utilise Ubuntu

heureux de te l’entendre dire et pourtant c’est pas la doc qui manque.

n’importe quoi… :non:
Le driver Libre est parfaitement utilisable et stable. Il lui manque juste les fonctionnalites 3D a cause du constructeur.
Pour debuter, il y a bien de choses a decouvrir avant d’avoir a installer ces drivers proprio franchement mal foutus.
De plus Linux est bien plus stable et “utilisable” (pour reprendre ton mot) sans ces drivers proprio qu’avec.

euh non, sans accélération 3D, je devrais rebooter si je veux jouer un peu, donc pour moi ce n’est pas un système utilisable :neutre: (étant donné que je bosse sur mon mac, le jeu occupe pas mal de mon temps pc)

et accessoirement, j’ai réinstallé à partir d’un vieux cd Sarge qui était en testing (kernel 2.4), et j’ai utilisé éxactement les mêmes options, résultat ça marche

je veux pas te decevoir mais choisir linux pour le jeu n’est pas specialement bien pense… c’est pas nouveau…

as tu consulte les bugs actuels de la testing ? peut etre es tu tombe dans un des rares moments ou elle est reellement cassee…
Lorsque Sarge etait en testing, sur la fin, elle etait extremement stable (je l’ai meme utilisee sur des serveurs en prod - c’est dire). Il ne lui manquait plus que les maj de secu… Voila peut etre pourquoi tu n’as jamais eu de prob avec testing. Mais aujourd’hui, testing est redevenue une vraie distrib de test (et rien que cela) et il est deconseille de l’utiliser sans etre vraiment a l’aise sous debian.

bof, warcraft III, Quake III, tetris attack sur super nes, ça devrait passer sans trop de souci

bin on m’avait dit l’an dernier que la testing était vraiment stable, j’étais resté sur cette idée :confused:
va falloir que je regarde ça :confused:

accessoirement, en repartant de la sarge (mais là je suis resté en stable du coup), j’ai réussi à installer les drivers nvidia, xfree et kde sans souci, en partant de rien et sans aller googler

warcraft 3 est un jeu windows, tu peux le faire tourner avec wine, mais tu risque d’avoir des problèmes au lancement du jeu à cause de la protection anti copie sur le CD

Aucun souci avec wine et Warcraft3, deux petits shots à l’appui :wink: :

http://img67.imageshack.us/img67/6273/znes3983qu.th.png[/img][/url] [url=http://img114.imageshack.us/my.php?image=znes3976ey.png][img]http://img114.imageshack.us/img114/6127/znes3976ey.th.png

Le truc à savoir cependant pour bnet : il faut, la toute première fois, couper le parefeu car le serveur envoie des requêtes suivant des ports assez aléatoires pour générer des fichiers utiles à l’identification, ensuite, tu pourras juste autoriser le port 6112 TCP (par défaut), et ça passera tout seul (les fichiers sur un de mes shots servant à l’identification étant alors seulement mis à jour à chaque fois via le port autorisé).

Pour wine, prends un des deux derniers (sinon, il risque d’y avoir un souci pour bnet) :

nb : il ne faut pas oublier l’argument -opengl quand tu lances wine.

edit : pour les perfs, il tourne très bien (noté platinium sur winehq, si je me souviens, cad le maximum, il n’y a pas, à mon avis, de différence avec la version tournant sous Windows).

edit2 : pour l’émulation zsnes, pas de souci.