Forum Clubic

Configuration Serveur FTP

Bonjour à tous,

Je souhaiterais créer un serveur FTP pour récupérer certains de mes fichiers depuis l’extérieur. Voici l’architecture de mon réseau :

http://img7.imageshack.us/img7/816/configinternetwol.jpg

Mon serveur FTP a donc été créé avec Filezilla. En local j’arrive à m’y connecter grace à l’adresse suivante : localhost…[/url] en revanche sur les adresse suivante :www.net2ftp.com. et [url=http://www.g6ftpserver.com/fr/ftptest]www.g6ftpserver.com… le serveur est à chaque fois injoignable en local ou en distant.

Avec Fillezilla client pareil, impossible de me connecter, le message suivant apparait :
Statut : Connexion à ....*…
Statut : Échec de la tentative de connexion avec “ECONNREFUSED - Connection refused by server”.
Erreur : Impossible d’établir une connexion au serveur
Statut : Attente avant nouvel essai…

J’ai pour le moment créé un compte anonymous, donc pas d’identifiant ni de mot de pass. Accès direct depuis mon adresse public. Concernant ce point je me suis créé un compte chez No-IP pour avoir accès depuis l’extérieur.

Ma livebox est configurée avec une DMZ pointant vers mon routeur. J’ai quand même forwardé les port 20-21-22 de la livebox. J’ai fait de même sur le routeur.

J’ai désactivé le par feu windows pour vérifier qu’il ne poserait pas de problème mais rien de nouveau.

Je suis un peu à bout de solution, si vous pouviez m’apporter quelques idées je suis preneur.

Merci d’avance.

Personnes pour une petite idée?

Salut, avec cet adressage (meme reseau coté wan et coté lan du netgear) c’est etonnant que tu ai le net sur les pc ^^

Ta livebox ne serait pas plutot branchée sur un des 4 ports du net gear ?

Si les pc et la livebox sont sur le meme reseau (192.168.1.XXX) tu dois faire le forward des ports directement de la livebox vers le serveur ftp.

Et n’oublie pas de configurer le firewall de la livebox :wink:

Ma livebox est bel et bien branchée sur le port WAN du netgear et non pas sur un des 4 autres. Ceci est fait pour que la DMZ soit effective.

Concernant les adressages ip, ne serait-ce pas cela qui m’empêcherait d’accéder à mon serveur FTP?

si tu utilise le port wan il dois y avoir une erreur dans ton schéma.
ou alors du as fait un pont entre l’interface wan et les 4 ports.

tu es sur de ces ip?

le netgear est en 192.138.xxx.xxx ?? donc il n’est accessible par aucun pc du réseau sans que tu leur change l’ip? :nexath

éclaircis moi et je t’éclaircirait :stuck_out_tongue:

DMZ (sur les box du commun des mortels) ca veut dire forward de tout les ports vers l’ip indiquée.

Si ton Netgear effectue du NAT effectivement tu dois forwarder les port en direction de l’ip du netgear coté wan et ensuite refaire un forward des ports en direction de l’ip de ton choix.

et pour le petit conseil, faire du nat chez soi pour en refaire en sortant pas sa box c’est pas terrible comme design réseau :slight_smile:

A moins qu’il n’y ai une motivation derrière? On peut mettre des routes statiques sur les livebox.
enfin il y a plein d’autre solutions :slight_smile:

Ah oui effectivement je comprend mieux pourquoi tu me dis qu’il y a un soucis je n’avais pas vu mais il y a bien une erreur dans l’adresse du routeur sur le schéma, celle ci n’est pas 192.138.1.2 mais 192.168.1.2. Effectivement ca aurait causé quelques problèmes sinon.

Donc ensuite dans ma box j’ai fait une DMZ en indiquant l’adresse du routeur. En faite je me sert du routeur pour faire du WOL. Le but de la DMZ est d’accéder à distance au routeur qui a un service de WOL intégré. J’ai fais une DMZ car impossible de fonctionner avec de la redirection de port. Quand je configure le NAT rien ne marche, peut-être n’est-je pas forwader les bons ports… mais j’ai fait tellement d’essais que cela m’étonnerais.

Par contre je ne comprend pas ce que tu veux dire par “faire du nat chez soi pour en refaire en sortant pas sa box c’est pas terrible comme design réseau”

La livebox ne te permet pas de faire du WOL ?

il y a un truc qui me chagrine dans ton schéma: ton routeur netgear ne peut pas agir comme un routeur dans cette configuration d’adressage réseau.

il n’y a qu’un seul réseau. le 192.168.1.0
donc pas de routage.

pour continuer il me faudrait des screenshot d’un ipconfig d’un des pc connecté sur le netgear et des screenshot de la configuration de netgear.

Sans ca je devrait te proposer maintes configuration différentes en fonction des hypothèse que j’emettrai sur ta configuration actuelle…on est pas sortit de l’auberge ^^

A moin que tu sache répondre à ma question: ton port wan du netgear est il assigné au switch? (dans ce cas ton netgear agit comme un switch 5 ports et tout s’explique)

Boss, ca réponse est juste au dessus :

oui, sans compter cette erreur.

relis mon post :wink:

Effectivement dans la configuration du routeur la case “ajouter le port Wan au switch” est bel et bien cochée. C’est la livebox qui gère le DHCP.

Le routeur ne me sert que à faire du WOL car la livebox ne permet pas d’en faire. Voici des screen

Screen de mon adressage du netgear
[Photo supprimée]

Screen de mon PC sur le réseau
[Photo supprimée]
Edité le 05/03/2012 à 10:31

Ok tout s’explique :slight_smile:

ton netgear est donc un simple switch dans cette configuration.

La livebox est le seul routeur de ton réseau.

C’est la livebox qui dois faire de la redirection de ports.

La grande question maintenant c’est
“est ce que lorsqu’on définit une adresse IP en DMZ avec une livebox on peut forwarder certains ports vers une autre IP”

Définir une ip en DMZ ca veut dire lui forwarder tout les ports. J’imagine qu’orange à prévu le coup (tout les ports sauf ceux pour lesquels il y a une règle de forward) ^^

Si ce n’est pas le cas ca va être genant :stuck_out_tongue: Mais je pense que c’est le cas.:wink:

Donc premier test: laisse l’ip du netgear en dmz et forward les ports du ftp vers l’ip du serveur ftp. Si ca marche: nickel.

Sinon tu n’aura que deux solutions. Une simple, une bien plus complexe.

La simple:
tu veux juste faire du wake on lan depuis la page web du netgear ? forward juste le port web au lieu de le mettre en dmz! (et tu améliorera la sécurité de ton réseau)

et ensuite tu forward les ports ftp :wink:

Au fait tu as fait un serveur ftp passif ou actif ? ou les deux ?
Aussi, le firewall de la livebox est positionné à quel niveau de sécurité ?
(orange est assez bette pour n’avoir pas lié les lrègles de firewall avec les regles de forward lol :jap:tu peux forwarder un port qui est bloqué par le firewall mdr)

(pour la complexe on verra plus tard)
Edité le 05/03/2012 à 17:05

Bon ok mais la question c’est quel port dois-je forwader et vers quel port??

J’avais déjà essayé le 80 vers le 80, le 80 vers le 8080 le 8080 vers le 80 ou le 80 avec le 8008 etc etc et j’ai fait ça avec toutes les combinaisons. J’avoue que je ne sais absolument pas pourquoi utiliser les ports 8080 et 8008 car pour moi le port web est le 80 mais le tuto que j’avais suivi pour faire du WOL disait de procéder ainsi. Et en plus il me semble que j’avais réussi à le faire marcher avec ces ports là avant de changer de livebox. Et avant ca marchait mais maintenant je n’arrive plus à arriver sur ma box avec une simple redirection de port. La seule solution que j’ai trouvé est la DMZ.

Pour ta deuxième question c’est du passif. Quand je fais mes essais je met le firewall au minimum et quand j’ai fini je le remet au niveau intermédiaire et je vérifie après ça que tout fonctionne toujours. Pareil pour le firewall windows.

La solution complexe j’imagine qu’il s’agit de transformer le netgear en routeur?
Edité le 06/03/2012 à 08:36

Oubli les modes du firewall de la livebox, le seul mode valable c’est le “personalisé” ou tu choisit les ports que tu ouvre.

L’histoire des ports c’est simple:

Tout les ports sont ouvert sur l’ip wan de ta livebox(ton ip internet).
Pour la protéger il y a un firewall qui va pouvoir bloquer ces ports.

C’est le même principe avec un pc, par défaut tout les ports sont ouvert sur son ip (ou ses ip).
Pour le protéger on peut mettre un firewall.

Le problème c’est que tes pc n’ont pas tous une ip wan.(dommage)
Donc on rajoute une petite complication.

On donne des adresses bidon a tes pc (on nommera locales) et lorsqu’ils essairont de communiquer avec des ip sur le wan, c’est la livebox qui fera croire que c’est elle qui demande disons une page web.(elle fait du NAT: Network Address Translation) La livebox garde en mémoire “qui à l’intérieur” a demandé la page web, et quand la page arrive, elle lui restitue et tout va bien.

Le problème c’est quand quelqu’un de l’extérieur veux joindre une machine à l’intérieur.

La livebox ne peux pas deviner vers qui envoyer les paquets.

Il faut donc lui dire.
Ex: tout ce qui arrive sur ton ip wan quelque soit le port tu balance tout à cette ip locale.
Ca, ca veut dire que l’ip locale est en DMZ.
Zone demilitarisée: pas controlée, yala tout est ouvert.

Pour être plus fin tu peux faire la meme chose mais avec uniquement certains ports.
Ex: tout ce qui arrive sur le port 80 de ton ip wan, tu balance vers le port 80 de cette ip.
Si sur cette ip il y a un serveur web qui ecoute sur le port 80. il recevra les requetes web en port 80 (par defaut quand tu précise rien dans ta barre d’adresse)

Mais admettons que j’ai plusieurs serveurs web???
Plusieurs possibilités:

Soit tu configure un serveur pour écouter sur un autre port, disons 8080 ou 8008 ou 8596 lol ou 7894 bref, comme ca te chante. Et tu fait une redirection de port sur la livebox.
Ex: tout ce qui arrive sur le port 8888 de ton ip wan, tu balance vers le port 8888 de cette ip.

Soit tu peux faire une redirection deport différente:
tout ce qui arrive sur le port 80 de ton ip wan, tu balance vers le port 80 de PC1
tout ce qui arrive sur le port 8182 de ton ip wan, tu balance vers le port 80 de PC2
tout ce qui arrive sur le port 8008 de ton ip wan, tu balance vers le port 80 de PC3

L’avantage de cette deuxieme solution c’est qu’on ne peut pas toujours spécifier le port sur lequel le serveur dois écouter.

La solution complexe c’est encore plus complexe que ca, mais tu n’en aura pas besoin :super:

Ok pour les ports j’avais déjà plus ou moins compris comment ça fonctionnait mais une petite mise à niveau ne fait pas de mal :wink:

Bon alors si je résume bien :

Actuellement mon Netgear est ma DMZ. Tous les ports de ma box sont donc forwadés sur le Netgear. De cette manière j’arrive bien à me connecter sur l’administration de mon Netgear Donc jusque la je suis Ok. Le soucis c’est que de cette manière quand je veux me rendre sur mon serveur qui lui n’est pas sur mon routeur mais à une autre adresse et bien ça fout la merde et c’est donc surement pour ça que je ne peux pas accéder à mon serveur en distant. C’est bien ça?

La solution serait donc de forwader seulement les ports nécessaires à l’accès de l’administration du Netgear pour pouvoir démarrer mon PC et donc mon serveur le tout à distance et ensuite de créer une autre règle pour me renvoyer sur le serveur.

Le problème c’est que j’ai déjà essayer de forwader le port 80 vers le 80 de mon netgear et je n’arrive pas à me connecter à l’administration du Netgear. Mais vu que ca marche avec la DMZ ca doit vouloir dire que je n’ai pas redirigé les bons ports c’est bien?

Donc comment savoir quel port redirigé? pour mon Netgear ( la question ne se posant pas pour le serveur étant donné que c’est moi qui choisis le port du serveur).

Par defaut c’est le port 80 pour les serveurs web.

Donc ton pour ton netgear ca dois être le port 80.
Essaie http : \ ip_du_netgear:80

Si ca s’affiche c’est que c’est le port 80.
Il me semble que pour les dd-wrt tu peux spécifier un port d’écoute particulier pour le service web lorsqu’il est en mode routeur.
(dans administration)
Mais ca c’est quand il est en mode routeur, d’ailleur il faut accepter le management par web toujours dans administration.
Mais ca normalement tu n’as pas à y toucher.

Après ca peut être ussi la livebox qui ovre les ports du parefeu lorsqu’une ip est définie en dmz. On peut pas savoir quelle sauce orange nous as mis dans sa boiboite.

Fais tes tests avec le parfeu au minimum.

Bon alors voici les nouvelles.

De retour chez moi j’ai désactivé la DMZ sur la box, enlever toutes les redirections et programmation spéciales du netgear et j’ai ajouter la redirection 80 vers 80 du netgear dans la config de ma box. J’essaye (en local) et ca marche, je demande à un collègue de tester de chez lui et ca marche (à prendre avec des pincettes, je vérifierais à nouveau demain). Bref c’est exactement ce que j’avais fait au début et ca ne marchais pas. Enfin bon la ca marche on va pas cracher dans la soupe. Le problème que j’ai maintenant c’est que ca me fait toujours pareil avec mon serveur FTP.

J’ai donc redirigé les port 20-21-22 vers mon PC ou est hébergé le serveur. Je le démarre, l’accès se passe niquel en local en tapant l’adresse localhost… Mais par contre dès que j’essaie un accès à distance impossible de se connecté. J’ai désactivé le par feu windows et toujours pareil…

Une petite idée de quoi faire?

Bon j’ai refais un petit paquet de manips et pas moyen de me connecter à distance!!!

L’accès à l’administration du netgear depuis l’extérieur fonctionne parfaitement bien et c’est déjà une très bonne chose.

En revanche il m’est totalement impossible d’avoir une quelconque amélioration pour ce qui est du serveur FTP.

Dans les options de Fillezilla server que dois je mettre de vraiment important. J’ai suivi plusieurs tuto mais rien ne fonctionne.

J’ai essayé avec mon adresse no-ip.org, avec mon adresse ip WAN rien ne fonctionne.

Par contre en local tout est niquel, que je tape localhost…[/url] ou bien [url=ftp://192.168.1.12]192.168.1.12… tout fonctionne niquel.

J’ai désactivé le par feu windows, mis le par feu livebox en personnalisé et fait du NAT. Par contre petite question, dans la section paramètre de la personnalisation de la livebox, est ce que je dois aussi rajouter les redirections? Parce que la il faut indiquer beaucoup plus de choses.

Ca dépends de ce qu’ a fait orange dans leur box:(
si ils ont liés les règles de parefeu avec les règles de forward ou pas. tu peux spécifier des ip de destination dans le pare-feu ?

A froid je dirai non.
Tu laisse ouvre le port 80 en direction du port 80

et fait les redirection dans la page à cet effet.

Pour tester si un port est ouvert (quelque soit le type de serveur qui écoute sur ce port) depuis une machine tu peux utiliser telnet
telnet ip port

telnet ip_de_ton_routeur 80

telnet ip_de_ton_serveur 21
etc…

Si t’as pas de message d’erreur c’est que le port est ouvert.

Et si le port est ouvert mais que tu n’accede toujours pas au serveur ftp c’est que le service lui même dois avoir une restriction. Il n’accepet peut être que les ip sources du réseau sur lequel il est.

Déjà teste si le port est ouvert.

Bon ok,

Alors j’ai testé depuis le boulot car chez moi la commande telnet n’est pas acceptée.

Donc je tape : telnet monadressDNS.org 80 -> une fenêtre noire s’ouvre comme si la connexion avait réussi et que ca attendait quelques chose.

J’essaye la même chose mais à la place de 80 j’essaye 20 ou 21 ou22 et la il me met que la connexion n’a pas put être établie.

Donc j’imagine que tu as bien diagnostiqué l’affaire, les ports 20-21-22 ne sont visiblement pas ouvert correctement. Mais pourtant tout à l’air de fonctionner normalement… Est ce qu’il ne faudrait pas que j’essaye de les forwader aussi sur le router, il les bloque peut être???

Concernant le par feu livebox il est bien possible d’indiquer des adressages.
[Photo supprimée]
Edité le 08/03/2012 à 12:07