Forum Clubic

Au secours mon serveur FTP deconne! acces impossible depui... [resolu]

B’jour tout le monde,

Voila j’ai un serveur FTP hebergé sur un pc sous windows 2000 qui fonctionnait bien jusqu’a maintenant. Depuis hier soir (peut etre avant en fait je ne sais pas trop) plus personne n’a acces au serveur depuis l’exterieur. Je me suis dit que c’etait sans doute IIS qui petait un cable j’ai donc essayé avec typsoft mais rien n’y fait ca ne fonctionne pas.

Pour la connexion internet j’utilise une livebox avec deriere un routeur Linksys WRT54G. Sur tous les deux les port UDP et TCP 21 sont ouverts et redirigés correctement sur la bonne ip.

ftp://test:test@80.13.116.207

Si qqu’un a une petite idée d’ou ca peut venir…

Merci =) :bounce:

ton IP a changé ?

(c’est peut etre juste ça :D)

non non c’est mon ip d’en ce moment ca mais c’est pas le pb… vas voir ac un soft ftp tu vas voir il y a la banniere de bienvenue et apres une erreur =(

[R] List Error
[R] PASV
[R] 227 Entering Passive Mode (192,168,5,10,9,157).
[R] Opening data connection IP: 80.13.116.207 PORT: 2461
[R] Data Socket Error: Connection refused
[R] List Error

voila le log que ca donne sur ceux qui essaient d’y acceder :frowning:

pkoi avoir mis le port ftp sur 2461 ?

remet le port d’origine… ( 21 )

le port est sur 21

si tu veux c’est bizare il se connecte il y a la banniere de bienvenue et puis apres ca plante (tu peux voir ce que ca fait avec le lien que j’ai laissé plus haut)

bah moi je me suis connecté sans problème…

je vais essayer de te mettre un fichier de kelkes octets pour voir ce ça donner :wink:

c’est a n’y rien comprendre =X tu utilise quel client FTP ?

comme une lettre à la poste… je viens de te déposer le fichier testftp.txt

j’utilise filezilla… tout simplement :d

attend, je vais me connecter depuis mon serveur en ligne de commande now et remettre un bete fichier txt

Hum… merci :slight_smile: peut etre un bug au niveau de la connexion vu que je n’ai pas touché aux routeurs ^^

Juste un question, tu laisses le mode passif ou pas ?

tiens bizarre, depuis mon serveur je me connecte sans problème mais il bloque à l’upload du fichier :heink:

je retente une dernière fois :d

yep, je laisse le mode passif :oui:

oki merci :slight_smile:

passe pas…

est-ce ke le fichier testftp2.txt à été up ? j’en doute…

Bon ben je crois que je vais conclure par => vive l’open source qui est gratuit et au chiottes flashfxp payant et en anglais :smiley: avec filezilla un autre arrive a se connecter =)

non il n’a pas été up

bah là g essayé en ligne de commande depuis un systeme linux… connexion sans problème mais upload impossible… :fou:

c mystique ton truc kan meme…

tu as essayé un autre serveur ftp ? y a typsoft ftp server ki est pas mal du tout

tu vois a la fin de ta ligne 227 => entering… ben 192.168.5.10 c’est l’adresse assignée par la livebox au port wan de mon routeur mais pourtant la regle NAT est bien créée sinon tu n’aurais pas reussi a up tout a l’heure…

avec typsoft ca fais la meme chose… je me suis dis que c’etait surement win 2k qui merdouillé donc j’ai rebooter la bete mais tjs pareil j’ai aussi rebooté le modem et le routeur, recréé les regles mais rien n’y fait