Forum Clubic

Aide formules excel

Bonjour à tous,

1 - J’aimerai savoir comment faire des formules sur plusieurs feuilles excel ou, au mieux, sur plusieurs fichiers.

Exemple de ce que je veux faire avec une feuille1 et une feuille2 :

J’aimerai que la cellule A1 de la feuille1 EGAL la cellule A1 de la feuille2 * la cellule A2 de la feuille1.

2 - En plus, j’aimerai aussi savoir comment faire pour faire :

La cellule A1 = 4*7 si on retrouve la valeur de la cellule A2 quelque part entre la cellule A8 et Z8

Un peu schématisé sa donne sa sur la feuille excel :

 1     2 ---------- 8 (colonnes)

A 0 1478 4589
B 0 1459 1222
C 0 1359 1459
D 0 1222 4879

Ici, A1 = 0
B1 = 28
C1 = 0
D1 = 28

Car 1459 ce trouve dans la colonne 8 et 1222 aussi.
Edité le 28/04/2011 à 14:10

Dans a1 = !feuil2a1*a2

si on retrouve la valeur de la cellule A2 quelque part entre la cellule A8 et Z8
=si(nb.si(A8:Z8;A2)>0;4*7)

Cellule A1 de la feuille1 :
=Feuille2.A1a2
ou
=Feuille2.A1
Feuille1.a2

Merci à vous mais pour le 1er je ne sais pas pourquoi, mais vos formules ne fonctionnent pas chez moi…

J’ai fais un mix et j’ai trouvé =Feuil2!A1*A2 merci à vous 2 !

Sinon =si(nb.si(A8:Z8;A2)>0;4*7) fonctionne, merci djidji !

Encore plus dur ^^ !!

Voici l’exemple :

Si le nombre B2 de la feuille1 est trouvé entre les cellules A1 et A4 de la feuille2 (Donc =SI(NB.SI(Feuil2!A1:A4;B2)>0)

Imaginons ici que la valeur B2 de la feuille1 soit trouvée en A4 de la feuille2, je voudrai que le résultat soit le B4 de la feuille2 donc :
Feuil2!B4
Sauf que si la valeur aurai été trouvée en A1 de la feuille2, alors le résultat aurai été :
Feuil2!B1

Ce qui donnerai ceci : =SI(NB.SI(Feuil2!A1:A4;B2)>0;RESULTAT) avec “RESULTAT” variable selon où ce trouve la cellule trouvée et donc soit Feuil2!B1, Feuil2!B2, Feuil2!B3 ou Feuil2!B4

Possible ?
Edité le 21/04/2011 à 15:33

Désolé, c’est bien un ! et pas un . C’est parce que j’ai testé sur openoffice et y’a une légère différence avec excel…8)

Pas de soucis ^^. Pas d’idées sur ma 2ème demande ?

Pas très claire ta demande.

Donne un exemple :
Feuille1:B2 = 10

Feuille2:A1 = 10
Feuille2:A2 = 20
Feuille2:A3 = 30
Feuille2:A4 = 40

Le resultat doit apparaître dans la colonne B de la Feuille2

Donc
si tu as Feuille1:B2 = 10 le résultat sera 10 dans Feuille2:B1
si tu as Feuille1:B2 = 30 le résultat sera 30 dans Feuille2:B3
si tu as Feuille1:B2 = 40 le résultat sera 40 dans Feuille2:B4
si tu as Feuille1:B2 = 50 rien ne se passe

Est-ce que j’ai bien compris ???

Pas trop sur de ton exemple, voici le mien avec d’autres valeurs pour plus de détails (Tu as raison je ne me comprends pas moi même ^^) :

Si nous avons :

Feuille1:B2 = 10----Feuille1:C2 = 0

Feuille2:A1 = 10----Feuille2:B1 = 99
Feuille2:A2 = 20----Feuille2:B2 = 98
Feuille2:A3 = 30----Feuille2:B3 = 97
Feuille2:A4 = 40----Feuille2:B4 = 96

Alors Feuille1:C2 = valeur de Feuille2:B1 et donc = 99

Mais si on aurai eu

Feuille1:B2 = 10 ----Feuille1:C2 = 0

Feuille2:A1 = 40----Feuille2:B1 = 99
Feuille2:A2 = 30----Feuille2:B2 = 98
Feuille2:A3 = 20----Feuille2:B3 = 97
Feuille2:A4 = 10----Feuille2:B4 = 96

Alors Feuille1:C2 = valeur de Feuille2:B4 et donc = 96

Je pense avoir bien schématisé ce coup-ci ^^
Edité le 21/04/2011 à 17:24

Si j’ai bien compris,
tu mets en Feuille2!B1 --> =SI(Feuille1!$B$2=Feuille2!A1;Feuille2!A1;"")
puis tu reporte la formule sur les 3 cellues en dessous : B2, B3, B4


On s'est croisé..... je réléchis sur ton dernier post.

Je repars de ton exemple.
Le résultat sera dans la colonne C de la Feuille1

Dans la cellule Feuille1!C1 --> =SI(Feuille1!$B$2=Feuille2!A2;Feuille2!B2;0) mettre “” à la place de 0 si on veut une cellule vide
Puis reporter la formule sur les cellules C2, C3, C4

Bonjour,

Ca ne serait pas plus simple avec un RECHERCHEV ?

Un tuc du genre =RECHERCHEV(B2;Feuil2!A1:B4;2;FAUX)

Bon, évidemment ce n’est pas très joli quand B2 n’est pas trouvé dans A1:A4 car ça renvoit une erreur. :neutre:

[edit]
On peut remplacer le code d’erreur par un contenu vide avec cette formule :
=SIERREUR(RECHERCHEV(B2;Feuil2!A1:B4;2;FAUX);"")
ou remplacer le code d’erreur par un message plus clair du genre :
=SIERREUR(RECHERCHEV(B2;Feuil2!A1:B4;2;FAUX);B2 & " non trouvé")
[/edit]
Edité le 22/04/2011 à 02:04

Merci mais le résultat change vraiment selon la celulle de ce que l’on cherche. Voici un autre exemple en image, sa pourrai aider :

[Photo supprimée]

Les lignes de couleur c’est pour la conditions du calcule : Si on trouve cette référence dans la feuille 2, alors on fait la quantité * le poids de cette référence.

Le truc serai de récupéré le nom de la cellule ou ce trouve la référence et de l’incrémenter d’une lettre pour la prendre dans le calcule (Si REF trouvé dans B1, alors on prend C1 pour le calcule).
Edité le 22/04/2011 à 10:44

Ah ben c’est plus clair, comme ça. :super:

En C2 de la feuille1 :
=RECHERCHEV(Feuil1!A2;Feuil2!$A$2:$B$5;2;0)*Feuil1!B2

puis tu reporte la formule sur les cellules en dessous : C2, C3, C4, etc

Perfect !!! Merci Nostradamus !!

:jap:

De rien, ce fut un plaisir. :bounce:

Merci à vous 2 ^^

Bon j’ai une autre requête :

J’ai des cellules avec des calcules ce qui donne :

  • A
    

1 1*15.198

2 1*15.18

3 2*78.1

4 5*7.1

Et ce qui affiche donc :

  •    A
    

1 15.198

2 15.18

3 156.2

4 35.5

Ce sont bien des points et non des virgules (Très important)

Je voudrai faire en sorte, sans modifier les cellules (donc pas de GAUCHE=(“calcule”;3)), que j’ai d’affiché :

  •    A
    

1 15

2 15

3 156

4 35

Une idée ? Je suis en pleine recherche là car le bouton “réduire les décimals” ne fonctionne pas

Si tu mets 0 decimal, qu’est-c e que ça donne ??

Comment puis-je mettre 0 decimal ? Si tu parle de la touche “réduire les décimals” et bien elle ne fait rien du tout en faite. Comme si je ne cliquai sur rien. Le problème viens d’un Excel d’un collègue hollandais qui a un Excel Anglais et qui a recu, apparement, un tableau d’un Americain :pt1cable:

Moi je n’ai pas le soucis…