Forum Clubic

Xorg.conf sous gentoo impossible de génerer un fichier correct[Resolu]

Bonjour à tous,

je viens de passer l’après-midi a essayer d’installer les drivers nvidia sur ma machine et je bloque … Pas moyen de configurer un fichier xorg.conf correct il me sort toujours une erreur !

J’ai essayé xorg -configure => démarre pas

Xorg -config avec le choix des questions => pareil.

Je ne sais plus quoi faire est-ce que quelqu’un peut me mettre sur la piste ?

Merci :stuck_out_tongue:

quelle erreur ?

Par défaut donc en xorg -configure :

il me sort no mouse detect …

Il me dit de le modifier /dev/ ??? je ne sais pas le nom de la souris …

bon je retente un fichier a la main :kaola:

Tu as bien chargé les bons modules pour la souris ?!

Edit

Je vois surtout cette erreur fixed Unable to locate/open config file [/fixed]
Ton fichier de conf c’est bien /etc/X11/xorg.conf ?

oui bon je vais noter les erreurs a la main je crois que ca sera mieux …

Maintenant j’ai :

Failed to initialisize core device

:’(

Voila mon fichier de config et log ca sera plus facile a lire :

http://membres.lycos.fr/pctunning/linux/

Je l’ai renommé sinon je sais pas booter mais je l’ai bien nommé xorf.conf dans le dossier /etc/X11

Tu n’aurais pas le module rivafb de monté par hasard ?

Comment puis-je le voir ?

tu fais un lsmod.

[cpp]bash-2.05b# lsmod
Module Size Used by
nvidia 3917436 -
[/cpp]

(EE) Unable to locate/open config file

Il est bien en Read pour tous ton fichier /etc/X11/xorg.conf ?

Oui, je viens de tenter de désinstaller le package nvidia-kernel, j’ai ensuite relancer la compilation du drivers nvidia en le prenant sur le site de chez nvidia.

J’ai relancé X et la il m’affiche le logo Nvidia et il se coupe aussitôt :frowning: je vais réuploader mes fichiers log et xorg

Merci de votre aide …

EDIT: je vais changer la ligne nv en nvidia mais j’y crois pas trop :frowning: -> ca ne change rien j’ai une erreur sur le mouse encore ne peut pas trouver le /dev/mouse … :heink:

http://membres.lycos.fr/pctunning/linux/

essaye de mettre “/dev/input/mice” pour la souris. Essaye aussi un “modprobe psmouse” si tu as une souris PS/2 ou “modprobe usbhid” sur tu as de l’USB.

Pour installer les pilotes nVidia : “emerge nvidia-kernel nvidia-glx”

Si tu es sous gentoo, as-tu fais opengl-update nvidia ?

fixed Log file: “/var/log/Xorg.0.log”, Time: Sun Apr 10 20:59:48 2005
(EE) Unable to locate/open config file
[/fixed]

Ici il y a déjà un PB. moi j’ai çà :
[fixed]
(==) Log file: “/var/log/Xorg.0.log”, Time: Mon Apr 11 10:18:34 2005
(==) Using config file: “/etc/X11/xorg.conf”[/fixed]

Apparement, il y a déjà un PB de lecture de ton fichier de config.

Met ici le résultat de
ls -l /etc/X11/

Le problème est résolu, c’était 2 lignes a ajouter dans le modules.conf, je posterai ca ce soir .

Merci a tous.

gros malin :stuck_out_tongue:

lool j’ai quand même passé la journée a trouver …

J’ai trouvé çà sur un site perso free :

Remplacer :

[cpp] Identifier “Mouse1”
Driver “mouse”
Option “Protocol” “Auto”
Option “Device” “/dev/psaux”[/cpp]

Au lieu de /mouse et :

[cpp]dans le fichier /etc/modules j’ajoute
psmouse
mousedev[/cpp]

Qui apparament a été regénéré aujoud’hui en démarrant le pc et les lignes n’y sont plus :fou: mais enfin maintenant ça marche.

http://libretto.debian.free.fr/Unstable810.html

EDIT : désolé Dumbledore je n’ai pas su réponde hier soir, forum.clubic.com inacessible toute la soirée merci skynet :o