Forum Clubic

Xgl / Beryl / Debian Sid

Bonjour tout le monde,

J’essaie en vain de faire fonctionner Beryl sur mon portable équipé d’une Radeon Mobility. Après 2 jours d’essaie … j’en arrive à simplement essayer de démarrer un serveur Xgl.

Pour ce faire, j’ai installé le package Sid d’un serveur Xgl (celui suggéré par le wiki Beryl), ai compiler les driver 8.28 d’ATI pour mon noyau et ai configuré mon kdmrc avec ce paramétrage :

ServerCmd=/usr/bin/Xgl -fp /usr/share/fonts/X11/misc/ -br -ac -accel glx:pbuffer -accel xv:pbuffer

Mais (parcequ’il y a bien forcément un mais) le serveur X démarre, je peux bouger ma souris et après quelques secondes, le serveur X crash sans logguer quoique ce soit dans Xorg.xx.log, ni dans kdm.log.

Quelqu’un a-t-il déjà eu ce symptome ou mieux, a-t-il trouvé un bon tuto ?
Avec mes sincères remerciements (après deux jours de tests en tout genre, on est forcément très courtoi lorsqu’il s’agit de solliciter un peu d’aide)
Bonne année à toutes et à tous !

PS: xorg.conf


Section "Module"
        Load  "bitmap"
        Load  "ddc"
        Load  "dri"
        Load  "extmod"
        Load  "freetype"
        Load  "glx"
        Load  "int10"
        Load  "vbe"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[1]"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
        Screen      1
EndSection

Section "DRI"
        Mode         0666
        Group        "video"
EndSection

Section "Extensions"
        Option  "Composite" "0"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "off"
EndSection

je pense que tu devrais utilisé aiglx plutot que XGL…
si tu est en sid tu l’as depuis la version 7.1 de xorg.
(perso j’ai une nvidia, j’ai pas besoin de xgl ou aiglx, ça simplifie bien les chose :jap: )

edit : http://wiki.beryl-project.org/index.php?title=Install/Debian
le depos que j’utilise, mis a jour tres regulierement(version 0.1.5 actuellement) -> deb http://download.tuxfamily.org/3v1deb debian-unstable beryl-svn

J’utilise le même dépot. Et je ne peux pas utiliser AIXGL car il n’est pas supporté par les drivers ATI (j’ai ouvert un ticket chez AMD pour connaitre la dispo de ce support que nvidia propose). Sinon, çà me simplifierai bien les choses :slight_smile:

ouai, j’ai pas mal bidouiller xgl/compiz avant que beryl sorte(et les nvidia d’ailleurs).
un truc qui m’a aider c’est de lancer tout a la main pour voir les erreurs justement.
tu log en root, tu stop ton serveur X, et tu lance cette commande -> Xgl :1 -fullscreen -ac -accel xv -accel glx:pbuffer & DISPLAY=:1 xterm
(il ya ptet une modif a faire pour les ati)
si ça plante tu verra l’erreur, moi, apres je lancais aussi compiz a la main dans le xterm pour voir les erreurs.
ça permet de tester a peu pres etape par etape.
enfin c’est comme ça que j’avais reussi a le faire marcher. :neutre:

Ca marche, j’essaierai çà demain (mon portable est au boulot :D)
Par contre un truc me turlupine, pourquoi lancer Xgl sur le canal 1 ? Xgl:0 -fullscreen … devrait avoir le même effet !
Merci de ton assistance, les howto sont multiples sur la toile mais aucun n’est fiable à 100% ! Je mettrai le topic à jour si un jour j’y arrive :wink:

Bon après plusieurs heures de galère, j’ai trouvé un autre soucis.
Lorsque je démarre mon serveur Xgl à la main via la commande que tu m’as indiqué, çà ne marche pas. Le serveur crash sans logguer quoique ce soit après que X se soit initialisé.

Alors j’ai eu l’idée d’ajouter un sleep entre le lancement de Xgl et le xterm. Là, çà marche mieux. J’arrive à lancer KDE puis Beryl (même si ce dernier est immonde, les fenêtres sont toute blanche, je ne distingue rien mais c’est p’tet normal, il doit manquer plein de module)

Par contre, lorsque j’essaie de simplement démarrer le serveur Xgl avec kdm, je trouve çà dans le daemon.log :


Jan  4 11:46:02 localhost kdm[4268]: X server startup timeout, terminating
Jan  4 11:46:02 localhost kdm[4268]: X server for display :0 can't be started, session disabled

Globalement kdm n’arrive pas à contacter le serveur X parceque ce dernier n’a pas fini de démarrer. Et lorsque c’est le cas, la session se termine par kdm. Voilà pourquoi çà merdouaille. J’ai tenté d’ajouter ces options dans mon kdmrc


OpenDelay=30
OpenTimeout=160

Pour rallonger le timeout, mais sans succès. Je vais ouvrir un topic sur kde-forum parceque j’ai pas trouvé grand chose sur le net …

Bon, pour l’instant, après 2 jours de prise de tête, j’ai décidé de laisser partiellement tomber. Xgl avec une ATI, pas facile …

Mais j’ai ouvert un ticket d’incident chez ATI. Il m’ont indiqué qu’il me fallait remplir un formulaire présentant les anomalies que je rencontre : pas de soucis, motivé …

Jettez un oeil au lien qu’il m’ont donné : http://support.ati.com/ics/survey/survey.a…ID=491&type=web

Y’a un truc qui manque dans la liste des OS : Linux !!! Bah oui, on peut ouvrir un incident pour Windows mais pas pour Linux … :super: ATI :sweet:

La politique d’ATI concernant Linux, voila quoi… De mon côté, j’ai vraiment été surpris de la facilité pour faire tourner Beryl avec du nVidia. Je suis sous Mandriva, tu installes les pilotes nVidia, les depôts Beryl, tu installes 4 paquets, et hop, ça fonctionne (ou presque, il y a quelques lignes à ajouter dans le xorg.conf).

Si ATI se décidait enfin à faire quelque chose pour Linux, ce serai une bonne chose. En attendant, je ne veux pas entendre parler de ces cartes (idem sous Windows vu la tronche des drivers).