Forum Clubic

"xcopy /D" vers un serveur samba - depuis windowsXP

j’ai un tres leger soucis au niveau de mon serveur samba.

J’utilise un batch appelant la commande xcopy pour faire une copie de sauvegarde de mes documents.

Normalement avec le parametres /D la copie ne s’occupe que des nouveaux fichiers ou ceux modifiés dont la date est posterieure a celle du fichier sur le serveur.
Ca fonctionne parfaitement en local, mais vers le serveur samba c’est comme si le /D n’existait pas. Quand je regarde les proprietes des fichiers sur le serveur il m’indique bien la date que je vois sur les doc en local (donc normalement un fichier à ne pas copier, ce qu’il fait malgre tout)

Vu que ça marche en local, je suppose qu’il s’agit d’une configuration au niveau de Samba (ou de Linux) pour permettre un entiere prise en compte de ce parametre, mais là je seche totalement. alors si quelqu’un peut m’aider, ce serait sympa :ane:

Merci

PS:

Distribution: MDK10.1
Samba 3.07
Partition ext3

Ton disque de destination est en NTFS ?

J’ai vu dans Total Commander que la NTFS a un décalage d’une heure sorti de je ne sais où… :ane:

le disque source est en NTFS (WindowsXP) la destination en Etx3 (Linux MDK)

et ce n’est pas l’affaire d’une heure… :neutre:

petit UP au cas où :ane:

J’espère que cette page va faire ton bonheur :
http://www.faqs.org/docs/samba/ch11.html
On y trouve toutes les infos sur les paramétrages du temps dans samba.

ah yes en voilà une reponse qui m’a l’air bien.

Je teste ça dès ce soir :slight_smile:

Merci

:frowning: ça ne change rien … zut je ne comprends pas pourquoi ça ne veut pas là :pfff:

Alors là j’ai peur de ne pas savoir.
Et si tu contactais la mailing list des développeurs samba ? Ils connaissent peut être le problème, et si ce n’est pas le cas, j’imagine la joie que tu éprouveras à avoir participé à la résolution de ce bogue (potentiel) !

je vais encore faire des essais… et si j’ai pas de resultats j’opterais pour cette solution

:jap: