Forum Clubic

Wubi problème d'installation

Bonjour,

J’ai essayé d’installer ubuntu via wubi pour pour jongler avec windows mais j’ai un message d’erreur à l’installation.

http://img249.imageshack.us/i/linux.jpg/

J’ai copié la fin du log en question (ca ne me parle pas vraiment)

07-11 12:53 DEBUG WindowsBackend: Copying C:\DOCUME~1\Sasarai\LOCALS~1\Temp\pylD.tmp\data\custom-installation -> C:\ubuntu\install\custom-installation
07-11 12:53 DEBUG WindowsBackend: Copying C:\DOCUME~1\Sasarai\LOCALS~1\Temp\pylD.tmp\winboot -> C:\ubuntu\winboot
07-11 12:53 ERROR TaskList: writelines() argument must be a sequence of strings
Traceback (most recent call last):
File “Z:\home\evan\bzr\wubi.trunk\build\wubi\files\lib\wubi\backends\common\tasklist.py”, line 196, in call
File “Z:\home\evan\bzr\wubi.trunk\build\wubi\files\lib\wubi\backends\win32\backend.py”, line 152, in copy_installation_files
File “Z:\home\evan\bzr\wubi.trunk\build\wubi\files\lib\wubi\backends\common\utils.py”, line 257, in replace_line_in_file
TypeError: writelines() argument must be a sequence of strings
07-11 12:53 DEBUG TaskList: # Cancelling tasklist
07-11 12:53 DEBUG TaskList: # Finished tasklist
07-11 12:53 ERROR root: writelines() argument must be a sequence of strings
Traceback (most recent call last):
File “Z:\home\evan\bzr\wubi.trunk\build\wubi\files\lib\wubi\application.py”, line 55, in run
File “Z:\home\evan\bzr\wubi.trunk\build\wubi\files\lib\wubi\application.py”, line 129, in select_task
File “Z:\home\evan\bzr\wubi.trunk\build\wubi\files\lib\wubi\application.py”, line 155, in run_installer
File “Z:\home\evan\bzr\wubi.trunk\build\wubi\files\lib\wubi\frontends\win32\frontend.py”, line 137, in run_tasks
TypeError: writelines() argument must be a sequence of strings

Si quelqu’un peu aider :slight_smile:

http://img249.imageshack.us/img249/1356/linux.jpg


[http://img249.imageshack.us/img249/1356/linux.th.jpg](http://img249.imageshack.us/i/linux.jpg/)
[[img=http://img249.imageshack.us/img249/1356/linux.th.jpg]](http://img249.imageshack.us/i/linux.jpg/)

bugs.launchpad.net…

Jette un petit coup d’œil ici. À priori ça peut venir de :

  • installation sur une FAT32 avec plus de 4GB pour le disque virtuel (FAT32 supporte pas)
  • utilisation d’une langue dans Wubi qui n’est pas installée sur Windows.

Merci beaucoup

Le problème était bien lié à la langue. Je cherchais à installé Kubuntu en anglais avec un windows français.

(Cela dit, j’espère que le bug sera fixé un de ces 4 :stuck_out_tongue: Tu peux par contre changer la langue après l’installation sans aucun problème).