Forum Clubic

Windows x64: pilote non signé à l'installation

Bonjour,

J’essaie d’installer un Windows Server 2008 R2 (mais je poste dans la section “Windows7” car c’est pareil) mais il ne détecte pas mon disque dur. J’ai un CD de pilotes, mais il ne veut pas les charger car ils ne sont pas signés par Microsoft.

J’ai démarré avec F8 et sélectionné l’option pour lui dire de ne plus me casser les c**** avec ça, mais ça ne marche pas. Je trouve ça quand même débile, c’est quand même un OS de serveur, normalement le type qui l’utilise il sait ce qu’il fait. Il devrait y avoir uniquement un avertissement et puis c’est tout.

Avez-vous une solution?

Merci d’avance.

sur quel type de machine essaye tu d’installer windows server 2008, il faut que tu fournisse au système des drivers compatibles windows server 2008 R2 x64, sinon il refusera de les installer.

Bonjour,

Je l’installe dans une machine virtuelle avec un disque paravirtualisé (il nécessite des pilotes).
Je peux laisser le disque en émulation classique, à ce moment là ça passe mais les perfs sont diminuées.

La machine virtuelle c’est KVM (sur Linux) et il y a des pilotes pour la paravirtualisation mais ils sont compilés par des développeurs du monde libre qui n’ont pas envie de verser des sous à Microsoft pour faire signer leurs pilotes.
Edité le 29/07/2010 à 10:09

Bonjour .

Je n’ai pas Windows server 2008 , mais regarder si la commande

bcdedit /set Nointegritychecks on fonctionne .

Il n’est plus possible de désactiver la vérification de signature des drivers sur Windows 7 x64 (et donc aussi sur 2008 R2) avec la commande bcdedit (ça marchait avec les versions beta mais ça ne fonctionne plus avec la version finale).

L’appui sur la touche F8 pour avoir le menu de démarrage et sélectionner “Désactiver signature…” doit fonctionner mais il faut le faire à CHAQUE démarrage.

Il y a peut être des solutions quand même, voir cet article (en anglais) : http://www.raymond.cc/blog/archives/2009/08/24/loading-unsigned-drivers-in-windows-7-and-vista-64-bit-x64/

Bonjour .

Une autre solution :

Installer et lancer EasyBCD 2.0.1
www.clubic.com…

Cliquer sur Advanced Settings , puis sélectionner Windows 7 ( si plusieurs OS) .

Cliquer sur Advanced , puis cocher la case

Allows installation of unsigned drivers on 64-Bit indows , et enfin

Save Settings

Cette solution ne fonctionne pas.
Windows seven se lance toujours en mode normal