Forum Clubic

Windows 10 ? accès au bureau en mode « tablette »

Bonsoir à tous,

Lorsque je suis en mode « Tablette », que je fais un clic droit sur l?icône « Windows », et que je clique ensuite sur « Bureau » dans la liste déroulante, j?accède à un bureau totalement vide.
Pourtant quand je ne suis pas en mode « Tablette » et que j?accède au bureau, ce dernier comporte un certain nombre de dossiers (corbeille, explorateur, divers raccourcis perso ?).

L?un d?entre vous peut-il me dire comment faire pour arriver à ce bureau non vide en mode « Tablette ».

Sinon, si je me mets en mode « Plein écran », est-il possible de faire démarrer « par défaut » le PC sur ce mode et pas sur le bureau ?

Merci d?avance.

Claude

Ben, par définition, le “mode tablette” est là pour retrouver (peu ou prou) la manière qu’on connaissait sous Windows 8.x, à savoir des applications en plein écran (ou plusieurs en écran partagé) et un Bureau composé des tuiles vers les applications épinglées (soit du Store, soit des applications classiques).

Maintenant, si ce que tu veux, c’est le menu Démarrer en plein écran mais en conservant le mode “Bureau classique”, tu as une option pour ça dans les Paramètres (ça doit être dans la section “Personnalisation”, rubrique “Accueil”).
Si tu veux démarrer ton compte d’utilisateur par défaut en mode tablette, même si tu utilises un PC normal sans écran tactile, tu le peux aussi (là, c’est dans la première section des Paramètres, rubrique “Mode tablette”, que tu as un interrupteur pour ça).

Bonjour et merci Trit34.

En fait ce que je souhaite, si c’est possible, c’est d’avoir par défaut accès au menu démarrer en plein écran à chaque démarrage du PC.
C’est ce que fais l’option “Tablette”.
Mais lorsque je suis en mode Tablette, je ne peux plus accéder à mon bureau classique. J’arrive seulement sur un bureau totalement vide.

Encore merci de ta collaboration.

salut, tu as essayé ce que t’a donné Trit34

[quote=Trit34]menu Démarrer en plein écran mais en conservant le mode “Bureau classique”, tu as une option pour ça dans les Paramètres (ça doit être dans la section “Personnalisation”, rubrique “Accueil”).
[/quote]
l’option “Utiliser le menu démarrer en plein ecran”

si cela te convient hors le fait que cela ne s’ouvre pas directement, j’ai bien une méthode pour ouvrir le menu démarrer au démarrage du pc mais cela le fait qu’en fin de chargement de windows

si tu veux tester :
faire un script powershell : bouton droit -> nouveau fichier texte -> nom finissant par .ps1

mon fichier test.ps1 contient


$wshell = New-Object -ComObject wscript.shell;

$wshell.SendKeys("^{Esc}")

on declare en ligne 1,
on envoie l’info que les touches ctrl+ esc ont été enfoncées en ligne 2 (la touche “windows” c’est ctrl+echap en fait)
ce script simule donc l’utilisation de la touche windows

pour qu’il s?exécute :
faire un raccourci : bouton droit -> nouveau raccourci avec comme action
powershell.exe -ExecutionPolicy unrestricted -File “C:[b]le_chemin_exact_vers_testps1[/b]\test.ps1”

mettre ce raccourci dans C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp (tu peux copier ce chemin dans la barre d’adresse de l’explorateur windows si tu ne vois pas c:\programdata qui est un repertoire caché)

mais comme je l’ai dit, cela execute ce script en dernier au démarrage (peut etre qu’il faudrait tenter de le lancer par la base de registre??)

Bonsoir,
Oui j’ai fait la méthode de Trit34.
Mais cela ne m’amène pas au menu démarrer par défaut au démarrage du PC.
J’ai essayé également le mode tablette. Dans ce cas au démarrage j’ai bien pas défaut l’écran avec les tuiles.
Mais en cliquant sur le bouton “Démarrer” et en choisissant “Bureau” dans la liste, j’accède bien à un écran style Windows 7, mais écran totalement vide, alors qu’il devrait comporter différentes icones (corbeille, explorateur et accès à diverses applications). Peut-être un bug lié à W10 qui se solutionnera dans le temps lors de MAJ.
J’y connais rien en informatique et je n’ose pas me lancer dans ta méthode, et je ne comprends pas bien l’histoire du script qui se fait en dernier au démarrage … au démarrage du PC, ce sera l’écran démarrer ou l’écran classique qui s’affichera ?
Encore merci de vos collaborations.
Claude

De ce que je crois comprendre, le script est censé actionner l’ouverture du menu Démarrer. En le plaçant dans le dossier “Démarrage” de ce même menu (c’est-à-dire dans “C:\Users[i]TonCompte[/i]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup”), et pour peu que tu règles le menu pour s’afficher en plein écran, il devrait se passer ceci lors des prochaines ouvertures de ton compte : le Bureau se charge avec ses icônes et tout, puis le menu Démarrer s’ouvre et tu as les tuiles sur ton écran.

Ça coûte rien d’essayer, je dis. :neutre:

si tu veux simuler l’action du script tu appuis sur la touche ctrl , que tu maintiens enfoncé puis appuis sur echap/esc
cela ne fait que cela

quand je dis qu’il se lance tard cela veut dire : mon windows se charge jusqu’à mon code pin de 4 chiffres -> le bureau apparait directement quand je tape le dernier chiffre, je pourrais commencer a faire ce que je veux, qq secondes plus tard (- de 10 en gros, cela depend peut etre simplement du nombre de truc au demarrage) le script ouvre l’accueil.

a mon avis autant appuyer soit même sur la touche windows cela irait plus vite

mais peut être qu’en le mettant dans la base de registre il serait lancé plus tôt, je ne connais pas l’ordre de lancement des logiciels du démarrage de windows mais il doit surement y en avoir un car tout ne se lance pas en même temps
c’est peut être un enchainement du style :
base de registre section machine -> base de registre section utilisateur(user) -> taches planifiées au démarrage -> répertoire démarrer ou j’ai mis le raccourci
Edité le 02/12/2015 à 13:12

Bonsoir et merci à tous les deux.
Un script powershell est de l’hébreux pour moi.
Je vais me satisfaire du truc classique: mon PC s’ouvre sur le menu bureau au démarrage et ensuite je clique sur le bouton windows pour avoir le menu démarrer en plein écran.
Je me trouve un peu exigeant dans mes souhaits … alors je vais faire simple.
Encore merci pour votre aide et vos suggestions.
Claude

Ce n’est rien d’autre qu’un bête fichier texte mais dont l’extension est PS1 au lieu de TXT. :neutre: Je t’assure : c’est vraiment pas plus compliqué que ça.

T’as qu’à recopier ce qui est dans le cadre rose plus haut, le coller dans le Bloc-notes, enregistrer sous un nom tel que “Menu Démarrer.ps1” (en veillant bien à choisir “Tous les fichiers (.)” dans la liste “Type de fichiers”) et c’est tout. Après, tu copies ou crées un raccourcis dans le dossier “Démarrage” dont j’ai donné les coordonnées plus haut (pour plus de sûreté, je le redonne en utilisant les variables utilisateur : “%UserProfile%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup”, à entrer directement dans la barre d’adresses de l’Explorateur pour y accéder directement).

Tu as tous les outils et modes d’emploi, maintenant. À toi de t’en servir comme on te l’a indiqué ou non, mais tu as ce que tu cherchais.

Merci à nouveau.

Dans le copier / coller du cadre rose, faut-il également reprendre les termes en rouge et <c/code> ?
Et le chemin d’accès au dossier “Démarrage” n’aboutit pas.
Par déroulement, j’arrive jusqu’à “%UserProfile%AppDataRoaming”.
Mais à ce stade je ne peux pas aller plus loin vers “MicrosoftWindowsStart MenuProgramsStartup” car non proposé.

Je ne veux pas te déranger plus, mais merci pour ton suivi et tes conseils.

:hello:

Non. :wink:

Curieux. Tu as activé l’affichage des fichiers cachés dans les Options des dossiers ? Parce que si j’essaie de coller le chemin dans la barre d’adresses de l’Explorateur (sans copier les guillemets), ça me mène bien au bon dossier.

Non, et tu peux pas sélectionner ces balises : ça fait partie de l’image de fond du cadre.

L’affichage des fichiers cachés est bien activée.

Mais en relisant toutes les réponses, j’ai l’impression que je dois créer un nouveau raccourci.
" pour qu’il s?exécute : faire un raccourci : bouton droit -> nouveau raccourci avec comme action
powershell.exe -ExecutionPolicy unrestricted -File “C:le_chemin_exact_vers_testps1test.ps1”.

Je comprends plus trop ce qu’il faut faire.

Bonne soirée.

j’ai voulu affiner mon truc et retester : bah cela marche pas comme il faut, faut que je lance le raccourci en administrateur pour que cela marche sur mon pc (alors que sur le pc ou j’avais fait mes tests cela n’était pas le cas)
sur mon pc, cela fait l’action mais l’accueil ne s’ouvre pas
c’est un win10 famille sur lequel cela marchait, le mien est un win10 pro je ne sais pas si c’est ca, je ne comprends pas pourquoi j’ai cette difference

donc je viens de tester par une tache planifiée : cela fonctionne et c’est même plus rapide à le faire après le démarrage du pc
il faut donc toujours avoir ce fichier de script .ps1 (j’ai essayé de m’en passer avec l’argument -command de powershell mais je n’y suis pas arrivé pour l’instant)

pour faire la tache planifié :
bouton droit sur demarrer
dans l’accueil taper tache ou plani
lancer le “planificateur de tâche”
a droite dans les actions : “créer une tache…”

onglet general
en nom j’ai mis “accueil” (ce sera le nom de la tache)
en bas faut cocher : exécuter avec autorisation maximale

onglet déclencheur : faire nouveau en bas:
et choisir : “a l’ouverture de session” comme choix pour lancer la tache

onglet action : faire nouveau en bas
le programmes a lancer : C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe
ajouter les arguments : -ExecutionPolicy unrestricted -File “C:\LE_CHEMIN_VERS_TON_FICHIER_PS1\test.ps1”
en image :
http://tof.canardpc.com/preview2/1afb1ab3-cfe0-4741-bd87-a1467b2ce934.jpg

C:\LE_CHEMIN_VERS_TON_FICHIER_PS1\test.ps1 est bien sur a modifier en fonction de la ou tu as mis ton fichier .ps1 et le nom que tu lui a donné
j’ai utilisé le répertoire mes documents, si j’avais ce nom d’utilisateur windows cela me donnerait un argument genre :
-ExecutionPolicy unrestricted C:\Users\Feunoir\Documents\test.ps1
Edité le 05/12/2015 à 11:00

Merci Feunoir de ces explications très précises avec les copies d’écran.
J’ai suivi ta procédure.
Mais au démarrage du PC, j’arrive toujours sur le bureau classique (type Windows 7) et pas PAR DEFAUT sur le bureau “Démarrer” avec les tuiles / vignettes en plein écran.
Mais je ne veux pas déranger plus, tu as avec Trit34 tout fait pour répondre à ma demande.
Bonne fin de dimanche et encore merci.
Claude

Ne t?inquiète pas, j’ai appris pas mal de truc (je trouvais powershell pas terrible, trop compliqué pour le résultat, mais en fait c’est ultra puissant cela compense sa complexité)

Au cas ou, il y a 2 tests a faire pour essayer de voir ce qui ne marche pas:

  • test du script : bouton droit sur le script puis “executer avec powershell”
    -> l’accueil doit s’ouvrir
    si cela ne marche pas il y a déjà un problème ici

  • la tache aussi est testable directement
    dans le planificateur de tache tu retrouves le nom de la tache
    tu fais bouton droit dessus :

  • si cela ouvre le menu contextuel tu fais “exécutez”
  • sinon si rien ne se passe il faut faire un double clic gauche sur le nom (cela devrait passer en mode “bibliothèque du planificateur”) et la le bouton droit fonctionnera pour faire executez

si cela ne marche pas :
déjà dans mon dernier message, tout en bas j’ai oublié les " " autour du chemin dans l’argument a mettre
-ExecutionPolicy unrestricted “C:\Users\Feunoir\Documents\test.ps1”

le mieux c’est de tester ta ligne de commande dans l?interpréteur de commande (en mode admin)
faut lancer cmd.exe (faut juste taper cmd apres avoir cliqué sur le bouton demarrer, faire bouton droit sur interpreteur de commande et “executez en mode administrateur”)
dans l?interpréteur de commande tu copies colles le texte que tu as mis dans la tache, dans action, en ajoutant un espace entre programme/script et argument
pour moi cela donnerait un truc comme cela (argument en gras, programme/script pas en gras, un espace entre les 2(avant le -))
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -ExecutionPolicy unrestricted -File “C:\Users\Feunoir\Documents\test.ps1”
la fin dépend évidemment de ton nom de fichier script et du chemin qui y mène

Bonsoir … donc je ne m’inquiète pas.
Les différents test suggérés ont été concluants après une correction du nom du script dans les arguments (faute de frappe de ma part).
Mais toujours pas accès à l’accueil voulu.
Je suis retourné dans la tache planifiée et j’ai consulté les différents onglets.
Dans l’onglet “Conditions” était cochée la case “Ne démarrer la tache que si l’ordinateur est relié au secteur”.
J’ai décoché cette case car je n’étais pas relié au secteur. Je suis sur la batterie (PC portable).
Et la … HOURRAH, ça fonctionne.
Seul petit hic, quelques secondes d’attente avec l’apparition d’un écran bleu ayant pour titre: C:WindowsSystem32WindowsPowerShellv1.0powershell.exe.
Mais bon, faut quand même pas être trop exigeant.
A part ces quelques secondes, j’ai ce que je souhaitais et cela grâce à toi.
Une nouvelle fois un grand merci pour ta compétence, la qualité des informations données et pour la patience.
Claude

tu peux ajouter -windowstyle hidden en début d’argument dans l’action avant -ExecutionPolicy

elle s’ouvre toujours mais c’est si rapide que tu ne vois pas le bleu ni le nom (c’est mon cas en tout cas)

Y a comme choix
-WindowStyle
Définit le style de fenêtre sur Normal, Minimized, Maximized ou Hidden.

dans chaque cas elle s’ouvre puis fait l’action (minimized : elle se réduit dans la barre de tache, mais c’est plus long que hidden)

pour avoir un disparition total faut passer par un script vbs ou un exécutable fait pour cela (mais la autant prendre/faire un exécutable qui fait ce “sendkey” directement)

sinon pour l’attente avant l’exécution tu peux peut être aussi essayer avec d’autres types de déclencheur de la tache, y en a peut être un qui se ferait un poil plus tôt.
Edité le 08/12/2015 à 14:16

l’argument -windowstyle hidden n’a aucun effet et l’écran bleu avec le titre reste aussi longtemps … si on peut dire longtemps car c’est environ 10 à 15 secondes.
J’avais essayé également “au démarrage” comme type de déclencheur, mais rien de mieux.
Mais c’est très bien comme cela … je suis totalement satisfait.
Peut-être à une autre fois pour une autre question.
Bien cordialement
Claude