Forum Clubic

[Wifi] probème d'install Mini PCI Askey

Bonjour,

j’aimerais enfin faire fonctionner mon wifi sur mon portable mais j’ai quelques difficultés …

bon déjà voici le modèle de mon chipset
http://service.packardbell.fr/items/index.php?PibItemNr=spec_Askey_WLL3070&PibItemParent=platform_NR1_DC#show

si je fais un lspci j’obtiens ceci :
0000:00:00.0 Host bridge: ATI Technologies Inc RS300 Host Bridge (rev 02)
0000:00:01.0 PCI bridge: ATI Technologies Inc Radeon 9100 IGP AGP Bridge
0000:00:13.0 USB Controller: ATI Technologies Inc: Unknown device 4347 (rev 01)
0000:00:13.1 USB Controller: ATI Technologies Inc: Unknown device 4348 (rev 01)
0000:00:13.2 USB Controller: ATI Technologies Inc: Unknown device 4345 (rev 01)
0000:00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
0000:00:14.1 IDE interface: ATI Technologies Inc: Unknown device 4349
0000:00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 434c
0000:00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4342
0000:00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC’97 Audio Controller
0000:00:14.6 Modem: ATI Technologies Inc IXP AC’97 Modem (rev 01)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc RS300M AGP [ Mobility Radeon 9000IGP]
0000:02:04.0 Network controller: Agere Systems (former Lucent Microelectronics): Unknown device ab34
0000:02:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

après quelques googlerie, j’ai l’impression que la seule méthode que je pourrais utiliser est ndiswrapper mais comment faire avec des drivers qui sont seulement au format .exe ?

wine ? :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue:

je vois la porte… j’y arrive… ca yest chuipula

up :slight_smile:

switcher: j’ai essayé avec wine ^^
lancement de l’install des drivers, après go dans le dossier tmp de wine et là y’a bien les fichiers INF,SYS & co mais quand je l’install avec ndiswrapper j’ai le droit à un beau Hardware NOT present :frowning:

Salut,
j’ai la “chance” d’avoir moi aussi un easynote G13je sais pas combien…
et moi aussi je souhaite passer sous linux
j’ai installer mandrake et la carte wifi n’est pas reconnue : jusque là : tout pareil que toi.
j’ai peut être une solution mais je sais pas si ça marche. je l’ai pas encore essayer parce que j’y connais rien à Linux et je sais pas encore utiliser des .tar.gz et je pensais faire ça un autre jour mais si tu as envie d’essayer tiens moi au courant.
j’ai trouver ça sur internet en tapant “ndiswrapper” sur google :
un lien vers des drivers agere linux :
http://www.agere.com/mobility/wireless_lan_drivers.html
j’ai téléchargé la version 7.22
si tu l’installes, dis-moi si ça marche.
@+

salut yohplala,

merci pour le lien mais en fait j’avais déjà été sur le site d’Agere, mais c’est pas les bons drivers apperemment :confused:

Dans le readme

 The driver in this package supports the network interface cards based on:
     - WL60010, a.k.a. Hermes-II
     - WL60040, a.k.a. Hermes-II.5

et nous c’est la WLL3070 …

snif snif

Bon, j’ai fait d’autres recherches. Je suis tomber sur un site qui liste pratiquement toutes les cartes wifi et qui donnent lesliens vers d’autres sites où on peut trouver les drivers :
http://linux_wless.passys.nl/
Là, je n’ai pas trouver la Wll3070 mais il y a plusieurs autres askey : on voit que la majorité n’ont pas de drivers linux, par contre il y en a une : la wll3020 dont des drivers sont à l’étude. Ils donnent le lien :
http://madwifi.sourceforge.net
Reste à savoir si nous aussi sur notre carte, c’est bien un chipset Atheros.

Bon alors je confirme : je suis allé rentrer mon numéro de série sur le site de packard bell : j’ai appris que j’avais un easynote G1320 et que la carte wifi, c’est une atheros AR5001 802.11 B/G bon, il y a quand même un truc qui m’étonne, c’est que sous XP, il m’affirme avoir un débit de 11 Mb/s , donc plutôt du wifi B : je vais d’abord les installer sous XP, les drivers proposés par Packard Bell, puis si ça marche toujours, j’irai sur l’adresse que je t’ai donnée précédemment pour voir s’il y a moyen de moyenner.
@+

bon, sous windows, avec les drivers pour ce chipset, ça marche.

t’as raison j’ai aussi été rentré mon numéro de série sur le site et c’est bien une carte Atheros AR5001 802.11B/G

faut que je recommence mes recherches alors :stuck_out_tongue:

edit: faut regarder du côté de madwifi
http://lea-linux.org/trucs/item.595.html

Pas cool : j’ai essayer de faire comme ils disent à l’adresse e tu as donné, mais ça ne marche pas vraiment : toutes les étapes à faire avec la console, aucun problème, mais ensuite quand il faut configurer la carte, j’ai l’impression qu’il ne la reconnait quand même pas.
l’utilitaire de configuration demande quel modèle est-ce. j’ai repéré un modèle du nom de ath_pci, ni une ni trois, j’essaye, mais ensuite il me demande soit de configurer à la main, soit de manière automatique :
je coche automatique : ça ne veut pas et ça revient au début en me demandant quelle type de carte c’est.
j’essaie à la main, mais il me pose des questions auxquelles je ne sais pas répondre : countrycode ? …etc