Forum Clubic

Whax impossible d'initialiser ma carte wifi

salut

un copain ma demandé de boot sur son cd car son pc y’arrivait pas.

le mien boot bien il me demande de m’authentifier ce que je fais

j’ai un centrino et a lire certain commentaire sur le net c’est aps de la tarte pour faire reconnaitre le chipset wifi

j’ai un ipw2200

juste apres mettre authetifier je tape : linux load=ipw2200 , noapic , nocmcia

ce qui devrait me faire reconnaitre ma carte

hors j’ai un message qui me dit bash~ : linux = no command found

est ce normale ? est ce que quelqu’un peut m’aider j’aimerai vraiment arrivé a franchir cette etape

merci bien

  1. Peux tu parler français? Tu sais cette langue étrange qu’on parlais autrefois sur les forums? :wink: Je ne parle pas des fautes de frappes (on s’en fiche) mais de tout le reste :frowning:

  2. J’ai un portable avec une carte wifi ipw2200 qui fonctionne parfaitement sous debian sid avec un noyau 2.6.14. Pour t’aider, il va donc me falloir savoir quelle distribution tu utilises.

“linux load=ipw2200 , noapic , nocmcia” : D’où sors tu cette syntaxe étrange? Ca resemble un peu à des options qu’on passe au noyau pendant le boot mais pas du tout à une ligne de commande à taper après s’être loggé.

je pense pas parler une autre langue, et ecnore désolé pour le fautes de frappes :MDR

j’utilise le live-cd Whax basé sur une slax

oui en effet cette command permmettrait de faire détecter ma carte wifi

je suis désolé de ne pas avoir ta culture dans le monde linux, mais j’ai bettement :neutre: recopié ce qu’il se disait sur les forum…

premier exemple

exemple 2

en espérant que tu puisse m’aider… :sarcastic:

Relis attentivement ces docs.
Cette commande est à passer au boot et non après l’identification :

D’ailleurs, la commande suivante suffit pour détecter ta carte (les autres arguments n’ont aucun rapport avec le wifi) :

 linux load=ipw2200 

ouais je suis bien d’accord qu’il faut taper ca avant l’authentification mais j’essai à plusieur moment mais je dois pas trouver le bon, et c’est indiqué null part!

avant le chargement du système, tout au début, tu tapes [esc] et là tu dois avoir de quoi rajouter des options. Il faut qu’on sâche si tu utilises grub ou lilo.

Sinon, le plus simple est d’attendre la fin du boot , après être loggué et de faire
(en root)
modprobe ipw2200

Résumé:
tu démarres, tu donnes le mot de passe root (ou tu fais su + mot de passe root )

et tu tapes la commande
modprobe ipw2200
et tu te retrouveras au même point que si tu avais passé l’option load=ipw2200

euh merci pour l’explication

mais quand je tepa modprobe il me met une erreure :"fatal : module ipw2200 not found"

pourtant ils disent y arriver ! pourquoi pas moi?
j’suis tant que ca un boulet !

Ah :frowning: C’est sur que si tu n’as pas le driver tu vas avoir du mal à configurer le wifi :confused:
C’est quoi comme noyau exactement ?
(uname -a )

Sur un noyau 2.6.13 de SuSE c’est ok pour le wifi.

apres avoir tapé cette commade voila ce que j’obtient

–> linux slax 2.6.11.8 #1 smp sun jul 10 00:29:57 local time zone must be set-seezic i686 unknown gnu/linux

mais normalement le wifi des centrino est pris en compte dans la whax !

oui, et ton noyau devrait le permettre aussi.

Fais ça :
find /lib/modules/2.6.* -name ipw*

il ne me trouve aucun resultat plutot embettant ! non?

sous windows quand je parcours le cd y’a rien dans module mais c’est dans un autre repertoire “optionnal”

Bah oui!
Ca veut dire qu’il n’y a pas de driver :frowning:

Essaie avec ça :
find /lib/modules/ -name ipw*

Edit: tu es sûr que la compatibilité centrino c’est pour l’économie d’énergie seulement ou pour toutes les fonctions (wan… )

Sinon, je te suggère de prendre une autre distribution :confused: Mandriva ou SuSE sont ok avec le centrino et le wifi

puisque tu en parle je vien juste de finir mon instal de la mandriva et quand je reboot il plante!

j’ai un “L” qui attend sans rien faire… donc je peux meme plus acceder a mon windows ni a la mandriva !

edit

je crois que le monde de linux ne veux pas de moi…

sous windows quand je parcours le cd y’a rien dans module mais c’est dans un autre repertoire “optionnal”

Ah :frowning:
C’est vrai que tu cumules!
Je sais d’où ça vient.
C’est assez facile à corriger… avec un peu d’expérience :confused:

Reboote sur le CD d’installation, et vas directement dans “installation de l’amorçage” ou un truc comme ça, et re mets de l’ordre dans le secteur d’amorce. Peut être il te faudra changer les options proposées.

Tu utilises la version 2006 de mandriva?

oui la version 2006

ouias je cumule et je te remercide m’aider ! c’est pas facile de changer …

j’essai quelque chose on verra bien …

EDIT :

j’ai tout supprimer et j’ai remis les deux partitions windows et la linux mais j’ai toujorus ce L qui m’emmerde !

j’ai meme pas le l’affichage lilo qui me donne le choix !
il detect le bios et apres il met ce “L” j’arrive pas à aller plus loin !

budylove : je sais, c’est précisément lors de l’installation de lilo que ça a merdé, donc il te faut réinstaller lilo proprement par dessus pour remettre de l’ordre

Depuis Windows tu peux aussi faire un
fdisk /mdr

Ce qui revient à peu près au même

ouais mais j’ai pas acces a mon windows je peux rien faire si ce n’est que booter pour reinstaller

EDIT

logiquement dans le lilo si je supprime tout et que je laisse juste windows en hda1 il devrait rebooter ? non? car c’est pas le cas :pt1cable: :paf:

Ok, normal puisque c’est lilo qui a foiré.

tu peux le faire à partir du CD de boot mandrake je pense
Tu dois avoir une option pour booter le système installé ou alors, tu vas dans le menu d’installation normal et il doit y avoir un truc pour réparer (clic sur la configuration de lilo… )

En cas tu peux utiliser grub, il marche peut être mieux pour toi

Edit : le problème c’est que c’est lilo lui même qu’il faut supprimer ou modifier, et oui, une fois que ce sera revenu dans l’ordre tu n’auras aucun pb

bon avec grub ca marche pas mieux

je recommence via lilo…

pour une premiere approche… :super: :paf: