Forum Clubic

Wampserver problème dans "mes projets"

Bonjour, j’ai un soucis avec wampserver derniere version.
je l’ai installé proprement, l’icone est bien vert, j’arrive à accéder au localhost mais impossible de voir les fichiers de “mes projets”… pourtant les fichier php et autres sont à l’intérieur du dossier www de wamp. Je trouve rien sur internet pour ce problème.

J’ai déjà réinstallé le logiciel et fais le ménage dans la base de registre. Je suis sous win 7 (32)

Bonjour,

Tu ne vois rien dans le dossier “www” du répertoire wamp ? Ou juste le dossier “Mes projets” que tu voit pas ?

Regarde dans “répertoire_WAMP”\WAMP\bin\apache"la version d’apache utilisé"\conf\ dedans tu as un fichier “httpd.conf”

Premier cas, si tu vois rien :
En l’éditant avec notepad, tu dois trouver ces lignes : (ligne 250 chez moi)

This should be changed to whatever you set DocumentRoot to.

<Directory “Y:/wamp/www/”>
Et vérifie que le chemin est le bon.

Second cas, juste le répertoire “Mes projets” que tu ne voit pas.
Toujours dans “httpd.conf” tu dois avoir une clause qui interdit l’accès au répertoire. (désolé pas la syntaxe en tête)

Je penche plutôt pour le second cas, j’ai vérifié le premier pas de soucis le répertoire est le bon.
Je vois le répertoire mes projets, mes rien dans l’arborescence de celui ci alors que j’ai un fichier test php.
J’ai vraiment du mal à comprendre pourquoi.
Edité le 04/07/2012 à 21:40

Hmm, tu vois le répertoire.
Quand tu clique dessus, tu ne voit plus rien.
Essayes de rajouter “test.php” (ou le nom de ton fichier) à la suite dans la barre d’adresse.

Ou tout simplement renomme ton fichier en “Index.php”

Effectivement si je renomme mon fichier test.php en index.php la page et la fonction php “bonjour!” fonctionne.
Mais le truc c’est que je n’ai plus la page localhost de base vu que j’ai supprimé l’autre index.php d’origine, donc en gros en cliquant sur l’icone wampserver puis localhost, je tombe directement sur ma page php et non sur la page localhost de wamp… je ne me suivient pas avoir utilisé le logiciel de cette manière :confused: mais bon en tout cas ça refonctionne un peu ^^ mais c’est pas trop ça encore.

Un screen pour montrer que rien n’est dans mes projets :wink:
Capture d’écran wampserver erreur
Edité le 05/07/2012 à 19:20

Ah, c’est sa que tu appel “Mes Projets” :slight_smile: Jamais vu cet écran de ma vie.

Dedans, tu verrai pas les répertoires qui sont dans “www” de wamp ?
Edité le 06/07/2012 à 09:30

Bonsoir,

Si j’ai bien compris ton problème, tu as créé ton projet dans le dossier www de wamp et non pas dans un sous-dossier. Si oui, il est normal qu’en supprimant le fichier index.php ou du moins en le remplaçant par le tiens, tu sois automatiquement redirigé vers cette page.

Pour que ton projet marche correctement, il faut que tu aies un répertoire qui ressemble à ça :
C:\wamp\www\dossier_de_ton_projet

Ainsi, tu mets tous tes fichiers dans ce dossier (“dossier_de_ton_projet”) et là tu auras accès à tes projets normalement depuis ton localhost.

Par contre pour récupérer le fichier index.php de wamp… à moins de télécharger à nouveau le programme je ne vois pas trop comment, j’avais fait la bourde une fois j’ai du le réinstaller ^^"