Forum Clubic

Wake Up on LAN : comment ca marche ?

hello,
j’ai 2 pcs reliés a mon routeur wrt54gs
mon pc de bureau et mon pc dans le salon
le pc de salon reste en mode hibernate mais j’ai besoin de le reveiller sans traverser toute la maison quand je suis dans mon bureau
sa carte mere est une Aopen AK77-600Max et je sais que le wake up on lan est possible
donc comment ca se passe ?
merci

Tu envois une sorte de paquet au PC à réveillé et ce dernier et censer réagir et se rallumer

Tu actives le wake-on lan dans le bios du pc à reveiller
Tu vas sur le site dépicus (recherche google powaa) pour trouver le soft qui va bien et tu saisis l’adresse mac du pc à reveiller

Pour connaitre l’adresse mac => ipconfig /all dans une fenêtre ds sur le pc à reveiller (6 série de 2 caractères ou chiffres)

C’est super pratique ; voili voilà :wink:

hello
merci pour les infos. j’ai le soft et le mac!
mais question, en fait je me connecte sur mon routeur avec une carte wifi
on m’a dit qu’il fallait une carte ethernet qu’il faut brancher au connecteur wol de la CM.
c’est vrai ?

M’étonnerait qu’en Wifi le WoL fonctionne. Je confirme qu’il faut que ta carte réseau soit connectée au port WoL de ta carte mère. Si elle est intégrée, le problème ne se pose pas.

ha! au revoir :MDR
merci en tout cas

C’était ironique? Parce que:
www.clubic.com/forum/wol-wake-on-lan-t311620.html

Bonjour. Je ne parviens pas non plus à faire fonctionner le Wake On LAN depuis internet.

Voici la structure du réseau (bien sûr les adresses sont fausses) :

  • J’ai 2 PCs (PC1 et PC2) en réseau local derrière une FreeBox v4.

  • J’utilise un hub Intel InBusiness™ 8-Port 10/100 Fast Hub. La FreeBox et les 2 PCs sont connectés au hub.

  • L’adresse MAC de la carte réseau de PC1 est : 01-23-45-67-89-AB et celle de PC2 est : DE-AD-BE-EF-00-00

  • La FreeBox attribue les IP 192.168.0.1 à la carte réseau de PC1 et 192.168.0.2 à la carte réseau de PC2

  • L’IP de ma FreeBox sur internet est 123.124.125.126

  • L’IP de ma FreeBox sur le réseau local est 192.168.0.254

Voici mes outils :

  • J’utilise l’outil Wake On Lan - Magic Packet de Depicus pour envoyer les paquets de réveil à PC1

  • quand PC1 est allumé, j’utilise l’outil Wake On Lan Monitor de Depicus pour vérifier l’arrivée des paquets de réveil à PC1

  • J’utilise le port 7 pour le Wake On LAN

Voici ce qu’il se passe :

  • En LAN, tout fonctionne bien. J’utilise Wake On Lan - Magic Packet, depuis PC2. J’entre :

    • Mac address : 01-23-45-67-89-AB

    • Internet Address : 192.168.0.1

    • Subnet Mask : 255.255.255.0

    • Send Option : Local Subnet

    • Remote Port Number : 7

    Les paquets magiques arrivent bien à PC1, je peux les voir lorsque PC1 est allumé et qu’il exécute Wake On Lan Monitor.

    Lorsque PC1 est éteint il s’allume dès que je clique sur “Wake Me Up”.

  • Par Internet, ça ne fonctionne pas. J’utilise Wake On Lan - Magic Packet, depuis un PC sur internet (chez un copain par exemple). J’entre :

    • Mac address : 01-23-45-67-89-AB

    • Internet Address : 123.124.125.126

    • Subnet Mask : 255.255.255.255

    • Send Option : Internet

    • Remote Port Number : 7

    Lorsque PC1 est éteint il ne s’allume pas quand je clique sur “Wake Me Up”.

    Pourtant, lorsque PC1 est allumé et qu’il exécute Wake On Lan Monitor, je peux voir arriver les paquets depuis internet. C’est le plus étrange.

Voici la configuration du PC1 :

  • système d’exploitation Windows XP Professionnel SP2

  • Carte réseau :

    • ma carte est : Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller

    • Cette carte réseau est intégrée à ma carte-mère, l’ensemble est compatible Wake On LAN

  • Configuration du BIOS

    • La version de mon BIOS est : AmiBios version 1201

    • Dans le menu “Power”

      –> J’ai activé “ACPI APIC support”

      –> Dans le sous-menu “APM configuration” j’ai activé “Power On By PCI/PCIEX Devices”

  • Configuration de la carte réseau depuis Windows

    • Dans l’onglet “Avancé” j’ai réglé “Capacité de réveil” sur “Magic Packet”

    • Dans l’onglet “Avancé” j’ai réglé “Wake From Shutdown” sur “Activé”

    • Dans l’onglet “Gestion de l’alimentation” j’ai décoché toustes les options qui permettent au PC de désactiver la carte réseau (“Autoriser ce périphérique à sortir l’ordinateur de sa mise en veille”, “Autoriser l’ordinateur à éteindre ce périphérique pour économiser de l’énergie” et "N’autoriser que les stations de gestion à faire sortir l’ordinateur du mode veille")

Voici la configuration de mon routeur :

  • Mon routeur est une FreeBox v4

  • Pour l’instant je n’utilise pas le Wifi

  • le routeur et le réseau local sont configuré de la manière suivante :

    • IP FreeBox : 192.168.0.254

    • DHCP : activé

    • Début DHCP : 192.168.0.1

    • fin DHCP : 192.168.0.2

    • IP DMZ : 192.168.0.0 (DMZ désactivée)

    • IP du FreePlayer : 192.168.0.0 (FreePlayer désactivé)

    • Réponse au ping : activé

    • Proxy WOL : activé

    • Redirection de ports : J’utilise le port 7 pour le Wake On LAN. Par conséquent, entre autres, je redirige les paquets UDP (et TCP, mais je ne pense pas que ce soit utile) arrivant à la FreeBox sur le port 7 vers l’IP 192.168.0.1, toujours sur le port 7

    • Baux DHCP permanents : l’adresse 192.168.0.1 est attribuée à la carte réseau 01-23-45-67-89-AB (PC1, à réveiller) et l’adresse 192.168.0.2 est attribuée à la carte réseau DE-AD-BE-EF-00-00 (PC2)

En résumé : la configuration de PC1 doit être bonne puisque celui-ci peut être réveillé à distance depuis le réseau local, et la configuration réseau doit aussi être bonne puisque même depuis internet les paquets arrivent jusqu’à PC1. Néanmoins le Wake On Lan ne fonctionne qu’en réseau local.

Auriez-vous des idées svp ?

Merci

Julien

Bonjour,

  1. vérifie que ton paquet arrive bien sur le port 7, il semble que suivant plusieurs sources, on utilise le 0, 7, 8 ou 9 et peut être d’autres.

  2. le plus simple c’est de faire un essai en mettant une DMZ sur le PC1.

  3. essai avec d’autres logiciels ou script (exemple : www.hackernotcracker.com…)

tiens moi au courant.
dochat