Forum Clubic

Wake on Lan via Internet avec Livebox

Je srais assez interressé de faire du WOL avec mon pc a mon domicile depuis mon travail.
Cela m’eviterais d’allumer systematiquement mon pc le matin avant de partir.
J’ai vaguement essayé avec le logiciel de depicus…
ca marche pas trop, du tout même.

Cela est-il réellement possible via un routeur par internet ?

J’ai lu quelque part que c’était réalisable, mais cela implique de faire un transfert de port sur le routeur du lan où est situé le pc à démarré.

Il y avait aussi une histoire de masque de réseau, où adresse de broadcast à paramétrer différement.

J’essaye de retrouver le lien…

Edit : le link

mouais, c’est vraiment pas gagné avec la livebox.
manqsue un menu semble t-il;

Bonjour. Je ne parviens pas non plus à faire fonctionner le Wake On LAN depuis internet.

Voici la structure du réseau (bien sûr les adresses sont fausses) :

  • J’ai 2 PCs (PC1 et PC2) en réseau local derrière une FreeBox v4.

  • J’utilise un hub Intel InBusiness™ 8-Port 10/100 Fast Hub. La FreeBox et les 2 PCs sont connectés au hub.

  • L’adresse MAC de la carte réseau de PC1 est : 01-23-45-67-89-AB et celle de PC2 est : DE-AD-BE-EF-00-00

  • La FreeBox attribue les IP 192.168.0.1 à la carte réseau de PC1 et 192.168.0.2 à la carte réseau de PC2

  • L’IP de ma FreeBox sur internet est 123.124.125.126

  • L’IP de ma FreeBox sur le réseau local est 192.168.0.254

Voici mes outils :

  • J’utilise l’outil Wake On Lan - Magic Packet de Depicus pour envoyer les paquets de réveil à PC1

  • quand PC1 est allumé, j’utilise l’outil Wake On Lan Monitor de Depicus pour vérifier l’arrivée des paquets de réveil à PC1

  • J’utilise le port 7 pour le Wake On LAN

Voici ce qu’il se passe :

  • En LAN, tout fonctionne bien. J’utilise Wake On Lan - Magic Packet, depuis PC2. J’entre :

    • Mac address : 01-23-45-67-89-AB

    • Internet Address : 192.168.0.1

    • Subnet Mask : 255.255.255.0

    • Send Option : Local Subnet

    • Remote Port Number : 7

    Les paquets magiques arrivent bien à PC1, je peux les voir lorsque PC1 est allumé et qu’il exécute Wake On Lan Monitor.

    Lorsque PC1 est éteint il s’allume dès que je clique sur “Wake Me Up”.

  • Par Internet, ça ne fonctionne pas. J’utilise Wake On Lan - Magic Packet, depuis un PC sur internet (chez un copain par exemple). J’entre :

    • Mac address : 01-23-45-67-89-AB

    • Internet Address : 123.124.125.126

    • Subnet Mask : 255.255.255.255

    • Send Option : Internet

    • Remote Port Number : 7

    Lorsque PC1 est éteint il ne s’allume pas quand je clique sur “Wake Me Up”.

    Pourtant, lorsque PC1 est allumé et qu’il exécute Wake On Lan Monitor, je peux voir arriver les paquets depuis internet. C’est le plus étrange.

Voici la configuration du PC1 :

  • système d’exploitation Windows XP Professionnel SP2

  • Carte réseau :

    • ma carte est : Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller

    • Cette carte réseau est intégrée à ma carte-mère, l’ensemble est compatible Wake On LAN

  • Configuration du BIOS

    • La version de mon BIOS est : AmiBios version 1201

    • Dans le menu “Power”

      –> J’ai activé “ACPI APIC support”

      –> Dans le sous-menu “APM configuration” j’ai activé “Power On By PCI/PCIEX Devices”

  • Configuration de la carte réseau depuis Windows

    • Dans l’onglet “Avancé” j’ai réglé “Capacité de réveil” sur “Magic Packet”

    • Dans l’onglet “Avancé” j’ai réglé “Wake From Shutdown” sur “Activé”

    • Dans l’onglet “Gestion de l’alimentation” j’ai décoché toustes les options qui permettent au PC de désactiver la carte réseau (“Autoriser ce périphérique à sortir l’ordinateur de sa mise en veille”, “Autoriser l’ordinateur à éteindre ce périphérique pour économiser de l’énergie” et "N’autoriser que les stations de gestion à faire sortir l’ordinateur du mode veille")

Voici la configuration de mon routeur :

  • Mon routeur est une FreeBox v4

  • Pour l’instant je n’utilise pas le Wifi

  • le routeur et le réseau local sont configuré de la manière suivante :

    • IP FreeBox : 192.168.0.254

    • DHCP : activé

    • Début DHCP : 192.168.0.1

    • fin DHCP : 192.168.0.2

    • IP DMZ : 192.168.0.0 (DMZ désactivée)

    • IP du FreePlayer : 192.168.0.0 (FreePlayer désactivé)

    • Réponse au ping : activé

    • Proxy WOL : activé

    • Redirection de ports : J’utilise le port 7 pour le Wake On LAN. Par conséquent, entre autres, je redirige les paquets UDP (et TCP, mais je ne pense pas que ce soit utile) arrivant à la FreeBox sur le port 7 vers l’IP 192.168.0.1, toujours sur le port 7

    • Baux DHCP permanents : l’adresse 192.168.0.1 est attribuée à la carte réseau 01-23-45-67-89-AB (PC1, à réveiller) et l’adresse 192.168.0.2 est attribuée à la carte réseau DE-AD-BE-EF-00-00 (PC2)

En résumé : la configuration de PC1 doit être bonne puisque celui-ci peut être réveillé à distance depuis le réseau local, et la configuration réseau doit aussi être bonne puisque même depuis internet les paquets arrivent jusqu’à PC1. Néanmoins le Wake On Lan ne fonctionne qu’en réseau local.

Auriez-vous des idées svp ?

Merci

Julien

Déja cherche WOW et non WOL (Wake On Wan) ensuite la livebox a un soucis, elle perd les routes des ordinateur au bout de 15 min d’inactivité, donc pour le WOW on l’a dans le c***** (je sais car j’ai déja essayé)

J’ai retourné tout internet, an ayant le même problème, et c’est du à un problème de la livebox qui “oublie” l’adresse MAC du PC éteint au bout d’un certain temps.

Et j’ai pensé à quelque chose qui à fini par fonctionner :

  1. téléchargez et installer mozilla firefox si vous ne l’avez pas déjà, lancez le
  2. rendez vous sur la page d’administration de la livebox, normalement 192.168.1.1, il faut donc taper 192.168.1.1… dans la barre d’adresse de firefox
  3. entrez votre login et votre mot de passe (par défaut “admin” et '“admin”)
  4. allez dans l’onglet serveur LAN et faites “ajouter”
  5. mettez le nom que vous voulez, dans activé mettez “oui”, le protocole est UDP, mettez le port que vous souhaitez (je crois que le port 9 est défini comme servant au wake on lan, donc, personellement, j’ai mis du port 9 au port 9), et dans adresse ip locale mettez “192.168.1.255” et pas autre chose, ne validez pas.
  6. Puisque vous avez firefox, allez dans le menu édition, puis préférences, et dans l’onglet “contenu” et désactivez javascript, validez et faites appliquer.
  7. Normalement, s’ouvre une page blanche, réactivez javascript, puis cliquez sur l’onglet “serveurs LAN”, et vérifiez que la nouvelle règle à été créée. Si elle à été créée, sauvegarder la configuration.

Et voilà, vous pouvez faire du walk on wan sur le port choisi.
En fait, 192.168.1.255 envoie la paquet à tous les PC du réseau, par contre, la livebox refuse de l’ajouter car ce n’est pas une IP valide, donc il faut désactiver javascript afin que ça marche quand même (et sous firefox 2, ça marche).
Pour allumez votre PC, utilisez un logiciel, ou un site, comme par exemple wakeonwan.free.fr…

Je l’ai fais, et, en tout cas, chez moi, ça marche

Voilà. J’espère que ça pourra en aider certains.

EDIT: Suite à une mise à jour de la livebox, même pas besoin de désactiver temporairement javascript : la livebox ne dit plus que l’adresse IP est invalide !
Edité le 02/09/2008 à 20:23