Forum Clubic

Wake On LAN - Comment ça marche?

Malgrès quelques recherches je n’ai pas trouvé de solution pour démarrer mon PC via une commande balancée sur le réseau.

J’aimerais donc pouvoir démarrer une machine en 192.168.0.x à partir d’une autre en 192.168.0.y sur le même réseau.

Comment faire? Il existe des logiciels qui font cela?

Salut,

Il faut le valider dans le BIOS.
Dans certaines cartes mères, il y a un connecteur à brancher sur la carte réseau.
Mais j’en sais pas plus, je l’ai jamais fait…

J’irai voir cela ce soir en rentrant :smiley:

il te faut un logiciel specifique qui enverra ce qu’on appel des “magic packet” sur le reseau.
Ces “packets” vont servir de signal à la carte reseau pour qu’elle enclanche le Wake-UP

ensuite tout depend du matos:

CM avec carte reseau integré:

il suffit d’activer le Wake-on-LAN

CM + carte reseau un peu ancienne:
il faudra relier un petit cable specifique entre les 2 cartes et activer le Wake-on-lan

CM + carte reseau recente:
Il suffit d’activer le wake-on-LAN ou le Wake-on-PCI. Depuis la V2.2 du Bus PCI, le Wake-on-lan peut passer par le bus et n’a plus besoin de cable

Oki :smiley:

J’ai donc activé le “Wake On PCI Card” dans le BIOS et installé sur mon autre PC un petit programme trouvé ici :
http://www.laboratoire-microsoft.org/logiciels/10890/

J’ai donc paramétré tout ça, mais aucune réaction quand je commande le démarrage :frowning:

C’est une carte réseau intégrée que j’utilise

C’est cette carte mère :
http://www-old.epox.nl/english/products/mo…board/4pca3.htm

Je viens de trouver la version du bus PCI : 2.3

Je viens de remarquer que PC éteint les diodes de la carte réseau comme celles du switch sont éteintes :confused:

http://geek63.no-ip.org/forums/Reseau.gif

PC2 doit démarrer PC1

si la carte reseau est integrée tu devrais avoir un wake-on-Lan, ce n’est pas le cas ?

car wake-on-PCI fera qu’il attendra un signal sur le bus PCI (normalement le reseau integre est sur PCI mais bon des fois qu’il fasse le distingo)


je viens de regarder le manuel de ta CM sur le page que tu indique:

il y a dans "power managmenent" de ton bios une ligne :

Power On By Ring or WOL

WoL = Wake On Lan ==> c’est ça qui doit etre sur enable

Je retourne voir :smiley:

Bon, j’ai réinstallé les pilotes de la carte intégrée car elle avait un /!\ dans le gestionnaire de périphs. (je teste un peu avec les deux cartes là) je vais faire d’autres tests

Ayé ça marche avec la carte intégrée [:love]

Bonjour. Je ne parviens pas non plus à faire fonctionner le Wake On LAN depuis internet.

Voici la structure du réseau (bien sûr les adresses sont fausses) :

  • J’ai 2 PCs (PC1 et PC2) en réseau local derrière une FreeBox v4.

  • J’utilise un hub Intel InBusiness™ 8-Port 10/100 Fast Hub. La FreeBox et les 2 PCs sont connectés au hub.

  • L’adresse MAC de la carte réseau de PC1 est : 01-23-45-67-89-AB et celle de PC2 est : DE-AD-BE-EF-00-00

  • La FreeBox attribue les IP 192.168.0.1 à la carte réseau de PC1 et 192.168.0.2 à la carte réseau de PC2

  • L’IP de ma FreeBox sur internet est 123.124.125.126

  • L’IP de ma FreeBox sur le réseau local est 192.168.0.254

Voici mes outils :

  • J’utilise l’outil Wake On Lan - Magic Packet de Depicus pour envoyer les paquets de réveil à PC1

  • quand PC1 est allumé, j’utilise l’outil Wake On Lan Monitor de Depicus pour vérifier l’arrivée des paquets de réveil à PC1

  • J’utilise le port 7 pour le Wake On LAN

Voici ce qu’il se passe :

  • En LAN, tout fonctionne bien. J’utilise Wake On Lan - Magic Packet, depuis PC2. J’entre :

    • Mac address : 01-23-45-67-89-AB

    • Internet Address : 192.168.0.1

    • Subnet Mask : 255.255.255.0

    • Send Option : Local Subnet

    • Remote Port Number : 7

    Les paquets magiques arrivent bien à PC1, je peux les voir lorsque PC1 est allumé et qu’il exécute Wake On Lan Monitor.

    Lorsque PC1 est éteint il s’allume dès que je clique sur “Wake Me Up”.

  • Par Internet, ça ne fonctionne pas. J’utilise Wake On Lan - Magic Packet, depuis un PC sur internet (chez un copain par exemple). J’entre :

    • Mac address : 01-23-45-67-89-AB

    • Internet Address : 123.124.125.126

    • Subnet Mask : 255.255.255.255

    • Send Option : Internet

    • Remote Port Number : 7

    Lorsque PC1 est éteint il ne s’allume pas quand je clique sur “Wake Me Up”.

    Pourtant, lorsque PC1 est allumé et qu’il exécute Wake On Lan Monitor, je peux voir arriver les paquets depuis internet. C’est le plus étrange.

Voici la configuration du PC1 :

  • système d’exploitation Windows XP Professionnel SP2

  • Carte réseau :

    • ma carte est : Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller

    • Cette carte réseau est intégrée à ma carte-mère, l’ensemble est compatible Wake On LAN

  • Configuration du BIOS

    • La version de mon BIOS est : AmiBios version 1201

    • Dans le menu “Power”

      –> J’ai activé “ACPI APIC support”

      –> Dans le sous-menu “APM configuration” j’ai activé “Power On By PCI/PCIEX Devices”

  • Configuration de la carte réseau depuis Windows

    • Dans l’onglet “Avancé” j’ai réglé “Capacité de réveil” sur “Magic Packet”

    • Dans l’onglet “Avancé” j’ai réglé “Wake From Shutdown” sur “Activé”

    • Dans l’onglet “Gestion de l’alimentation” j’ai décoché toustes les options qui permettent au PC de désactiver la carte réseau (“Autoriser ce périphérique à sortir l’ordinateur de sa mise en veille”, “Autoriser l’ordinateur à éteindre ce périphérique pour économiser de l’énergie” et "N’autoriser que les stations de gestion à faire sortir l’ordinateur du mode veille")

Voici la configuration de mon routeur :

  • Mon routeur est une FreeBox v4

  • Pour l’instant je n’utilise pas le Wifi

  • le routeur et le réseau local sont configuré de la manière suivante :

    • IP FreeBox : 192.168.0.254

    • DHCP : activé

    • Début DHCP : 192.168.0.1

    • fin DHCP : 192.168.0.2

    • IP DMZ : 192.168.0.0 (DMZ désactivée)

    • IP du FreePlayer : 192.168.0.0 (FreePlayer désactivé)

    • Réponse au ping : activé

    • Proxy WOL : activé

    • Redirection de ports : J’utilise le port 7 pour le Wake On LAN. Par conséquent, entre autres, je redirige les paquets UDP (et TCP, mais je ne pense pas que ce soit utile) arrivant à la FreeBox sur le port 7 vers l’IP 192.168.0.1, toujours sur le port 7

    • Baux DHCP permanents : l’adresse 192.168.0.1 est attribuée à la carte réseau 01-23-45-67-89-AB (PC1, à réveiller) et l’adresse 192.168.0.2 est attribuée à la carte réseau DE-AD-BE-EF-00-00 (PC2)

En résumé : la configuration de PC1 doit être bonne puisque celui-ci peut être réveillé à distance depuis le réseau local, et la configuration réseau doit aussi être bonne puisque même depuis internet les paquets arrivent jusqu’à PC1. Néanmoins le Wake On Lan ne fonctionne qu’en réseau local.

Auriez-vous des idées svp ?

Merci

Julien

Bonsoir,

si votre Freebox est en mode routeur (obligatoirement le cas si plusieurs PC sur le reseau), il convient de rediriger le port.
En clair, il faut rediriger l’IP internet sur le poste en question “192.168.0.1”. (Port 7 donc)
Par contre je ne sais pas si WOL utilise TCP ou UDP.

Cdt.

bon c par UDP,moi aussi je connecte par un routeur(NAT) sa a marchè par reseau local mè pa par internet sa fonctionne pa,et je cherche l’aide mon pote moi aussi

Pour pouvoir l’utiliser depui internet, le plus simple est de passer par un site web qui propose le Wake on lan.
Perso j’utilise http://wakeuponwan.free.fr

je suis désolé de déterrer un sujet vieux d’un ans :frowning:

mais j’ai besoin d’une confirmation:

j’ai un pc portable hp pavilion dm4 (1070sf) (pas du tout vieux ! )

et j’ai aucune trace de WOL:-(:

ni dans le BIOS, ni dans les propriété de ma carte wifi (broadcom 4313).:yeux1:

donc je voulais savoir, si le faite de ne pas avoir de “trace” de wake up lan voulait définitivement dire que je n’avais pas cette fonction ? (malgré que j’ai pu lire que tous les pc récent en sont équipé)

merci

Salut Edem2302,

C’est effectivement étrange que tu n’aies pas d’info dans le bios en ce qui concerne le Wake On Lan (WOL)…

Le mieux… c’est de tester…

Une petite précision importante quand même : Il n’est pas possible de faire du Wake On Lan via un réseau Wi-Fi (sinon… ça serait du Wake On Wlan :-))
(Selon Microsoft, c’est possible de faire une modification dans le registre MAIS, il ne faut pas confondre réveiller un PC et l’allumer complètement)

Donc pour résumer… faut tester sur sa carte réseau (LAN) et si on veut tester la méthode Microsoft, ça sera en mode “Mise en veille”

A++
Edité le 23/03/2011 à 21:04