Forum Clubic

Virtual hosts problème de configuration

Bonjour,

J’ai un petit soucis avec apache2 sur debian.

Je ne comprend pas pourquoi certains de mes virtualhosts fonctionnent alors que d’autres non.

Exemple :

<VirtualHost xx.xx.xx.xx:80>
DocumentRoot /home/rep1/rep2/www
<Directory "/home/rep1/rep2/www">
allow from all
Options +Indexes
DirectoryIndex index.php
AllowOverride All
</Directory>
ServerAlias www.mondomaine.com mondomaine.com
Options ExecCGI FollowSymLinks Includes IncludesNOEXEC Indexes MultiViews SymLinksIfOwnerMatch
DirectoryIndex index.php index.htm index.html
ServerSignature On
ContentDigest on
ServerName mondomaine.com
</VirtualHost>

fonctionne

<VirtualHost xx.xx.xx.xx:80>
DocumentRoot "/home/rep1/forums/www"
ServerName forums.mondomaine.com
<Directory "/home/rep1/forums/www">
Options +Indexes
DirectoryIndex index.php
AllowOverride All
</Directory>
Options ExecCGI FollowSymLinks Includes IncludesNOEXEC Indexes MultiViews SymLinksIfOwnerMatch
DirectoryIndex index.php index.htm index.html
ServerSignature On
ContentDigest on
</VirtualHost>

fonctionne aussi.

Par contre

<VirtualHost xx.xx.xx.xx:80>
DocumentRoot "/home/rep1/forum2/www"
ServerName forum2.mondomaine.com
<Directory "/home/rep1/forum2/www">
Options FollowSymLinks
DirectoryIndex index.php
AllowOverride All
</Directory>
Options ExecCGI FollowSymLinks Includes IncludesNOEXEC Indexes MultiViews SymLinksIfOwnerMatch
DirectoryIndex index.php index.htm index.html
ServerSignature On
ContentDigest on
</VirtualHost>

et

<VirtualHost xx.xx.xx.xx:80>
DocumentRoot "/home/rep1/rep2/www/document"
ServerName document.mondomaine.com
<Directory "/home/rep1/rep2/www/document">
allow from all
Options FollowSymLinks 
AuthType Basic
</Directory>
DirectoryIndex index.php index.htm index.html test.htm
</VirtualHost>

me donnent

:-/

A moins que ça ne vienne pas des vhosts…
Le premier vhost correspond à mon site internet, il y a un .htaccess
Le second est un forum
Le troisième est un forum protégé par un .htpassword
Le troisième est un répertoire contenant plusieurs répertoires contenant des images affichées sur le site (par exemple, document.mondomaine.com/8794/imgs/3.jpg)

Je ne suis pas un expert ni de apache, ni de debian, ni de php ni du web en général, si quelqu’un pouvait m’aider, ça m’enlèverait une fière chandelle du pied ! :slight_smile:

Merci !
Edité le 05/03/2008 à 19:42

Tu as une ou plusieurs adresses IP publiques qui pointent vers ton serveur ?
Edité le 05/03/2008 à 12:07

Non, une seule.

ok, ben je te reponds ce soir quand je serai rentre chez moi.

Ta conf n’est pas du tout bonne… il y a 2 sortes de Vhosts Apache : bases sur l’IP ou sur le nom.
Le premier sert quand tu as 1 IP/site qui pointent sur le meme serveur et le 2e sert quand tu n’as qu’une seule IP et plusieurs sites sur le meme serveur.
Tu es partie sur une conf base sur l’IP alors que c’est l’autre solution dont tu as besoin. C’est un probleme tres courant quand on debute avec les vhosts sous apache.

Plus de details dans qq heures.
Edité le 05/03/2008 à 18:36

J’ai trouvé la solution, mais je veux bien tes explications :slight_smile:

En fait dans mes .htaccess, les paramètres option +indexes ou option +FollowSymlinks étaient en trop apparemment… en les enlevant, tout refonctionne parfaitement…

Je ne sais pas pourquoi… Je dois dire que j’ai oublié de mentionner que je migrais un serveur en apache 1.3 vers apache2, donc peut être que certaines choses n’étaient pas adaptées…

Et puis je ne suis pas très bon non plus donc… :stuck_out_tongue:

en fait, je me la pete mais je raconte n’imp’… :riva:
Tu as bien configure tes vhosts mais a cause du “allowoverride all”, il faut que tu fasses super gaffe a ce que tu mets dans tes .htaccess car chaque directive placee dans un .htaccess ecrase celle declaree dans le vhost ou la conf generale.
C’est visiblement le prob qui t’es arrive.

Conseils :
Il faudrait aussi que tu reorganises tes fichiers de conf : les servername et serveralias en haut pour bien identifier le vhost, documentroot en dessous, section directory en dessous et le reste a la fin.
Directoryindex n’a pas specialement d’interet si celui qui est dans apache.conf est correctement configure.
N’hesite pas a mettre des commentaires.
Generalement, si tu ne sais pas a quoi sert une option : soit tu vas dans la doc pour voir quoi elle sert et verifier qu’elle t’es utile, soit tu l’enleves.
Tu connais la debianway pour apache ? on fait 1 fichier par vhost dans /etc/apache2/site-available et on utilise a2ensite pour activer le site.