Forum Clubic

Virtual dub

bon voila j’ai une video dont je voudrais coupe le debut donc j’ouvre ma video avec virtual dub mod je supprime le morceau qui m’interesse pas et je met a enregistrer en avi la aucun probleme je lance la vieo mais au debut de la video il reste une image de ce que je voulais enleve donc je reassaye de supprime et jeregistre et l’image a parait encoreune fois et du coup je comprend pas d’ou elle sort si quelqu’un peut m’aider pas de refus

Si tu coupes par le mode Direct video stream copy et que cette image n’est pas juste avant une key frame, tu ne peux pas l’éliminer comme ça. Il va falloir réencoder la vidéo si tu veux une découpe aussi précise.

merci ca a marche

nglechau>>> Merci mais je l’ai deja encodée en Xvid comme dit precedament dans le topic. Tu veut dire alort que je doit obligatoirement la reencodé encore une fois en Divx cette fois avec VirtualDub pour que ça marche ?

Tu dois la réencoder, soit en DivX soit en Xvid mais il faut la refaire, la coupe directe ne se base que sur les key frames et ne permet donc pas d’arrêter à une frame précise si ce n’est pas une key frame.

D’accort, c’est ce que j’ai l’intention de faire mais malheureusement avec VirtualDub, quand je vais dans “Select Audio Compression” pour choisir le codec audio, en l’occurance Mpeg Layer-3, sur la fenetre de droite je suis sencé avoir tout un tas de possibilité de frequence et de bitrate, or même en cochant la case “Show all formats” il me mes qu’une minuscule petite liste (avec même pas la frequence d’origine de ma video, donc je peut pas convertir du cout) et quant au bitrate ils sont limité à 56Kbit/s grand maximum…

Ta piste audio est actuellement dans quel format ?

Si c’est déjà du compressé, tu peux choisir l’option Direct audio stream copy pour ne pas à la réencoder l’audio. Tu réencodes uniquement la vidéo.

Ma piste audio est en Mpeg Layer-3 par defaux. Sinon là je viens de faire ce que tu m’as dit, j’ai donc reencodé la video en Xvid (encore une fois), mais apre quand je tente de coupé un bout de video de la grosse video, ben je me retrouve le même probleme…

Tu pense pas plutot que c’est un probleme de manip venant de moi d’apres toi ?

Pourquoi tu réencodes puis découpes ? Tu dois faire les deux à la fois. C’est-à-dire tu choisis le morceau à couper, et au lieu de sélectionner Direct video stream copy, tu choisis Full processing mode et tu définis ton codec. Tu laisses seulement l’audio en mode Direct stream copy.

En résumé, tu ne coupe pas la vidéo réencodée, mais tu réencodes le morceau à couper. Je ne sais pas si mes explications sont assez claires :wink:

Ok cette fois j’ai compris, je fait tout en même temp. Je commence par definir ce que je doit decoupé en indiquant le frame, ensuite dans la foulé j’indique le codec a utilisé dans les option, et je fait “Save as AVI” comme ça il me fait tout en même temp. Ok mais je viens de le faire et sa me fait le même probleme O_0
J’ai quand même reussi a “triché” etandonné que le vois l’avancement de la decoupe/encondage de la video dans une fenetre, j’ai juste eu a clické sur “Abort” pour arrété la decoupé un peut pres au moment oû c’est la fin du premier clip, mais pas exactement aussi pressie que je l’aurais souhaité avec l’indication des frame du debut et de la fin de la decoupe.

Bref, ça marche toujours quoi lol

Je remonte le sujet car j’aurais besoin d’une reponse ce soir svp :wink:

Merci d’avance.

J’ai l’impression que l’index de ton fichier n’est pas bon.

Essaie de demander à un modo de déplacer ton topic dans la section Vidéo numérique :
http://www.clubic.com/forum/photo-et-video-numerique-f4.html

C’est quoi “l’index” d’un fichier stp ?

C’est grossomodo le mapping entre le temps et les images. Quelle key frame à quel moment, ce qu’apporte (modifie) une non-key frame par rapport à celle qui la précède, etc.

Tu auras sûrement des réponses plus précises par les experts dans le bon forum :wink:

Essaie de découper qqes images avant ou après,de préférence avant quitte à redécouper encore un mini morceau sur ta découpe.