Forum Clubic

VBA Macros Excel : Comparer colonnes A et B - Comparer valeurs, colonnes A et B

Bonjour, je souhaite comparer une colonne A de nombres avec une colonne B de nombres, normalment ils doivent être égaux, mais sont dans le désordre et il n’est pas possible de trier la colonne A et B. Si le nombre présent dans une cellule de A n’est pas dans B, je la copie et la colle dans une seconde feuille du classeur ou une colonne par exemple pour faire le point sur les nombres manquants, meci.

C’est simple : il te suffit de boucler sur chaque élément de A et pour chaque élément, boucler sur tous les éléments de B pour comparer si l’élément courant de A existe dans l’élément courant de B.

si tu veux utiliser une colonne de ta feuille de calcul, tu peux faire directement en excel :
C’est plus faicile à expliquer sur un cas concret, donc on suppose que tes valeurs sont dans les deux premières colonnes, lignes 1 à 30.
Dans le troisème colonne, tu entres la formule qui correspond à ton type d’aafichage :

 
=RECHERCHEV(LC(-1);L1C1:L30C1;1;0)
=RECHERCHEV(B1;$A$1:$A$30;1;0)

NB : attention à ne pas omettre le zero !!!

Toutes les correspondances non trouvées sortiront avec la valeur d’erreur #NA

sinon, en VBA, soit la double boucle comme indiqué dans le message de KarLKoX,
soit une seule boucle associée à la fonction find()