Forum Clubic

Us Robotic 56k fax modem

Bonjour

J’ai un souci avec ce modem branché sur COM1 sous W2K server. De temps en temps apres le reboot de la machine, il ne prends plus la ligne. Il faut eteindre et rallumer le modem. Le probleme c’est que cela se passe a 6h du mat le dimanche. Autant dire qu’il n’y a pas grand monde aupres de lui pour l’eteindre.
Je cherche le moyen de le rebooter par ligne de commande dans un fichier BAT ou autre.
Si quelqu’un connait la syntaxe ou le moyen de le faire je suis preneur.

Par avance merci.

xp >> forum nt/2k

je n’ai plus de mémoire la chaine d’initialisation des USR mais ca aide un ATZ et AT&F ?

Je fais comment ? echo ATZ >com1 ?
J’ai pas trouvé de doc qui explique comment faire ca !

Merci

tu ajoutes cette ligne dans les paramètres du modem dans le gestionnaire de périphériques (section commandes d’initialisation).
Sinon, tu ajoutes au logon script de la machine un echo ATZ >COM1: effectivement

Merci de ta réponse.

A priori j’ai un autre probleme : quand je fais echo ATZ >COM1 j’ai en réponse :
“access is denied”

Une idée ? Je suis admin du poste, W2K server sp4 + hotfixes…

ton accès au port COM est bloqué par un autre logiciel.

Que fais-tu avec le modem ? il sert pour accéder au réseau depuis l’extérieur ?
Si un logiciel occupre le port COM, tu ne pourra pas faire un echo dessus.
portmon (www.sysinternals.com) te dira quel process utilise le port COM à cet instant.

Je pense donc qu’il est préférable d’avoir la chaine ATZ&F par exemple sur les propriétés du modem dans le gestionnaire de périphériques