Forum Clubic

Urgent réalisation tableau Excel + macros

Bonjour à tous,
je suis stagiaire dans un lycée, et je dois utiliser Excel et les macros pour effectuer un inventaire du matériel informatique. J’ai la structure du tableau, mais je ne vois pas où placer les macros. Je vous explique: j’ai trois colonnes - salles / modèles d’ordinateurs / nombre.
Je ne connais pour l’instant pas le nombre ni le numéro des salles qui sont regroupées par secteur (chimie, géographie…). Quant aux modèles d’ordinateurs, il y en a cinq, numérotés de 1 à 5 :slight_smile:
Je dois calculer via des macros, le total d’ordis, et le total d’ordis par salle. Ça fait un moment que je n’ai pas utilisé de macros (et j’ai jamais vraiment aimé ça ^^) et je ne vois pas où la/les mettre. Si je rajoute une quatrième colonne “total” je ne vois pas comment utiliser la macro dessus.

Voici ce que j’ai en tête mais du coup ça cloche :confused: (http://www.imagup.com/data/1145089123.html
Je dois faire ça pour demain, donc c’est assez urgent :s

Merci pour votre aide.

Pas besoin de macro pour faire ça, utilise la fonction =somme.si.ens()

Bonjour,

Regarder ci cette feuille conviendrait :slight_smile:

EDIT: il y a le total d’ordinateur par modèle et général.

Il ne te reste plus qu’a encadrer les colonnes.

Pour avoir un total par salle, ajouter sous “Total ordinateurs” la formule suivante…
=SOMME(B3:F3)
qui sera a recopier vers le bas jusqu’à la dernière salle.

ne pas oublier de supprimer les chiffres 3 et 12 qui traînent :slight_smile:
Edité le 29/02/2012 à 10:18

Ah merci, j’avais pas pensé à le faire dans ce sens là, vu qu’on m’avait déjà donné la structure du tableau. C’est sûr c’est plus facile comme ça. Cependant on m’a demandé d’utiliser des macros pour le réaliser… du coup sous cette forme, j’en vois pas vraiment l’intérêt

Bonjour,

Tu leurs réponds que ta feuille est fonctionnelle et que si il veulent absolument une feuille qui sente le poisson (macro) qu’ils te la fournissent :slight_smile: