Forum Clubic

Upload wifi incohérent

Bonjour,

Je viens vers vous aujourd’hui car je rencontre un petit problème avec une machine sous Debian 7 (32bit).

De temps en temps (je ne sais pas pourquoi) mon réseau Wifi (livebox) se met à planter,
j’ai remarqué que l’upload en wifi est de 2Mo/s à ce moment là sur mon PC sous Debian, chose impossible car je ne peut monter qu’à 1Mo/s.

J’aimerais savoir ce qui pose ce problème et peut être le résoudre.

ifup/ifdown peut parfois résoudre le problème mais de manière temporaire.
Je n’arrive pas à m’expliquer ce phénomène.

Un petit screenshot :

http://img11.hostingpics.net/pics/589355Sanstitre.png
Edité le 13/02/2014 à 16:10

Salut,

Les stats mesurent l’ensemble de ce qui passe par une connexion en local. Il n’y a rien d’autre que de l’internet qui traverse ta patte wifi ?

Ton vnc par exemple, il passe par la patte wifi ou filaire ?

Cette base de 1 Mo/s pourquoi ? Tu veux dire 1 Mb/s par rapport au up max en adsl standard ?

Peut-être que le modele de ta carte wifi donnerait une piste, si la carte est la source du probleme bien sûr.
Ta config réseau pourrait aussi aider :wink:

Le VNC passe par l’ethernet (résultat identique en SSH).

Quand je transfert un gros fichier en wifi (d’un PC à un autre en passant par la livebox) je monte au maximum à 1Mo/s, d’où mon étonnement quand aux 2Mo/s.

Je ne sais pas trop d’ou vient ce débit (étant donné qu’il n’y a que deux PC et que je ne reçois rien sur le deuxième à ce moment).

Les informations données par la commande lspci :

Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

La config réseau :
wlan0 DHCP
eth0 static 192.168.2.1 (deuxième pc 192.168.2.2) avec comme masque 255.255.255.0
Edité le 14/02/2014 à 13:05

Ok pour l’ethernet.

Les débits sont toujours très variables d’une installation à une autre, en fonction des cartes wifi utilisées, de la distance, etc…

Si tu es en 54 Mb/s sur ton wifi, avec une distance raisonnable, tu devrais avoir une vitesse reelle mesurable de 25 Mbits/s, ce qui donne (toujours en théorie) une valeur plus proche de 3 Mo/s en transfert.
Donc ton 2 Mo/s reste crédible.

[/quote]

Bref, plutot stable. As tu essayé de mesurer tout ça avec l’outil “iperf”, de machine à machine ? Il te donnera surement des valeurs de transfert fiables.

Pour rappel, sur l’une des machines Linux, la commande “iperf -s” et sur l’autre : “iperf -c ip_du_poste_en_face”

Plus d’infos ici par exemple…
Edité le 14/02/2014 à 15:01

j’ai déjà rencontré ce genre d’incohérence en download sur une mauvaise connexion 3G (plusieurs Mo/s sur une connexion qui doit pas pouvoir faire rentrer plus d’une centaine de Ko/s). Les fichiers à l’arrivée étaient totalement corrompus.

Si dans ton cas le trafic augmente sans transferts à cause de l’AP instable il s’agit peut être de “paquets vides” de test/maintiens/qualité de connexion qui r"agis mal et cause un malaise genre syn flood.

Faudrait savoir sur quelle couche ifstat prends ses mesures, et j’ai la flemme de chercher.