Forum Clubic

UltraVnc derrière freebox en mode routeur - UltraVnc tourne mais n'est pas joignable

Bonjour,

pour planter le décor : je suis en dégroupage total avec une freebox avec mode routeur activé et un portable avec XP Familial (SP2) relié à la freebox.
j’ai installé ultravnc pour pouvoir prendre contrôle de mon pc à distance. J’ai donc paramétré le routeur pour faire suivre les requêtes sur les ports 5800 et 5900 vers mon pc et ouvert ces ports dans mon firewall (Firewall XP).
Le problème, c’est que ça ne fonctionne pas :frowning:
Quand je vais dans mon navigateur et que je me connecte depuis mon pc en utilisant mon IP local (http://192.168.0.1:5800), ça fonctionne, j’obtiens mon écran (je vous l’accorde, l’intérêt de prendre contrôle depuis mon propre poste peut paraître assez limité mais ça permet de vérifier que le serveur ultravnc tourne…). Quand je veux faire la même manip en mettant mon IP public (http://82.ip.ip.ip:5800), ça ne marche plus :??:
Quelqu’un aurait-il une idée ? Merci beaucoup !

Change le port et met un autre port, en dessous de 1024 (615 par exemple), et route le à la place du 5800.

Pour te connecter via le Net, utilise ton ip:port (147.278.78.21:615 par ex), ça fonctionnera sûrement beaucoup mieux.

Tu dois aussi avoir coché "enable Java Viewver" pour te connecter en mode http

le fait de changer de port ne change rien.
En fait, j’ai plus l’impression que c’est mon adresse IP public (82.228.60.177) qui ne semble pas répondre (Erreur de chargement de la page, délai d’attente dépassé)

j’ai bien coché “enable Java viewer”, la preuve en étant que ça fonctionne quand je passe par mon ip locale (y compris quand j’avais mis comme port 5800)

une autre idée ? merci beaucoup !

Heu… le test avec l’IP publique, tu le fais depuis quelle machine?

Si tu le fais de chez toi, c’est normal que ça ne fonctionne pas. Il faut le tester depuis un autre PC qui ne soit pes derrière ton routeur.

Ou bien dans le fichiers hosts (C:\WINDOWS\system32\drivers\etc\hosts) tu dois rajouter cette ligne :
192.168.0.1 82.228.60.177
Afin de "court-circuiter" le routeur (comme si tu tapais directement ton IP locale)

Pourtant il arrive à pinger son IP publique (enfin celle de la freebox) depuis son poste. Alors pourquoi ne pourrait-il pas accéder à sa machine avec cette adresse IP?

Salut,
Je ne suis pas un expert de VNC mais comme toi j’ai été confronté à ce pb.
Alors après quelques recherches je crois pouvoir te dire que le pb vient du fait que tu essaies de te connecter sur un poste qui est sur un réseau (il a une @ ip public et une @ locale)
L’@ public c’est ton routeur qui l’a alors que toi tu veux te connecter sur l’@ locale où il y a VNC server.
D’après ce que j’ai compris il faut que tu fasses un “mappage de ports” !!!

Qu’il arrive à pinguer c’est une chose, qu’il arrive à retraverser le routeur en est une autre.

Si il veut le tester, il doit le faire à distance, chez un ami par exemple.

Ca te donne quoi si tu utilises telnet?
>> telnet ton_ip 5900

Tu devrais avoir un retour genre “RBF003”, et si ça n’est pas le cas c’est qu’il y à un vrai bloquage.
Cette manip’ peut t’aider à voir si au moins l’handshake se fait de façon correcte ou pas.
Finalement si ça marche, il s’agirrait alors soit 'une problème de service vnc, soit d’un mauvais retour du routeur.

tips: achete toi un vrai routeur, même à 40 euros, ça sera toujours mieux qu’un matos pas fait pour à la base :jap: