Forum Clubic

[Ubuntu] Synaptic - [En attente de mise à jour....]

Bonjour

Synaptic refuse de se lancer, impossible de le démarrer,

quelqu’un à le même problème ?
quelqu’un sait pourquoi ?

Lance le depuis une console pour voir quel est le problème.

fabrice@luigifab:~$ synaptic
synaptic: error while loading shared libraries: libvte.so.4: cannot open shared object file: No such file or directory

Le problème est apparu après une mise à jour il me semble…

Il faut que tu recompiles synaptic avec la bonne bibliothèque, mais comme Ubuntu n’est pas une distrib source, il vaut mieux attendre une maj.

nb : sous Gentoo revdep-build fait le job (à faire chroniquement).

Ou tu attend une mise à jour ou tu essaies de réinstaller synaptic pour voir mais je doute.

sudo apt-get remove synaptic
sudo apt-get clean
sudo apt-get update
sudo apt-get install synaptic

la deuxième ligne pour nettoyer le référenciel et reforcer éventuellement le download

ca la déjà retélécharger, ca rien changer !

Je crois que tout le monde à ce problème. :paf:
Alors sois t’attends la mise à jour, soit :

sudo ln -s /usr/lib/libvte.so.9 /usr/lib/libvte.so.4

j’attend la mise à jour bien trankillement…

Actuellement je n’ai aucun problème pour lancer synaptic, mais je viens de faire un apt-get update && upgrade : màj de libvte-common libvte4 python-vte.

Après màj ça marche plus. J’ai pas trouvé de bugs sur launchpad, je suis allé demander sur #ubuntu-bugs, avant de me rendre compte que cette mise à jour vient d’un dépôt non officiel ^^

$ apt-cache policy libvte4
libvte4:
  Installé : 1:0.13.5-0ubuntu2
  Candidat : 1:0.13.5-0ubuntu2
 Table de version :
 *** 1:0.13.5-0ubuntu2 0
        500 http://www.beerorkid.com dapper/main Packages
        100 /var/lib/dpkg/status
     1:0.12.2-0ubuntu2 0
        500 http://xgl.compiz.info dapper/main Packages
     1:0.12.2-0ubuntu1 0
        500 http://fr.archive.ubuntu.com dapper-updates/main Packages
     1:0.12.1-0ubuntu1 0
        500 http://fr.archive.ubuntu.com dapper/main Packages

Voilà pourquoi il est souvent déconseillé d’utiliser des dépôts non officiels. Ça m’étonnait qu’un bug de ce genre puisse arriver dans dapper, la version stable depuis plus de deux mois. :slight_smile:

Est t’il possible d’installer une version précédente, et comment ?
Ca va poser problème ?

sudo apt-get install --reinstall libvte4/dapper libvte-common/dapper

Mais si tu n’as pas besoin de synaptic tout de suite, je te conseille d’attendre la mise à jour.

http://forum.ubuntu-fr.org/viewtopic.php?id=56039