Forum Clubic

[UBUNTU] Probleme graphique. - Droit d'écriture !

Bon voila,
jai modifié le fichier xorgg.conf de mon ubuntu pour installer Beryl, cependant mon ubuntu n’a pas trop aimé et me redémarre en mode console…
Ok je dois remettre le fichier comme il était avant mais il est en lecture seule COMMENT JE VAIS M’EN SORTIR :na: Merci pour votre aide.

Edit : le problème est : comment modifier un fichier qui n’a pas les droit d’écriture ???

Utilise la commande sudo qui permet de passer en super-utilisateur
man sudo pour plus de détails :wink:

Précis et efficace : Merci.
C’était exactement cette ligne (si ça peut t’interesser) : “sudo -e xorgg.conf”.

Oui pas mal, je connaissait pas l’option -e pour éditer directement le fichier voulu. Disons que j’ai plutot tendance à faire un sudo joe monfichier :wink: .

Si jamais t’as besoin de lancer plusieurs commande de suite en tant que root, l’option -s permet de se passer du sudo et remplace d’une certaine manière le su classique.

Ok merci, c’est bon a savoir. Maintenant que c’est réglé, je me remets sur la personalisation de mon Ubuntu :wink:

nota : sudo su marche aussi… :wink:

Bon tant qu’on y est j’ai un autre petit problème, je vais essayer de ne pas recréer un topic juste pour ça.
Je m’explique :

Là j’étais sur le point d’installer Beryl, mais pour les nvidia y’a un petit changement à faire et il est conseiller de taper cette ligne dans un premier temps :

sudo nvidia-xconfig --composite --add-argb-glx-visuals

Seulement, quand je la tape, il me renvoit :

sudo nvidia-xconfig : command not found

Donc a mon avis, c’est une petite mise à jour sachant que je viens d’installer ubuntu, mais laquelle…

Merci d’avance.

Tu n’as pas du installer les pilotes proprio nvidia. Je te conseille de suivre cette doc:
http://doc.ubuntu-fr.org/envy
ou http://doc.ubuntu-fr.org/nvidia.run

Ok c’est bon, merci à tout le monde :slight_smile: