Forum Clubic

Ubuntu --> problème de locale

Comme dit dans le titre, j’ai un problème de locale sous ubuntu.
J’ai fait un dpkg reconfigure locales, pour configurer correctement les locales, mais quand j’edite un texte avec un éditeur texte graphique (Gedit, par exemple) le texte est encodé en utf-8 alors que lorsque je l’édite en mode texte il est encode en iso-8859-15…

Le problème est sous le serveur apache (qui est correctement configuré maintenant), si j’utilise vi pour créer mes pages, aucun problème de locale, par contre si j’utilise un éditeur en mode graphique, la le texte est mal encodé et s’affiche mal sur le site…

J’ai appris qu’ubuntu est connu pour ses problèmes de locales, quelqu’un a trouvé une solution ?
en attendant je convertit mes fichiers, mais c’est un peu pénible à force…

Je sais pas trop, mais ce serait pas dans les options de gnome qu’il faut chercher ça, car gedit doit fortement en dépendre.

Sinon regarde sur le forum fr d’ubuntu, tu devrais y trouver ton bonheur.

Sur le forum, je n’ai pas trouvé beaucoup de solutions

Par contre, si ils veulent que cette distribution s’impose un peu plus, il ferai mieux de revoir la définition des locales, c’est un peu scandaleux qu’elles soient définies par défaut en utf-8 !!

Quelqu’un qui débute risque d’être un peu dérouté…
En attendant je code mon site sous… windows !

Ce n’est pas mieux d’utiliser ce que tout le monde utilise : l’iso-8859-15 ou -1?

Mais maintenant je comprend mieux pourquoi certain fichier de configuration d’application que j’utilise ne fonctionnait pas… :confused:

Le problème, c’est que tous les systèmes seront obligés de passer tôt ou tard en utf8… alors c’est clair que pour l’instant, ça peut être gênant, mais bon…

installe le paquet "recode", puis tape "recode latin1…utf8" pour convertir tes fichiers de conf :wink:

http://forum.ubuntu-fr.org/viewtopic.php?id=6446 :neutre:

Dans la vie faut aller de l’avant !
L’utf-8 est la norme de demain d’autant plus que je ne vois pas ce que cela change pour le codage du site puisque si tu es standard compliant alors tu dois préciser dans ton en-tête quel type de codage tu utilises.