Forum Clubic

Ubuntu, pas de connexions reseaux donc ps d'internet (page 2)

ok merci, je l’ai fait voile ce que ça donne

mehdi@mehdi-desktop:~$ sudo dhclient3 eth0
[sudo] password for mehdi:
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit www.isc.org…

Listening on LPF/eth0/00:1e:8c:aa:8d:c1
Sending on LPF/eth0/00:1e:8c:aa:8d:c1
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
mehdi@mehdi-desktop:~$

Tu as quoi comme carte mère (référence exacte) ?

Et dans une console :

sudo lspci

Quelle est la référence exacte de ta carte mère ?

Que te donne :

sudo lspci

alors ma carte mère est une asus P5GC-MX/1333, et pour la console ça donne

mehdi@mehdi-desktop:~$ sudo lspci
[sudo] password for mehdi:
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
02:00.0 Ethernet controller: Attansic Technology Corp. L2 100 Mbit Ethernet Adapter (rev a0)

sous windows ca passe ta connexion reseau en dhcp ?

Salut,

Tu as une carte réseau pas très courante : Attansic Technology

Une solution qui fonctionne apparemment : ubuntuforums.org…
ubuntuforums.org…

Voici le site de Asus pour télécharger les pilotes réseau : support.asus.com…
Tu fais une recherche par le nom de ta carte mère, puis sélectionnes “Linux” dans la liste.

Par contre, je crains que tu devras refaire cette manipulation à chaque mise à jour du noyau (kernel).
Edité le 28/09/2008 à 21:21

putain, c’est une des 1ere carte reseau mal reconnue que je vois…
C’est tellement rare…

Ben merci les gars pour votre aide je vais faire ça, il fallait que ça tombe sur moi lol, pourtant Atheros c’est quand même assez courant non?

excusez moi je vais peut être paraître un peu bête, je comprends l’anglais mais bon j’ai pas envie de me tromper vous pourriez me donner la démarche en français?

Merci

Salut,

Commence par télécharger les pilotes par le site d’Asus. Extrait cette archive à la racine de ton répertoire utilisateur (tu dois te retrouver avec un dossier “LinuxDrivers” contenant un autre dossier “Lan” puis “Attansic”. Dans ce dernier dossier tu as une autre archives que tu extraits à la racine de ton répertoire utilisateur également.

Installe le noyau “header” grâce à synaptic qui porte le même numéro de version que ton noyau :

uname -a

pour connaitre ce numéro.

Ensuite, tu lances une console et tu vas dans le répertoire “l2-linux-v1.0.40.4” :

cd /home/mhi/l2-linux-v1.0.40.4/src

(tu peux utiliser la touche en dessus de verrouille maj pour faire de l’auto-complétion avec les premières lettres du mot).
Tu vérifies que tu es dans le bon répertoire, et que tu as bien les mêmes fichiers qu’en “visuel” :

ls

Maintenant, il faut passer à la compilation du pilote :

sudo make install

Tu devrais voir des lignes apparaitre. Si à la fin tu n’as pas vu le mot “erreur” ou quelque chose qui s’en approche, et que d’après toi la compilation c’est bien déroulée :

insmod atl2

Maintenant que le pilote est installé, tu redémarres pour le prendre en compte (tu n’as pas besoin normalement, mais ne sait-on jamais).
Puis tu configures ton réseau grâce à l’icône dans la barre système.

/!\ N’oublie pas qu’à chaque mise à jour du noyau (kernel), tu devras recompiler ce pilote.

/!\² : je n’ai pas testé ce que j’ai écrit plus haut.


[quote="mhi_1_1"] Ben merci les gars pour votre aide je vais faire ça, il fallait que ça tombe sur moi lol, pourtant [b]Atheros[/b] c'est quand même assez courant non? [/quote] Ce n'est pas une Atheros, mais une Attansic. Pour dire, je ne connaissais même pas. Mais heureusement qu'Asus fournit des pilotes, même s'ils sont proprio et donc galère à installer. Edité le 29/09/2008 à 18:50

merci beaucoup pour ton aide je vais tester ça ce soir

Mais quand je regarde sous le gestionnaire de peripherique dans carte reseau, il me marque Atheros L2…

Commence par télécharger les pilotes par le site d’Asus. Extrait cette archive à la racine de ton répertoire utilisateur (tu dois te retrouver avec un dossier “LinuxDrivers” contenant un autre dossier “Lan” puis “Attansic”. Dans ce dernier dossier tu as une autre archives que tu extraits à la racine de ton répertoire utilisateur également.

Re, alors j’ai telechargé les pilotes mais pas sur le site d’asus je ne le trouvais pas, mais j’ai un problème c’est qu’en le décompressant je n’ai le repertoire Linuxdriver, mais seulement un repertoire L2-linux-v…, donc pas de fichier header tout ça

Si, prend le lien que je t’ai filé, fait des recherches sur le mot P5GC-MX, sélectionne 1333, puis lorsque ça te le demande choisis Linux.

Pour les headers, comme je l’ai signalé, il faut que tu te serves de Synaptic.

bon c’est bon j’ai trouvé mais je n’arrive toujours pas à installer, j’avance pas à pas come c’est la premiere fois, alors voila quand je vais dans la console je tape la commande pour entrer dans le fichier l2-linux-v1…, et qu’apres je tape la commande sudo make install, il me marque qu l’installaton ne peut se faire et marque arret, en même temps tu dis d’extraire les fichiers à la racine du répertoire utilisateur mais je ne trouve pas ce répertoire donc je les ai tout simplement mit sur le bureau c’est peut etre pour cela que ça ne fonctionne pas

bon j’ai quand même réussi à faire la manip mais bon, dans gestionnaire de paquets synaptic apparement le header est deja installé et quand je fais sudo make install ça me trouve des erreurs, regard

dl.free.fr…

Ok pour les “headers”.

J’ai pas le temps en ce moment de t’aider plus.
Revisite les forums cités plus haut, lis le fichier “readme” contenu dans le dossier du pilote.

Bonne chance.

ok en tout cas merci beaucoup pour ton aide

Tu as pu avancer ?