Forum Clubic

Ubuntu et utilisation de la partition FAT32 de win - Tous est dans le titre ^^

Coucou a vous ami clubikien et linuxien.

Voila il y a deja un petit mois de ça j’ai installé Ubuntu ( derniére version actuelle ), j’ai mis un peu d temp a comprendre certaine chose. Mais enfin voila, maitenant en tant que simple user j’arrive a faire a peu prés tous ce que je veux ( Internet, les mails, faire des modif sur mes photo,écouter de la zic, mater des films, coder mon site etc… ), pour un mec qui n’avais connue que windows depuis sa version 95, je trouve que je m’en sort trés bien.

Commençant a m’éloigné du coté obscure du logiciel proprio qu’est windows XP ( sauf pour les jeu, quel domage cela dit en passant ), je me suis dit qu’il falais que je partage mes fichier entre mes 2 OS. Donc j’ai couper mon HD principal en 2, une partition de 30Go en NTFS pour XP et mes jeux. Et une de 25Go pour le reste en FAT32. Jusque la pas de prob.

Seulement voila, j’ai suivie se que nos cher ami de clubic on expliqué dans leurs dossier " cohabitation linux & windows "(ici) pour faire apparaitre la partition en FAT32 sur Ubuntu…

Et je ne la vois pas.

Sinon sur le terminal ça me marque ça : ( les * c’est pour cacher les 2 mots qui sont la ^^ )

@*:~$ sudo fdisk -l
Password:

Disque /dev/hda: 60.0 Go, 60022480896 octets
255 têtes, 63 secteurs/piste, 7297 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce Début Fin Blocs Id Système
/dev/hda1 * 1 4110 33013543+ 7 HPFS/NTFS
/dev/hda2 4111 7297 25599577+ b W95 FAT32

Disque /dev/hdb: 6488 Mo, 6488294400 octets
255 têtes, 63 secteurs/piste, 788 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce Début Fin Blocs Id Système
/dev/hdb1 * 1 752 6040408+ 83 Linux
/dev/hdb2 753 788 289170 5 Extended
/dev/hdb5 753 788 289138+ 82 Linux swap / Solaris
@*:~$ sudo mkdir /media/windows
mkdir: Ne peut créer le répertoire `/media/windows’: Le fichier existe.
cyril@vegeta:~$ sudo mount /dev/hda1/media/windows/ -t vfat -o iocharset=utf8,um ask=000
Usage: mount -V : afficher la version
mount -h : afficher l’aide
mount : lister les systèmes de fichiers montés
mount -l : idem, incluant les étiquettes de volumes
Cela pour la partie informative. Suit la partie portant sur le montage.
La commande est « mount [-t type-sys-fichier] quelque-chose quelque-part ».
Les détails se trouvant dans /etc/fstab peuvent être omis.
mount -a [-t|-O] … : monter tous les périphérique listés dans /etc/ fstab
mount périphérique : monter le périphérique à l’endroit connu
mount répertoire : monter le périphérique connu ici
mount -t type périph rép : commande de montage ordinaire
Noter que celle-ci ne monte pas réellement un périphérique, une monte
un système de fichiers (d’un type donné) trouvé sur le périphérique.
Une peut aussi monter une arborescence de répertoires déjà visibles quelque part :
mount --bind ancien-rép nouveau-rép
ou déplacer une sous-arborescence:
mount --move ancien-rép nouveau-rép
Un périphérique peut être identifié par un nom comme /dev/hda1 ou /dev/cdrom,
ou par une étiquette, en utilisant -L étiquette ou par uuid, en utulisant -U u uid .
Autres options: [-nfFrsvw] [-o options] [-p mot_de_passe].
Pour plus de détails exécuter: man 8 mount .

Voila, si quelqu’un peu m’aider. J’ajouterai que je n’ai pas de racoucie qui c’est crée sur le bureau.
Contairement a mon HD externe qui aparai tous seul ( me demande bien pourkoi d’ailleur ^^ )

Merci de votre aide.

Il faut que tu ajoutes cette ligne au fichier /etc/fstab (qui gère le montage des partitions) :

/dev/hda2 /media/windows vfat defaults,auto,user,rw,uid=1000,gid=1000,umask=022,iocharset=utf8 0 0

Ca t’évitera de devoir faire ‘mount blabla’ à chaque fois que tu veux l’utiliser :wink:

defaults : options par défaut
auto : montage automatique (mettre noauto si tu ne veux pas)
user : permet à un utilisateur de monter/démonter la partition (et pas seulement root)
rw : lecture-écriture (mettre ro si lecture seule)
uid=1000 : donne les droits de cette partition à l’utilisateur numéro 1000
gid=1000 : donne les droits de cette partition au groupe d’utilisateurs numéro 1000
umask=022 : fixe les permissions (lecture, écriture, exécution)
0 0 : fréquences de sauvegarde et de vérification du système de fichiers (j’y connais rien je ne trifouille pas ^^)

Je te conseille de regarder le wiki ubuntu-fr, il a un très bon article à ce sujet. :wink:

Et ton disque dur externe est monté comme un grand car il est géré par une couche d’abstraction matérielle (HAL), qui le détecte, et transmet l’info via un messager (dbus) à un autre programme (gnome-volume-manager), qui le monte automatiquement.

PS : en fait, tu n’as pas respecté les espaces quand tu as copié la commande ‘mount blabla’ :smiley:

Cool ça marche !!!! :sol: :sol: :sol:

J’ai suivie en fait ce qui été écris sur le wiki de ubuntu comme tu me la conseiller.

Et en fait sur ma version, ben il y a un prog qui gere tous :lol: , donc voila mes donnée sur la partition fat me sont accecible de mes 2 OS. ( j’ai meme modifier mon HD externe en FAT32 :oui: )

SI ça continue bilou va pouvoir aller se faire f***** :pt1cable: :pt1cable: :pt1cable:

Vive linux, vive ubuntu :super: :super:

Et merci a toi mr_pouit :wink: