Forum Clubic

Traduire un algorithme sous java

Bonjour,
J’ai un projet en sciences de l’ingénieur, en terminale s, ou l’on bosse sur un lave vitre automatique.
Avec mes collègues, nous nous sommes répartis les taches et je m’occupe de la partie programmation.

J’ai donc pas mal travaillé en “brouillon” sur le logiciel algobox mais maintenant, je voudrais passer aux choses sérieux et traduire ce que j’ai fais sous Java pour faire une interface graphique et si possible simuler avec des objets numériques l?algorithme.

Donc j’aurais besoin d’un peu d’aide pour commencer svp.
Voici l’agorithme déja commencé :
[spoiler]1 VARIABLES
2 Colonne_min_immeuble EST_DU_TYPE NOMBRE
3 Ligne_max_immeuble EST_DU_TYPE NOMBRE
4 Ligne_min_immeuble EST_DU_TYPE NOMBRE
5 Colonne_max_immeuble EST_DU_TYPE NOMBRE
6 Température EST_DU_TYPE NOMBRE
7 Hauteur_système EST_DU_TYPE NOMBRE
8 Largeur_système EST_DU_TYPE NOMBRE
9 Volume_réservoir_1 EST_DU_TYPE NOMBRE
10 DEBUT_ALGORITHME
11 Volume_réservoir_1 PREND_LA_VALEUR 0
12 LIRE Ligne_max_immeuble
13 LIRE Colonne_max_immeuble
14 Ligne_min_immeuble PREND_LA_VALEUR 0
15 Colonne_min_immeuble PREND_LA_VALEUR 0
16 TANT_QUE (Volume_réservoir_1<9) FAIRE
17 DEBUT_TANT_QUE
18 Volume_réservoir_1 PREND_LA_VALEUR Volume_réservoir_1+0.2
19 AFFICHER Volume_réservoir_1
20 FIN_TANT_QUE
21 AFFICHER “Acquisition de la température ambiante de l’eau :”
22 LIRE Température
23 TANT_QUE (Température<125) FAIRE
24 DEBUT_TANT_QUE
25 Température PREND_LA_VALEUR Température+1
26 AFFICHER Température
27 FIN_TANT_QUE
28 TANT_QUE (Ligne_min_immeuble<Ligne_max_immeuble ET Colonne_min_immeuble<Colonne_max_immeuble) FAIRE
29 DEBUT_TANT_QUE
30 TANT_QUE (Ligne_min_immeuble<Ligne_max_immeuble) FAIRE
31 DEBUT_TANT_QUE
32 Ligne_min_immeuble PREND_LA_VALEUR Ligne_min_immeuble+1
33 AFFICHER “(”
34 AFFICHER Colonne_min_immeuble
35 AFFICHER “;”
36 AFFICHER Ligne_min_immeuble
37 AFFICHER “)”
38 TRACER_POINT (Colonne_min_immeuble,Ligne_min_immeuble)
39 Volume_réservoir_1 PREND_LA_VALEUR Volume_réservoir_1-0.5
40 SI (Volume_réservoir_1==0) ALORS
41 DEBUT_SI
42 TANT_QUE (Volume_réservoir_1<9) FAIRE
43 DEBUT_TANT_QUE
44 Volume_réservoir_1 PREND_LA_VALEUR Volume_réservoir_1+0.2
45 AFFICHER Volume_réservoir_1
46 FIN_TANT_QUE
47 Température PREND_LA_VALEUR 22
48 TANT_QUE (Température<125) FAIRE
49 DEBUT_TANT_QUE
50 Température PREND_LA_VALEUR Température+1
51 AFFICHER Température
52 FIN_TANT_QUE
53 FIN_SI
54 FIN_TANT_QUE
55 Colonne_min_immeuble PREND_LA_VALEUR Colonne_min_immeuble+1
56 AFFICHER “(”
57 AFFICHER Colonne_min_immeuble
58 AFFICHER “;”
59 AFFICHER Ligne_min_immeuble
60 AFFICHER “)”
61 TRACER_POINT (Colonne_min_immeuble,Ligne_min_immeuble)
62 SI (Volume_réservoir_1==0) ALORS
63 DEBUT_SI
64 TANT_QUE (Volume_réservoir_1<9) FAIRE
65 DEBUT_TANT_QUE
66 Volume_réservoir_1 PREND_LA_VALEUR Volume_réservoir_1+0.2
67 AFFICHER Volume_réservoir_1
68 FIN_TANT_QUE
69 Température PREND_LA_VALEUR 22
70 TANT_QUE (Température<125) FAIRE
71 DEBUT_TANT_QUE
72 Température PREND_LA_VALEUR Température+1
73 AFFICHER Température
74 FIN_TANT_QUE
75 FIN_SI
76 TANT_QUE (Ligne_min_immeuble>1) FAIRE
77 DEBUT_TANT_QUE
78 Ligne_min_immeuble PREND_LA_VALEUR Ligne_min_immeuble-1
79 AFFICHER “(”
80 AFFICHER Colonne_min_immeuble
81 AFFICHER “;”
82 AFFICHER Ligne_min_immeuble
83 AFFICHER “)”
84 TRACER_POINT (Colonne_min_immeuble,Ligne_min_immeuble)
85 Volume_réservoir_1 PREND_LA_VALEUR Volume_réservoir_1-0.5
86 SI (Volume_réservoir_1==0) ALORS
87 DEBUT_SI
88 TANT_QUE (Volume_réservoir_1<9) FAIRE
89 DEBUT_TANT_QUE
90 Volume_réservoir_1 PREND_LA_VALEUR Volume_réservoir_1+0.2
91 AFFICHER Volume_réservoir_1
92 FIN_TANT_QUE
93 Température PREND_LA_VALEUR 22
94 TANT_QUE (Température<125) FAIRE
95 DEBUT_TANT_QUE
96 Température PREND_LA_VALEUR Température+1
97 AFFICHER Température
98 FIN_TANT_QUE
99 FIN_SI
100 FIN_TANT_QUE
101 Colonne_min_immeuble PREND_LA_VALEUR Colonne_min_immeuble+1
102 TRACER_POINT (Colonne_min_immeuble,Ligne_min_immeuble)
103 SI (Volume_réservoir_1==0) ALORS
104 DEBUT_SI
105 TANT_QUE (Volume_réservoir_1<9) FAIRE
106 DEBUT_TANT_QUE
107 Volume_réservoir_1 PREND_LA_VALEUR Volume_réservoir_1+0.2
108 AFFICHER Volume_réservoir_1
109 FIN_TANT_QUE
110 Température PREND_LA_VALEUR 22
111 TANT_QUE (Température<125) FAIRE
112 DEBUT_TANT_QUE
113 Température PREND_LA_VALEUR Température+1
114 AFFICHER Température
115 FIN_TANT_QUE
116 FIN_SI
117 FIN_TANT_QUE
118 FIN_ALGORITHME[/spoiler]
Merci d’avance =)

et toi, qu’as tu fait ?

J’ai fais tout ce que j’ai mis dans la partie “spoiler”