Forum Clubic

Syntaxe pour accès en fat 32

Bonjour à tous,
Voudriez-vous me dire ce qui doit être rajouté à la syntaxe ci-dessous pour un accès sur une partition en fat 32, depuis ubuntu, en tant qu’utilisateur ?

/etc/fstab: static file system information.

<file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-15,ro 0 0

[i]/dev/hda2 /mnt/win_d vfat umask=0,iocharset=iso8859-15,codepage=850 0 0[/i]

/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/sda1 /mnt/cle vfat defaults,user,rw,noauto 0 0
Au lancement il existe aussi un "failed" dans le système de fichiers. Est-ce que ça peut être lié au rajout des deux lignes concernant windows.
merci

voilà ce que je mets comme options :
defaults,users,rw,uid=1000,gid=1000,iocharset=utf8,codepage=850 (pour le fat)

defaults,users,noauto,ro,uid=1000,gid=1000,nls=utf8 (pour le ntfs)

plus de renseignements ici => http://doc.ubuntu-fr.org/installation/part…ndows?s=windows :wink:

[+] désolé, il est fâché avec ce retour à la ligne en plein milieu :frowning:

essais d’ajouter l’option “default” a tes lignes :


/dev/hda1 /mnt/win_c ntfs default,umask=0,nls=iso8859-15,ro 0 0
/dev/hda2 /mnt/win_d vfat default,umask=0,iocharset=iso8859-15,codepage=850 0 0

mais en faisant ça, tes partitions seront montées automatiquement eu démarrage et démontées quand tu éteindra ta machine.

Bonjour,
J’ai été dans l’impossibilité de vous répondre pour cause de défaillance du FAI (dégroupage sur la commune ? ).
J’ai pu lire la doc. et transposer ceci à ma configuration.
Que ce soit avec ce que j’avais mis et en ajoutant “default” ou par ce qui est indiqué dans le tuto ubuntu, l’accès à la fat (win_d) (hda2), m’est toujours interdit.
Je peux lire “ntfs”, (hda1), mais ça a moins d’intérêt dans l’immédiat.
Et j’ai toujours ce “failed” apparu récemment à “mounting local systems”.
Réinstaller ? Que me suggérez-vous dans l’état ?
merci

peux-tu nous donner le résultat des commandes suivantes (dans l’ordre ça serait mieux) :

mount /mnt/win_d
sudo mount -t vfat /dev/hda2 /mnt/win_d
sudo fdisk -l /dev/hda
ls -l /mnt

/dev/hdb4 /media/hdb4 vfat defaults,uid=1000,gid=1000,auto,rw,users,quiet 0 0
voila la ligne de mon fstab créée par kubuntu pour etre monté au demarage si sa peut t aider

Bonsoir,
Je vais essayer ta syntaxe, bien que je sois avec gnome.
Pour la réponse, ce sera au bon vouloir du FAI, à éclipses depuis 4 jours.
merci de ton aide.

Bonjour,
Voilà ce que donnent les commandes que tu suggères “moi 1392”
Je crains que ce ne soit pas bon du tout. J’ai dû prendre des initiatives malheureuses. Une façon d’apprendre !
J’attends ton verdict.
merci
moroe@ubuntu:~$ mount /mnt/win_d
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
missing codepage or other error
(aren’t you trying to mount an extended partition,
instead of some logical partition inside?)
In some cases useful info is found in syslog - try
dmesg | tail or so


moroe@ubuntu:~$ sudo mount -t vfat /dev/hda2 /mnt/win_d
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
missing codepage or other error
(aren’t you trying to mount an extended partition,
instead of some logical partition inside?)
In some cases useful info is found in syslog - try
dmesg | tail or so


moroe@ubuntu:~$ sudo fdisk -l /dev/hda

Disque /dev/hda: 41.1 Go, 41110142976 octets
255 têtes, 63 secteurs/piste, 4998 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce Début Fin Blocs Id SystÚme
/dev/hda1 * 1 2295 18434556 7 HPFS/NTFS
/dev/hda2 2296 3021 5831595 f W95 Etendu (LBA)
/dev/hda3 3022 4998 15880252+ 83 Linux
/dev/hda5 2296 2932 5116671 b W95 FAT32
/dev/hda6 2933 3021 714861 82 Linux swap / Solaris


moroe@ubuntu:~$ ls -l /mnt
total 16
drwxr-xr-x 2 root root 4096 2006-03-11 10:09 cle
drwxr-xr-x 2 root root 4096 2006-03-11 10:11 minidisk
dr-xr-xr-x 1 root users 4096 2006-03-06 17:54 win_c
drwxr-xr-x 2 root root 4096 2006-03-11 10:12 win_d
moroe@ubuntu:~$


moroe@ubuntu:~$ dmesg | tail
[4295915.623000] sda: Write Protect is off
[4295915.623000] sda: Mode Sense: 45 00 00 08
[4295915.623000] sda: assuming drive cache: write through
[4295915.623000] /dev/scsi/host0/bus0/target0/lun0: p1
[4295915.664000] Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
[4295992.707000] usb 1-2: USB disconnect, address 2
[4296217.544000] FAT: bogus number of reserved sectors
[4296217.544000] VFS: Can’t find a valid FAT filesystem on dev hda2.
[4296302.188000] FAT: bogus number of reserved sectors
[4296302.188000] VFS: Can’t find a valid FAT filesystem on dev hda2.
moroe@ubuntu:~$

hda2 est une partition étendue : ta partition fat32 est hda5. Donc essaie en ajoutant à ton fstab (sur une seule ligne) :

/dev/hda5 /mnt/win_d vfat defaults,users,rw,uid=1000,gid=1000,iocharset=utf8,codepage=850 0 0

pareil que mr_pouit, j’avais oublié que cet imbécile de windoze ne sait pas créer plus d’une partition principale ! donc forcément, après hda1, c’est au moins hda5 :wink:

Salut,
Et merci, le problème est résolu.
J’ai maintenant accès à la fat32 depuis ubuntu. Une icône est même affichée sur le bureau, alors que dans la syntaxe figurait 'mnt" au lieu de “media”. Mais je ne m’en plains pas.
Merci encore pour l’aide efficace qui apprend beaucoup.
cordialement