Forum Clubic

SuSE 10 + X remote

J’essai de lancer une application X depuis une machine distante.
La connection échoue : Error: Can’t open display: mamachine:0

-J’accède à cette machine par rlogin (pas ssh)
-Le display sur la machine distante est bien positionné

Par contre sur la machine locale, X n’est pas en écoute sur le port 6000, donc évidement la connection est impossible.

Donc : quel est la croix à cocher pour que X accepte les connections distantes (et le fasse en effet, car la case est cochée dans yast, mais pas de connection en pratique). Quel est le fichier à modifier pour enlever une option de style -notpc ?

quetion subisdiaire : quel est le sombre imébcile qui à eu l’idée de cette option à la µ*%ù£$¤§! ?

Si tu essayais si :1 au lieu de :0 çà irait mieux :ane:

machine:1 c plutot pour vnc, pas pour X

Non c’est aussi pour X.

X -ac -query mamachinedistante :1

Voilà la différence Dans le second cas, j’ai une jolie connexion sur la machine.

je crois que c startx qu’il faut modifier pour enlever notcp

merci pour l’info je ne savais pas.

e.nounours: non, car je veux effectivment que ce soit affiché sur l’écran en cour s d’utilisation qui est bien le :0

bad_day01: Comment tu fais?

Tu es en console ?
Si tu as un xdm ou autre ‘X’ de lancé, faut taper le :1 ou :2 :3 … pas le choix.

Faut que tu expliques mieux. C’est quoi le gestionnaire de connexion sur ton serveur ?

c’est çà que tu veux ?
http://e.nounours.free.fr/Tmp/Capture.png

e.nounours : tu fais comment pour enlever le -notcp ?
Pour le reste c’est ok. Sur le serveur le gestionnaire est gdm, mais ce n’est pas très important puisque ce que je veux c’est:
1/ Sur la machine distante : accès par rlogin
2/ Dans le terminal de la machine distante lancement d’un programe utilisant X
3/Que l’application fonctionne sur mon desktop ‘comme d’habitude’ (ça fait un bout de temps que j’utilise ça)

Car ça marchait très bien jusqu’à un update…

On peut soit editer à la mimine le de conf de gdm “/etc/X11/gdm/gdm.conf” et c’est je crois à la fin du fichier quand il lance X “command=/usr/X11R6/bin/X -audit 0”
soit tu utilises le gdmsetup
Et là il faut :
Sous l’onglet "sécurité
“Activer XDMCP”
“Allow running XDMCP chooser”
onglet “XDMCP”
“honorer les requêtes indirectes”

Si çà va toujours pas, sous l’onglet “sécurité” tu peux autoriser les connexions différés à distance.

Ok, je jette un oeil là dessus.

[EDIT] Résolu

Hello :slight_smile:

Je me suis lancé dans l’aventure aussi mais je crois que quelque chose déconne sur ma debian :paf:

tux@Gentoo ~ $ X -ac -query 192.168.1.103

Fatal server error:
Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.


Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.

tux@Gentoo ~ $ X -ac -query 192.168.1.103:1

Fatal server error:
Xserver: Name or service not known: -query 192.168.1.103:1


Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.

:whistle:

J’ai bien editer le fichier gdm.conf et mis enable=true mais :pt1cable:

Bon apparament çà marche obligatoirement avec les noms et pas les ips :??:

En ajoutant le nom dans hosts çà roule :ane: et faut un espace aussi après le nom :smiley: