Forum Clubic

Streaming ne fonctionne pas avec Windows Media Player

Bonjour,

J’ai l’habitude d’écouter/de regarder des programmes sur le web en streaming audio/video. Je fais cela depuis longtemps, etr je n’ai jamais eu de problème. Mais dernièrement, je ne peux plus lire certains flux.
Je suis sous Windows Vista.

Exemple de flux ne fonctionnant pas:
Videos sur le site de France 5:
www.france5.fr…
www.france5.fr…
live.europe1.fr…

Exemple de flux fonctionnant:
radio.rtl.fr…
www.france-info.com…

J’ai essayé de mettre le lien “mms” des flux vidéos dans VLC (le lecteur vidéo par défaut pour les flux mms est WIndows Media Player) et cela ne fonctionne pas non plus.
Je n’ai fait aucun changement dernièrement, mais il se peut qu’il y ait eu une mise à jour de Vista entre temps, je ne m’en rappelle pas.

Une idée? Je me sers énormément du web pour regarder/écouter des programmes, et c’est vraiment un gros problème pour moi :frowning:

Merci

C’est peut être un problème ponctuel car je viens d’essayer France 5 (c dans l’air, celui ici ) et je n’ai pas eu de problème avec wmp.

Ce n’est malheureusement pas un problème ponctuel, cela fait un moment que cela dure :frowning:

Et en fait, cela fonctionne bien avec VLC, j’ai du faire une fausse manip précédemment. Seul WMP ne fonctionne pas correctement.
Malheureusement, VLC ne peut être intégré en tant que plugin dans Firefox ou IE, donc je dois passer par WMP pour une navigation comfortable.

Une idée? Je sèche complètement… :etonne2:

Bonjour,

Pour lire des flux vidéos avec WMP11, il faut :

  1. Vérifier les paramètres du lecteur WMP :
  • Dans le menu WMP, ouvrir “Outils”, choisir “Options” puis l’onglet “Réseau”.
  • Dans le cadre “Protocoles pour les URL MMS”, vérifier que RTSP/UDP, RTSP/TCP et HTTP sont bien cochés.
  • Dans le cadre “Flux multidiffusion”, vérifier que "Autoriser
    " est bien coché.
  • Dans le cadre “Paramètres du proxy”, cliquer sur la ligne HTTP puis sur “Configurer…” et cocher “Détecter automatiquement les paramètres du proxy”. Faire la même opération pour la ligne RTSP.
  1. Vérifier les paramètres d’Internet Explorer :
  • Dans le menu IE, ouvrir “Outils”, choisir “Options Internet” puis l’onglet “Avancés”.
  • Vérifier dans la partie “Multimédia” que tout est coché.
  • Dans l’onglet “Sécurité”, baisser éventuellement le niveau (Bas ou Moyen)
  1. Avoir installé les codecs Divx et Xvid.

En espérant que cela te dépanne…

A+

Merci.

Dans le cadre “Paramètres du proxy”, j’ai rien du tout…

Utilise Firefox et les modules Download Helper ou bien Unplug.
Ca marche epatamment bien.
WMP c’est valable pour ceux qui achetent leur musique avec des drm.
Ou bien pour tenir une bibliotheque de titres.
J’ai coupe le sifflet de ce truc dans le registre il y a longtemps. Comme ça il ne m’emmerde pas avec les tentatives de connection et de maj.
Edité le 19/03/2008 à 17:14

Une idée pour regler cela?


[quote="bigbernie"] Utilise Firefox et les modules Download Helper ou bien Unplug. [/quote] Unplug?

Unplug est aussi un module Firefox. Comme Helper.
J’ai installe les deux et je choisis l’un ou l’autre selon mes opportunités.
Ca marche tres bien et c’est tres leger comme tous les modules de Firefox.
Ca cree une icone en haut a droite de la barre de raccourcis de FF.
On clique sur l’icone et ça affiche tout ce qui est lien video sur la page sur laquelle on est loggé.
On choisit sa video et on clique Save et c’est parti.
Edité le 21/03/2008 à 12:20

Merci, c’est pas mal du tout en effet.
Malgré tout, je souhaiterais regler mon problème, non pas que je sois un fan absolu de WMP, mais c’est quand même comfortable de pouvoir lire la vidéo directement sur la page en question…

Up :frowning:

Tu y tiens a ton WMP

Comme c’est dit par les experts en video c’est

Tu dois d’abord configurer FFDShow en faisant bien attention que flv soit coche dans les additional tasks
Ensuite dans les decoder configuration tu dois cocher le libavcodec flv1 et VP6F
Ensuite dans les coder configuration tu dois cocher la meme chose
Pas fini

Pour ce truc limite piégé et limité qu’est WMP tu as besoin de flvsplitter

Tu as besoin de GabestFlashVideoSplitter que tu dois configurer comme ceci

Run the executable file that you downloaded, click Install and then click Close. Now to test it out, try to open your FLV files with Windows Media Player. Right click the FLV file, choose “Open With” and then select the “Select Program” option. From the list that pops up, select Windows Media Player. If the splitter is installed and FFDShow configured correctly, the file should play back without a hitch. If you get a message alerting you that the extension is not recognized by Windows Media Player, select “Don’t ask me again” and click Yes.

Alors que ça marche bien avec une facilite deconcertante avec les outils prevus pour, tu tiens absolument a utiliser cet engin de malheur qu’est WMP qui n’est pas prevu pour. WMP est fait pour les originaux “honnetes” ah ah ! je ris ! qui achetent des morceaux avec drm wmf. Beurk !

Bon…tu as a reponse ?
Ah oui ! Mon WMP lit bien les flv car j’ai testé avant bien sur.
Tu peux voir que mon WMP lit bien un film streaming appele chat.flv
C’est normal en capture d’ecran que le film lui meme ne soit pas visible, c’est un effet overlay

http://pagesperso-orange.fr/bigbernie1/chatflv.gif
Edité le 25/03/2008 à 18:23

Merci :slight_smile:

En fait, je ne tiens pas du tout à WMP, VLC lit très bien les fichiers que je souhaite avoir, j’aimerais simplement avoir un player intégré au navigateur, c’est plus comfortable.
Et en l’occurence, ce n’est pas vraiment les SLV, maus plutot les liens de type mms par exemple. En attendant, j’utilise VLC en player externe et cela fonctionne très bien.
S’il y a une astuce pour intégrer VLC en rant que plugin pour IE ou FF, je suis preneur!

Pas possible
WMP = Microsoft protege tres bien son player et ne veux pas payer pour integrer des modules externes.
Et je vois mal des outils du libre etre integres dans un outil Microsoft.
VLC est un player a temps complet qui n’a besoin de rien, sauf des codecs “libres” de FFDshow pour certaines actions

En fait le streaming c’est flv et swf qui est un format proprietaire a Macromedia. Lus par vlc et ces deux formats peuvent etre transformes en avi avec les logiciels adequats.
Quant a Microsoft Media Service c’est un format proprietaire Microsoft. Ca sert de transfert de données en Unicast. Tu peux lire ça avec WMP
Port UDP et TCP 1755 ouvert. Protocole RTSP.
Edité le 25/03/2008 à 19:40

MMS est aussi par VLC.
Merci de ta réponse.
Mais je ne comprend pas pourquoi cela a fonctionné pendant plusieurs mois sans problème et puis d’un coup cela ne fonctionne plus… Il doit y avoir un moyen de retourner à la config initiale!

Alors dans ce cas desinstalles WMP, par securite fais un nettoyage complet des restes eventuels avec par exemple TweakAll.
General add/remove visible et invisible. Attention, ça n’est pas un desinstalleur, c’est un nettoyeur.

Ensuite un bon coup de nettoyage registre avec par exemple RegCleaner. Il y en a d’autres.
Et tu reinstalles un WMP tout neuf.

WMP ne peut être désinstallé de manièreclassique sur Vista, et TweakAll ne supporte pas Vista apparemment :frowning:

Desole. Je n’avais pas remarque que c’etait Vista…faute d’inattention.
Je ne m’interesse pas a Vista, je n’apprend rien sur Vista, je ne passerai jamais a Vista. Plutot passer a Linux. Je commence a m’y interesser de nouveau d’ailleurs.
J’ai utilisé environ 8 O.S differents depuis 22 ans que je fais de l’informatique et pour moi Vista est le plus inutile de tous.
XP peut faire absolument tout ce que fait Vista ( meme Aero) en utilisant beaucoup moins de ressources et plus rapidement. Seul DX 10 ne fonctionne pas sur XP.
On ne va pas relister tous les moins de Vista par rapport a XP. Le web est plein de comparatifs sur le sujet.
En fait Vista n’a pas ete fait en vue d’ameliorer les performances au contraire car il les ralentit mais bâti avec la complicite de Majors afin de verrouiller le systeme le plus possible. Vista est un outil anti piratage. Pas un O.S. performant. Les explications sur les verrouillage et protections de Vista sont hallucinantes. De la folie.
Bon…Bonne journée.

En fouillant les forums anglophones, je vois que plusieurs personnes ont ce problème, mais toujours pas de solutions à l’horizon :frowning:


PS: ce sujet peut être fermé, je l'ai recréé dans la section Vista vu que c'est apparemment un bug propre à cet OS.