Forum Clubic

Streaming en Quicktime, question sur les codecs! - Quicktime streaming et codecs

Bonjour à vous !

voilà, je me retrouve avec deux formats vidéos, et je désire mettre des vidéos en ligne, en quicktime (et je veux ce format!!!), donc en "pseudo-streaming…
mais faut-il utiliser:
1° : du Sorenson video 3 + Q Design 2, stereo, 44100khz
(ça marche direct, sauf que la qualité est moyenne, et une barre de chargement charge la video au fur et à mesure…et donc cela pourra permettre “peut-être” de mettre un plus grand format…)
ou
2° : du MPEG-4 + AAC, Stereo, 22050khz
(bonne qualité, mais on sent que la video ne charge pas et qu’elle arrive entière
et cela peut-être après chargement dans le cache…

J’ai fait des essais avec ces deux formats, et je n’arrive pas à me décider, mais je privilégie la qualité, le sorenson et un peu “sale”, mais si celui-ci peut gérer de grosse video (+ de 100 mo) se serait bien aussi…
Voilà, si vous vous y connaissait je suis ouvert aux propositions , en sachant que je suis près à utiliser ces différents formats (ou autre…) pour arriver à mes fins,
et je le redis je ne suis pas intéréssé par du real one, ni par du media player…
car il me semble que le quicktime se gère bien sur pc et qu’à la base tout ça vient de personnes qui sont sous mac!!!
Merci à vous tous :smiley:

On peut pas faire grand chose pour ton pb, s’ils ont mis un cache important pour le mpeg4 c’est surement du à l’algorithme de compression qui necessite pas de mal de video avant de pouvoir decoder.

Tu peux peu etre essayer une autre solution, si tu veux faire un server de streaming essayes darwing (serveur de sreaming d’apple) qui sera peu être plus efficace que le lecteur quick time. (si ca trouve c’est la meme chose mais tu peux tjrs essayer)

++

:slight_smile: :slight_smile: pour la réponse, je vais jeter un coup d’oeil / serveur / quicktime

au passage, quelqu’un connait-il le fonctionnement de cette “histoire” de créer un metatags, avec un fichier .QTL, pour que cela puisse faire tampon entre le temps de lancement et de chargement des vidéos…?? car j’ai trouvé des trucs là-dessus, et j’ai un peu essayé, mais ya un truc qui m’échappe…ou alors c’est plus d’actualité…merci…

l’utilisation d’un tampon dans le cas d’un streaming video est pour palier 2 choses: l’encodage temps réel (codec) et pour palier les temps réseau.

Thanks pour la réponse tableur !! ya que toi qui connait le sujet et je t’en remercie…!

Mais il faut que :

  •      1 fichier HTML qui fait le lien vers le méta fichier
    
  •      1 meta fichier (.txt) (.QTL ou autre selon media utilisé...) qui pointe vers le
          vrai fichier video ou audio
    
  •      1 fichier média final, vidéo ou audio
    

bon en gros je capte, mais je n’y arrive pas…à la base je suis aller là pour mieux comprendre http://www.repaire.net/navig/diff_internet/#1 (bon si j’avais pas le droit de mettre cette source je suis sorry :))
pourtant ça doit être tout simple, mais voila je galère avec le metafichier…c’est comme si ça ne servait à rien…!!!
en même temps pour ça je n’ai pas fait d’essai sur le web, et vu que s’est pour du streaming, peut-être que s’est idiot de m’entêter à le faire sans web…???
merci pour la ou les réponses…et si tu as un exemples plus concret que ma source (qui ne fait que décrire) je suis preneur (enfin, du moment que je puisse accéder au code source des pages pour capter…merci :pt1cable: )

Le meta fichier indique le chemain d’acces à ta source vidéo. as tu attention aux / ou \ dans le chemin ?
Sinon as tu des messages d’erreur pour voir ce qui ne va pas?

Concernant tes essais en local, normalement ca doit marcher.

non pas de message d’erreur, juste qu’il ne se passe rien.

j’ai regardé vite fait la page de grabennouitch, que je vais tester, mais le <Href (etc…)> s’appliquerait donc à un objet video dans la page web…?

Peut-on répéter cette commande avec d’autres videos ? (ma page web sera plus une galerie de vignette menant aux videos streamé.)

Le hic est que j’aimerai ne pas avoir à créer des htmls intégrant le .quicktime
et c’est peut-être cela qui fait que ça mrd …
( je voudrai ne faire que les envoyers sur le dossier du site (les videos) + une image ajoutée aux autres dans la galerie, et une ligne pour cliquer sur l’image et lancer la video,…)

et savez-vous pourquoi avec internet explorer il-y-a une “latence” au lancement des videos, tandis qu’avec firefox s’est quasiment de l’instantané ? (test à partir d’ un pc…)

Merci à vous…

je fais un petit up en espérant une petite réponse…please… :slight_smile:

encore un up de up … je sais que s’est les vaçances … et j’attends toujours une petite réponse … même si se sera mon dernier up vu la foule des réponses … !!!
Thanks quand même !