Forum Clubic

Sous formulaire access pb de sauvegarde ?!

Bonjour,

Voilà mon problème. J’ai créé une base de données pour mon travail. Dedans j’ai une table factures et une nommée désignation.

A partir de la première table, j’ai fais un formulaire. Dans mon formulaire, j’ai mis un sous-formulaire en lien avec la seconde table. Ces tables ont une relation par le n° de facture.

Cependant, quand je rentre les informations dans mon sous formulaire, rien est enregistré. que ce qu’il y a dans le formulaire mais rien dans le sous-formulaire. Par contre, si je vais dans ma table, les informations y sont mises.

Pouvez-vous m’aider svp. Car je vais finir par m’arracher les cheveux.

1er question : quelle logiciel as tu utilisé et quelle type de base

j’utilise access 2003

prob de relation tu as le n° facture dans le sous formulaire ?

a+

J’ai essayer avec et sans et le problème persitste. Ou sinon j’ai une sauvegarde mais il y ma désignation se met sur toutes les fiches formulaires. déjà j’ai le choix !

Tu as quel type de relation entre tes deux tables ?

la normale.
Je ne connais que les bases de access mais d’habitude je ne rencontre pas de problème. ma relation a pour champs commun le n° de facture

Normalement, tes tables ne devraient être liées que par le contenu champ pere/champ fils que tu as mis en déclarant ton sous formulaire.
Vérifie bien leur contenu et supprime les autres relations voir si ca change quelque chose.
Si tu utilises des requêtes de sélection comme source, et pas les tables en direct, vérifie qu’elles se mettent bien à jour
Fais aussi Enregistrements > Afficher tous les enregistrements pour vérifier qu’il ne s’agit pas d’un simple problème d’affichage.

Merci beaucoup je teste dès lundi 9h00!

Ca fonctionne très bien maintenant. J’ai tout supprimer et recommencer en tenant compte de vos informations. C’est génial. Milles mercis x 100000.

:jap: