Forum Clubic

Soucis imprimantes LPT1 [relativement urgent plz] - Windows XP Home n'aime pas mes LPT1

:hello: Bonjour :hello:

Chat va ??

Alors… Mon soucis (x2, car j’ai le même soucis sur deux postes différents)…

Chez un client, j’ai le droit à deux PCs sous Windows XP Home (un en SP1 et l’autre en SP2). Ils ne sont pas en réseau.
Le poste sous SP1 a internet par la Freebox. Il a Kasp en AV-FW.
L’autre n’a pas d’accès internet, mais il a un Norton Internet Security.

J’ai voulu installé un copieur Ricoh en port parallèle sur chacun des deux PCs. Windows ne me le détecte pas automatiquement. J’ai donc fait une installation manuelle avec les pilotes d’XP, et les pilotes du site.
Windows me donne une erreur toute simple : impossible d’imprimer la page. Que ce soit sur l’un ou l’autre PC.

Je me suis dit, c’est le câble. Ne pouvant le testé, j’ai pris une autre imprimante qu’ils avaient (une HP Deskjet 1028 je crois). Qui a un port USB et parallèle.
Aucun des deux PCs n’a pu détecter l’imprimante, ni l’installer.

Auriez-vous une idée svp ??

Merci d’avance !

Dans le gestionnaire de periphériques t’as tout qui est bon au niveau des LPT1 ?

:hello:

Merci pour ta réponse.

Apparemment, tout est bon au niveau des ports de communications.
Le LPT1 à l’air bien configuré, il n’y a pas de conflit…
J’ai même tenté de les supprimer pour les réinstaller, mais ça n’a rien donné.

Dans le BIOS, il est enable, et EPP/ECP, v1.7, avec une IRQ ?

Dans le gestionnaire de périphérique, tu lui laisses prendre son IRQ et tu actives le P’n’P “à l’ancienne”.

:hello:

Je te remercie pour ta réponse.
Le bios est en en EPP/ECP (Bi-Dir), l’IRQ est la 7, mais je ne me rappelle pas pour la V1.7. Je dois retourner chez le client cet aprèm ou demain (ca dépendra de mes autres RDV).

Sous Windows, j’ai coché la case “détection PNP hérité” (je crois que c’est ça… :confused: )
Mais ça n’avait rien donné.

Si quelqu’un à d’autres idées que je pourrais essayé quand j’irais chez ce client, je suis toujours preneur :sol:

merci encore ! :jap:

Boot en DOS, et regarde si elle reçoit quelques choses en imprimante avec EDIT par exemple. Bien que certaines imprimantes comme les HP Business Inkjet aient perdu cette compatiblité, c’est un test interessant.

Sous Windows, mets le pilote intégré de la HP Laserjet 4, c’est une bonne base pour les imprimantes PCL, ou de la HP Deskjet 560C, pour les HP ! :wink:

Regarde aussi dans quel état est le service "Spooler"

Chef oui chef !

mici encore :slight_smile:

Je vais chez ce client lundi après midi. Ca me laisse encore un peu de temps.

Très bonne idée pour le service d’impression. Je n’y pensais même pas.
Merci encore :wink:

:hello:

Ca va bien today ?

Bon… C’est mon collègue qui s’en est occupé, et rien ne marche :frowning:
Il a même fait une réinstallation par dessus le windows présent, mais ça n’a rien donné.

Je suis en train de me demandé si les ports LPT ne seraient pas HS…
On va tester avec une installation propre dans la semaine (prendre un disque dur neuf, puis réinstaller et voir si ça marche).

Qu’en pensez-vous svp ?

Merci d’avance !! :wink:

Et par le port USB ?

Je pense que ça marcherait… Mais bon… L’imprimante en question est à l’étage du dessous (il y a un câble de 10m entre les PCs et l’imprimante).

Question… est-ce qu’une imprimante utilise tous les brins du câble parallèle ? Car il y a un HP Laserjet 6 (ou 4, je ne sais plus… Un vieux truc quoi qui marche mieux que les imprimantes neuves) de branché en LPT sur l’un des deux PCs, et elle marche. Mais les autres imprimantes, absoluement rien du tout.

Je suis complètement vidé là… aucune idée, rien du tout (comme les impressions… rien :ane: )

Merci pour ton intéret en tout cas Admin :wink:

Normalement le parallèle utilise un paquet de brins !
Normalement, aussi, la longueur max d’un câble parallèle, c’est dans les 5/6 mètres… (même si j’en ai eu de 20m)…

Quel type de copieur Ricoh ? Parce que pour certains copieurs ou fax, l’option imprimante est merdique à souhait…

La longueur maximale pour un câble parallèle est de 10m :wink:

C’est un Gestetner 3222 si je ne me trompe pas.

L’impression a marché avant… Un jour ils ont débranché le câble pour le mettre sur l’autre PC, et ça n’a plus marché, que ce soit sur l’un ou sur l’autre.
Mon collègue a testé le Ricoh avec le câble déjà présent sur son PC portable, et dessus, ça marche…

Aurais-tu une idée stp ?

Mici !

Et a l’etage en dessous ya aucun pc ?
Tu pourrais la partager sur le reseau, ce serait plus simple…

On va dire que pour le moment, il n’y a pas de réseau dans cette société… :neutre:

Ce projet est prévu pour un peu plus tard dans l’année (va comprendre pourquoi… Ca reviendrait bien moin cher niveau déplacement m/o de passer par le réseau pour tout faire que d’y aller pour cette connerie là).

Je te remercie pour ton idée en tout cas :slight_smile:

J’espère qu’on aura pas à formater… j’aime pas faire la récup de données :ane:

Retélécharge et réinstalle le pilote, pour voir… :neutre:

Tu peux imaginer que je l’ai déjà fait grand chef… ca n’a malheureusement rien donné :’(

Windows est incapable de me trouver une imprimante sur le LPT1. Même en passant par l’ajout suppression de périph, la fonction détecter du gestionnaire d’imprimante… rien, nada, que dalle.

Pour le service Spooler, il est actif et démarrer.

Merci pour tes idée :slight_smile:

Ce genre de truc ça ne se detecte pas…

Mais là… je ne vois pas… :frowning:

Essaye à l’inverse… de remettre le port parrallèle en SPP ou normal dans le BIOS, pour désactiver le bidirectionnelle et autres conneries, pour revenir à une config de basique !

Oki, je vais essayer ça…

J’avais déjà fait une remise à zéro du bios, et ça n’avait rien donné. Je verrais bien ce que ça donnera en SPP.

Je te tiendrais au courant :wink:

Merci encore une fois !! :super: