Souci avec touchpad sur un DELL XPS 1530 sous Ubuntu 8.10 ?

Bonjour a tous , voila , j’ai installer tout à l’heure Ubuntu 8.10, or avec le touchpad integrer à mon dell XPS 1530, sa ne fonctionne pas .

La souri bouge mal , clique n’importe quand alors que de base je voulai juste bouger .
Sous windows sa fonctionne correctement .

J’ai brancher une souri USB en attendant donc , et sa fonctionne que sa soit sous linux ou windows .

Quelqu’un sait d’ou pourez provenir le souci ?

Merci d’avance

Est-ce que tu as synaptic quelque part dans ton /etc/X11/xorg.conf ? si oui tu nous montres le passage.

voici xorg.conf ^^

xorg.conf (X.Org X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the xorg.conf manual page.

(Type “man xorg.conf” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following command:

sudo dpkg-reconfigure -phigh xserver-xorg

Section “InputDevice”
Identifier “Generic Keyboard”
Driver “kbd”
Option “XkbRules” “xorg”
Option “XkbModel” “pc105”
Option “XkbLayout” “fr”
Option “XkbVariant” “oss”
EndSection

Section “InputDevice”
Identifier “Configured Mouse”
Driver “mouse”
Option “CorePointer”
EndSection

Section “InputDevice”
Identifier “Synaptics Touchpad”
Driver “synaptics”
Option “SendCoreEvents” “true”
Option “Device” “/dev/psaux”
Option “Protocol” “auto-dev”
Option “HorizEdgeScroll” “0”
EndSection

Section “Device”
Identifier “Configured Video Device”
Driver “nvidia”
Option “NoLogo” “True”
EndSection

Section “Monitor”
Identifier “Configured Monitor”
EndSection

Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
Defaultdepth 24
EndSection

Section “ServerLayout”
Identifier “Default Layout”
screen “Default Screen”
Inputdevice “Synaptics Touchpad”
EndSection
Section “Module”
Load “glx”
EndSection
Edité le 03/05/2008 à 00:57

Ouvre un terminal tape “cat /dev/psaux” et utilise ton touchpad. S’il se passe rien alors c’est soit que ton touchpad est désactivé, soit que c’est pas le bon /dev qu’utilise ton xorg. Enfin si on te dit que tu as pas les droits tape sudo avant mais normalement y’a pas de problème.

bonjour, je viens d’essayer cat /dev/psaux, il se passe quelque chose, des caractere s’affiche qui ne corresponde a rien .
mon probleme esst assez compliquer a expliquer . Le touchpad fonctionne , mais le deplacement de la souri se fait tres mal . soit sa ne bouge pas beaucoup, soit sa clique alors quand je veux bouger .

Si tu veux Evorchfrend, je peux te faire un copier/coller de la commande , mais je doute que sa ne te serve

J’avais compris que ton touchpad ne fonctionnait pas du tout; pardon. Ce que je t’ai demandé est concluant ça veut dire que le touchpad fonctionne, mais j’étais crever hier soir et j’avais mal compris :slight_smile:

Le truc c’est qu’Ubuntu est aussi chiant que Windows si tu modifies ton xorg à la main il va pas vouloir le remodifier lui même lors des mises à jour de l’interface graphique (autrement dit du serveur X). Ceci dit ça peut régler le problème, et de toutes façons il suffit de faire un petit “dpkg-reconfigure -phigh xserver-xorg” (cette fois avec sudo) pour qu’il reconfigure tout comme un grand …

Bref, tu peux essayer “sudo dpkg-reconfigure -phigh xserver-xorg”, même si je pense pas que ça règle grand chose, mais bon… on sait jamais. Oublie pas de redémarrer le serveur X : Ctrl+Alt+Backspace après coup.

Si ça ne change rien, utilise le gestionnaire de paquet à Ubuntu pour retélécharger les drivers synaptics et les réinstaller (peut-être qu’il y a eu une mise à jour).
.
Ensuite, on peut essayer de retirer les lignes qui servent à rien dans le xorg.conf.

Commence par faire un backup du xorg.conf : “sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak”. Ensuite, ouvre le xorg.conf en root (enfin avec sudo parce que c’est sous ubuntu). Pour l’instant tu as ça dans ton xorg.conf :

Section “InputDevice”
Identifier “Synaptics Touchpad”
Driver “synaptics”
Option “SendCoreEvents” “true”
Option “Device” “/dev/psaux”
Option “Protocol” “auto-dev”
Option “HorizEdgeScroll” “0”
EndSection

et tu supprimes les lignes pour que ça ressemble à ça ( !! Oublie pas de laisser les lignes vide au dessus et en dessous de la section c’est super important)

Section “InputDevice”
Identifier “Synaptics Touchpad”
Driver “synaptics”
Option “Device” “/dev/psaux”
EndSection

Tu enregistres le fichier, puis tu fais un petit Ctrl+Alt+Backspace, et logiquement il fonctionnera, pas avec toutes les fonctionnalités, mais il devrait marcher sans bugger. SI l’interface graphique refuse de se lancer, ça arrive quand on touche au xorg.conf, pas de panique ! Tu fais un bête “sudo cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf” pour remettre le fichier d’origine et le serveur X se relancera normalement.
Et après tu peux t’amuser en supprimant les lignes que j’ai retirées une à une pour voir laquelle fait planter le serveur X et si l’une des autres ne règlent pas ton problème.

Si ça marche toujours pas solution de bourrin :
vérifie que cat /dev/input/mice te sort bien quelque chose que ce soit avec la souris usb ou avec le touchpad et si c’est le cas recontacte moi.

merci pour ton aide Evorchfrend mais sa ne fonctionne toujours pas , aucune difference en faisant les trucs que tu ma dit 1 par 1 .
le cat /dev/input/mice sort bien quelque chose que sa soit avec la souris USB que le touchpad …;

ok, bein reste un truc bourrin à faire. Perso c’est ce que je fais comme je configure toujours le xorg à la main et que je suis une grosse feignasse :smiley:

La section “InputDevice” sur le touchpad tu la supprime, ainsi que celle sur la souris, en gros ces deux là :

Section “InputDevice”
Identifier “Configured Mouse”
Driver “mouse”
Option “CorePointer”
EndSection

Section “InputDevice”
Identifier “Synaptics Touchpad”
Driver “synaptics”
Option “SendCoreEvents” “true”
Option “Device” “/dev/psaux”
Option “Protocol” “auto-dev”
Option “HorizEdgeScroll” “0”
EndSection

et tu remplaces par ça :

Section “InputDevice”
Identifier “Mouse0”
Driver “synaptics”
Option “Protocol” “auto”
Option “Device” “/dev/input/mice”
EndSection

sans oublier de changer la ligne du bas.

Inputdevice “Synaptics Touchpad” en
InputDevice “Mouse0” “CorePointer”

Oublies pas que tu as un backup parce que ça arrive que ça merde. (oublie pas non plus le ctrl+alt+backspace pour relancer le server X, sinon les changements sont pas pris en compte)

non plus snif …
je sais vraiment pas dou sa pourrai provenir

bon ba c’est bon j’ai trouver la solution sur un autre forum
voici le lien

www.net-actuality.org…