Forum Clubic

Souci avec mon Grub - souci de lancement de mon systéme

bjr,
rescement j’ai insatallé Fedora core 5 sur mon ordi portable;celui si étant déjà sous Win XP.
vu que je suis un debutant en systéme gnu linux,je suis arrivé malgrés ca à mettre à jour mon noyeau et installé d’autre élèments livna et aussi reconnaitre mais partitions ntfs.
Seulement voilà,j’ai dû faire une manip ka planté mon fedora5;la solution à lakél j’ai tranché c de formater ma partition linux.(mauvaise reflexion :sweet: )
suite a ca j’ai perdu la possibilité d’avoir le choix de depart pr prendre mon Win XP.
Maintenant quant je démarre mon ordi j’ai une page noire sur laquelle c’est noté :
**********************
GNU CRUB version 0.97 (638k lower / 5222112k upper memory)
[ Minimal Bash_ like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB Lists the possible complitions of a device/filename.]
grub> _
**********************
merci pr votre aide.

Soit tu réinstalles fedora, qui installera à nouveau un grub qui marche.
Soit tu utilises ton cd d’installation de windows et tu démarres en console de récupération ou réparation et tu tapes fixboot et fixmbr.

Si tu veux reinstaller fedora, la core 6 est sortie depuis peu et elle semble vraiment pas mal :wink: .

l’installation de fedora 6 ne me sera possible que d’ici 3mois;je suis actuellement une formation sur le théme des sys Gnu linux,et le prof s’est basé sur la fedora5.
sinon, re-installer mon fedora5 me semble plus simple du moment ke j’ai pas de cd vierge ici au tavail pr tester se ke ca donnera si je démarre mon ordi avec le CD recue de fedora ou même Ulmate boot CD.
merci en tt cas pr la reponse et encore pr la rapidité.

Si tu as formatté, de toute facon, la seule solution est de réinstallé fedora ou de restaurer le mbr de windows.

Pour ce qui est de l’utilisation de fedora, je te conseille ces trois sites :
http://fedorafaq.free.fr/
http://doc.fedora-fr.org/Accueil
http://fedoraproject.org/wiki/fr_FR/Projets

Sinon pour installer des logiciels, yum est très bien, mais je lui préfère smart package manager : http://labix.org/smart
Il y a y une interface qui me semble un peu plus puissante que yumex.

Bon courage.

je te remercie Jean pr ces informations supplmémentaires.ca me seront surement de grande utilité.
je ne sais pas si t’as vu ma deuxiéme question sur ce forum,ca concerne l’affichage de mon ecran,que j’arrive pas a exploité a fond,je te fais une copie :
*********************************
Rescement j’ai installé fedora5 sur mon ordinateur portable en procedant avec la command “linux vesa” vu que l’installation en mode graphique ne foncionnait pas (je me retrouvais devant un ecran noir au début du mode graphique) ; sinon, avec cette command, tout s’est bien déroulé seulement je suis en affichage 800 x XXX .j’aimerai bien profiter pleinement de mon ecran super large roll tout en restant avec fedora que je commence d’ailleurs à trop aimer cool
Ma carte est une carte ATI MOBILITY RADEON x700.
*********************************
merci encore pr ton aide.

au fait jean,je viens de lire la reponse d’une personne sur un autre forum ou j’avais posté ma derniere question hier soir.
cette personne a le même ordi que moi avec la même configue .il m’a proposé de :
“”“Si c’est un HP Pavilion DV4000 on a exactement le meme, dans ce cas je te file mon xorg.conf.”""
et juste aprés y’a tt un script à copier et coller et faire des modifs sur kelkes lignes.
seulement voilà je ne reste qu’un malheureux debutant :??: qui a besoin de savoir déjà se ke c’est le file xorg.conf et encore ou le trouver :sweet:

J’ai moi-meme un portable hp avec une x600 et je te conseille plutot de garder ton fichier xorg.conf., car d’une distrib à l’autre cela peut être un peu différent (quoique).

En gros:

  • soit a la prochaine installation tu tape linux vga=771 et tout devrait être nickel
  • soit tu utilises le pilotes libre radeon (il me semble qu’il doit etre inclu par défaut, mais a vérifier) et alors il te suffit de modifier le fichier /etc/X11/xorg.conf. Avant il faut passer en root (superutilisateur) avec la commande su (c’est normal que le mot de passe ne s’affiche pas), puis tapes:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.save
gedit /etc/X11/xorg.conf

Ensuite tu cherche la section Device et au niveau de l’option Driver tu mets radeon (a la place de vesa normalement). Ensuite il faut que tu te déconnectes. Si tu ne vois aucuns changements, appuies sur CTRL+ALT+Backspace.
Si tu n’as toujours pas la bonne résolution, c’est que ces modes ne sont pas présents. Donc dans le fichier xorg.conf précédent, il faut que tu les rajoutes dans la section screen, par exemple, voila une des subsection Modes que tu pourrais avoir:


    Subsection "Display"
        Depth       24
        Modes       "1680x1050" "1280x800" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection

  • soit tu installes le pilote propriétaire ati fglrx. Recherche avec yumex ou smartPM les paquets relatifs a fglx et installent celui qui correspond à ta version de kernel (uname -r). Et ensuite tu applique la méthode précédente en mettant fglrx à la place de radeon.Si a un moment tu as un soucis et que tu te retrouves sans interface graphique, il faut que tu restaures le fichier xorg.conf d’origine avec la commande en root :

cp /etc/X11/xorg.conf.save /etc/X11/xorg.conf

Je te conseille par commencer à regarder si les modes d’affichage sont bien présents. Après le driver radeon ou fglrx sont quand meme mieux que vesa, donc n’hésite pas les installer.

si tu a encore la ligne de commande grub, tout n’est pas perdu …
pour demarer Xp, il te suffit de tapper :

root (hd0,‘i-1’)
makeactive
chainloader +1
boot

si xp est sur ton disque /dev/hda’i’ (remplace i par le bon choix bien sur…)