Forum Clubic

[Solution] : Inspiron 6400 en 1280x800 sous linux - Comment faire

Après avoir passé quasi une nuit a essayer de mettre mon inspiron 6400 en 12800800 sous linux et non en 1024768 comme proposé, je vous donne ici la solution que j’ai trouvée.

Vous devez tourné sur xorg 6.9.0 au minimum. En premier lieu, vous devez tourné avec le driver vesa d’origine.

Voici la description des problème que j’ai obtenus au cours de cette installation, et leurs solutions :

(1) AU lieu d’utiliser le driver Vesa d’origine, j’ai sélectionné dans mon fichier de config le driver i810. Sous Xfree 6.9.0, le drivers est fourni dans /usr/X11/lib/modules/drivers : i810_drv.so.
Ne vous fiez pas à son nom.

Dans la version fourni avec Xfree 6.9.0, ce driver supporte les chipset suivants (tiré de xorg.0.log) :

(II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
	i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G

Le premier problème que j’ai rencontré était que je ne connaissais pas cette liste de chipset supportés, or sur mon dell inspiron 6400, c’est un 945GM.

J’avasi donc configuré mon xorg.conf correctement, pour utiliser ce driver i810 et une résolution de 1280*800, et ç marchait pas :

Le problème ne venait pas de mon xorg.conf comme je l’ai longtemp cherché mais du drivers qui ne supportait pas le chipset. Il faut donc recupéré le driver le plus i810 le plus récent.

Vous le trouverez ici :

http://dri.freedesktop.org/snapshots/

Téléchargé la dernière version qui n’est pas la common mais la i915 par exemple à cette date là la dernière est :

http://dri.freedesktop.org/snapshots/i915-…ux.i386.tar.bz2

Ouvrer l’archive, vous y trouverez le driver i810_drv.so dans le dossier i915, et palcer le dans le dossier /usr/X11/lib/modules/drivers afin de remplacer celui existant.

Ce driver supporte :

C’est déjà mieux :slight_smile:

Voilà à ce stade, après reboot, je n’avais plus le message d’erreur ci-dessus, mais ça marchait toujours pas :

C’est le deuxième problème

(2) Il y a un bug sur les dell qui empeche l’affichage d’une résolution type 1280*800. VOir cette page :

https://wiki.kubuntu.org/LaptopTestingTeam/DellInspiron6400

Mais il existe une solution : l’utilitaire 915resolution (pareil ne vous fiez pas a son nom il supporte actuellement j’usqu’au chipset 945GM (ouf!))

voir http://www.geocities.com/stomljen/ pour le témécharger

Compiler le ensuite, placer le dans le dossier /bin par exemple.

Ce logiciel modifie le bios de votre cg pour la faire tourner en 1280*800 sous Xfree. Ce n’est qu’un changement en mémoire, rien de définitif au niveau de votre cg. Ce programme doit se lancer a chaque démarrage pour pouvoir fonctionner (la modification n’étant pas permanente).
Sous Slackware, j’ai donc rajouter la ligne suisvante dans rc.local

/bin/915resolution 3c 1280 800

Pour savoir quel mode utiliser (le 4c ici), lister les modes compatibles avant en lancant

915resolution -l

puis choissisez le mode qui vous convient

Puis rebooter.

Bon le programme se lancait bien, et le patch s’appliquat bien pour le mode 3c (1280*800, 8bit/pixel)

Donc je tape startx

C’est le 3eme problème ^^

(3) Toujours le même message d’erreur :

(là ca commancait à me saouler)

En fait, maintenant que Xfree peut afficher une telle résolution, c’était mon xorg.conf qui foirait.

Il était comme cela à ce moment là :

Bon je me dit : il manque une modeline. Alors je la génére avect gtf :

 gtf 1280 800 60 

# 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
  ModeLine "1280x800"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync

Vous pouvez la réutiliser pour votre dell inspiron 6400 écran standart

Je la place alors dans la section monitor comme cela :

Et là je me dit que ca peut que marcher. reboot, tout ce passe bien, startx
Même message d’erreur :paf:

C’est le … 4 ème problème

(4) Pour résoudre le 4ème problème il suffit d’enlever ces lignes dans la section monitor :

et la … ca marche lol, démarrage en 1280*800 :super:

J’ai changé ensuite de mode au lancemznt de i915 pour avoir un mode avec plus de couleur (5c je crois)

J’espère que ca aidera quelqu’un.

Je vous fourni mon xorg.conf fonctionnel total au cas où:

:slight_smile:

classe !

tu devrais mettre ca dans le wiki clubic et/ou si tu utiises une ubuntu dans le wiki de www.ubuntu-fr.org
Ca serait vraiment utile a plein des gens

Salut, j’ai parcouru ton tuto à la recherche d’une info que tu as peut-etre: j’ai un 640m et je trouve que les couleurs sont pâles (aussi bien sous Win que sous Linux), aurais-tu une idée pour y remédier ?

Merci :slight_smile:

En gardant les proportions 4/3, ça ne devrait pas être 1280x960 ? ou 1280x720 pour le 16/9e (HD Ready :ane:).

Ben si les couleurs sont pales sous les 2 OS, c’est peut etre normal ou alors c’est un problème hardware et dans ce cas, contacte le sav de dell.
Regarde sur leur site dans la section téléchargement si tu ne peux pas trouver une configuration des couleurs pour ton écran (mais ca m’étonnerai).

Aop, tu parles de quel portable? car le 6400 est un 15,4" (donc du wxga en 1280x800 ou wsxga en 1680x1050) et le 640m est aussi un écran wxga en 1280x800 malgré le fait qu’il ne soit qu’un 14,1".

C’est un 640m.
J’ai essayé les autres résolutions 1280x*** et c’est très moche comme résolution. Nan je crois que la résolution est bonne (c’est celle-ci sur le site de dell je crois).

Maintenant, je ne sais pas dire si les couleurs que moi (qui suis habitué à un écran LCD de bureau) sont pales ou si c’est un pb hardware … :confused:

Je ne les connais pas, je n’ai que des Inspiron 5000, 7000, 7500 et C610 (tous en 1024x768).

Mais la résolution me semble bizarre … Ce sont des écrans "wides" ?

Mais visiblement, il construit son propre pilote. Je me contente des infos renvoyées par le PNP à Windows ! :ane:

C’est le moment de faire une pages web surle sujet et de mette un lien sur ce site très utile:
http://www.linux-laptop.net/