Forum Clubic

Serveur web perso - probleme pour monter mon serveur web

Bonjours a tous! :hello:
tout d’avors j’ai monté un petit serveur sur windows avec easyphp
voila j’ai tout configuré sauf qu’apres , je met mon ip dans internet explorer ( dans mon cas j’utilise dyndns.com pour rediriger mon ip puisqu’elle n’est pas fixe!!)
donc je tape http://servhd.dyndns.org et je ne peux pas acceder a ma page web :sweet:

AIDEZ MOI SVP

est ce que sa marche quand tu fais http://127.0.0.1 de ton serveur?

ton modem ou routeur ne gère peut etre pas le loopback. ou alors si tu as un routeur, tu n’as peut etre pas router le port 80 vers ton pc.

juste pour etre sur, avec easyphp, il suffit de mettre un index.html dans le bon repertoire et de specifier l’ip “locale” de ton pc dans le fichier de config de ton pc. ensuite tu verifies que easyphp demares bien.

EN fait quand je met http://127.0.0.1 dans mon navigateur j’accede bien a ma page web :bounce:

Et j’ai bien ouvert le port TCP 80 dans mon routeur (j’ai une livebox inventel)

Mai cependant quand je met mon ip publique je n’accede toujours pas a mon site web :??:

AIDEZ MOI PLIZZZZZZZ

Salut,
C’est normal, ton routeur ne te permet pas de sortir et rentrer sur ton réseau (fonction loopback). Fais un test en te connectant d’ailleurs que chez toi.
Amitiés
Janus

MERCI a tous pour vos explication
Mais j’ai essayer d’acceder a mon site depuis le pc d’un pote
donc j’ai tapé mon ip dans internet explorer (83.114.***.***)
et je ne peux toujours pas y acceder a ma page web :frowning:

SI VOUS AVEZ UNE REPONSE AIDEZ MOI SVP

Salut,
Quel message d’erreur ? Tu ne tapes que ton adresse IP ou bien l’adresse de ta page d’accueil ? Le ping fonctionne de l’extérieur ? Tu as quoi comme modem / routeur ?
Amitiés
Janus

SALUT janus,

Bon et bien je tape mon ip/index.php (mais ca de marche pas) j’ai aussi esayé en ne mettant que mon ip et sa ne marche pas non plus.

Quand je ping de l’ exterieur mon ip ca marche bien.

Et j’ai une livebox inventel

ET le message d’erreur est : “internet explorer de peut pas acceder accetta page web”

Tu as ouvert le port 80 c’est bien, mais surtout l’as-tu redirigé vers l’ip de ton poste (192.168.x.x)?

oui j’ai bien ouvert le port 80 et je l’ai redirigé vers l’ip de mon poste.

UNE PETITE IMAGE :
http://img295.imageshack.us/img295/3024/port80ux8.jpg

question tu as un firewall sur ton pc?
on t as peut etre poser la question mais bon!

J’ai entendu des gens dire qu’il faut mettre le pc dans la dmz… :confused:

oui j’ai un firewall :smiley: mais j’ai ouvers les ports 80 pour apache et 3306 pour mysql

et j’ai confiqueré la dmz ver l’ip de mon poste (192.168.1.114 :bounce: )

mais ca marche toujours pas!!!!!!!!!

:grrr:

ca ne sert a rien de mettre la dmz.
comme c’est indiqué sur ton snapshot, dans la dmz, tous les ports sont ouverts. donc soit tu mets ton serveur dans la dmz et tu laisse tomber l’ouverture des ports, soit tu ouvres les ports manuellement et tu laisse tomber la dmz.

question con, t’as bien configurer l’ip et le port dans le fichier de config d’apache?