Forum Clubic

Serveur proxy

Bonjour, J’ai installé FreeProxy sur un ordinateur.
Sur cet ordinateur, il y a deux cartes réseaux, la connexion Internet est branché sur l’une et sur l’autre il y a un routeur Netgear.
Sur l’ordinateur où le proxy est installé Internet marche.
Mais sur les autres ordinateurs qui sont branchés sur le routeur Netgear, Internet ne fonctionne pas, j’ai un message de Freeproxy qui me dit délai d’attente dépassé.

Quelqu’un aurait une solution ?

Merci de votre réponse

As-tu configuré l’adresse IP du proxy (sous Internet explorer) sur les postes où tu souhaite avoir internet?

Oui je l’ai configuré.
J’ai essayé en branchant la connexion Internet sur le routeur Netgear et de brancher le serveur proxy aussi sur le routeur Netgear.
Et là le proxy fonctionnait.
Mais j’aimerais que Internet ne marche que si on utilise le proxy donc j’ai essayé de brancher internet et le routeur Netgear sur l’ordinateur sur 2 cartes réseaux différentes.

De plus dans le message de délai d’attente dépassé, il y a marqué “Error reported by FreeProxy”

ton routeur est en mode routeur ou en mode passerelle?
Si il est en mode routeur vérifie que ton proxy autorise les accès aux IP qui ne sont pas sur le même réseau que lui
En mode routeur tu ne pourras pas utiliser l’authentification par adresse MAC…

Regarde les logs de ton serveur pour voir si tu as des infos complémentaires sur l’echec reporté

Un simple proxy ne permet pas d’obliger l’accès au net par son intermédiaire. Il te faut à la fois un proxy (éventuellement transparent) et des règles de routage/firewall qui force le passage des requêtes web via le proxy et/ ou qui bloque les requêtes directes
Edité le 23/12/2008 à 22:55