Forum Clubic

Serveur IIS + permissions

Salut,
je ne savais pas trop si ce topic avait sa place ici ou dans internet ou dans programmation, mais je pense que ce forum est le plus approprié.

J’explique mon problème :
j’ai installé sur mon pc Windows XP Professional SP1, puis j’ai installé SP2 par dessus. Ce faisant, j’ai perdu les fonctionnalité de la version Professional, j’ignore pourquoi. Sur le moment je ne m’en suis pas soucié vu que je ne m’en servais pas.

Or aujourd’hui je suis en train d’essayer de mettre en place un serveur IIS, faisant tourner entre autres php. L’installation et la configuration de php s’est déroulée sans encombre, et l’exécution des pages fonctionne, à un détail près : les sessions.
Dès qu’un script php essaie de créer une session, je reçois le message :

Warning: Unknown(): open(E:\Program Files\PHP\sessiondata\sess_0b53003523e494f9ede8232d8595b004, O_RDWR) failed: Permission denied (13) in Unknown on line 0

E:\Program Files\PHP\sessiondata étant le dossier où j’aimerais que les sessions soient stockées. Après quelques recherches et quelques tests, il semblerait que ce soit parce que le compte utilisateur utilisé par le serveur n’a pas les droits d’écriture dans le dossier. La technique pour changer les droits sous xp sp1 pro était simple : clic droit sur le dossiers, permissions, et de là changer les permissions de l’utilisateur voulu.
Et c’est là que ça coince vu que j’ai perdu les fonctionnalités de la version pro, je n’ai donc plus cet onglet dans les propriétés d’un dossier.
Connaissez-vous un autre moyen de changer les permissions, ou un moyen de réactiver les fonctionnalités de la version pro sans procéder à une réinstallation complète de windows ?

Merci d’avance

Bon j’ai à peine créé ce topic que j’ai trouvé la solution…

Pour ceux qui auraient le même problème, j’ai tapé dans la console :

cacls "e:\program files\php\sessiondata" /G IUSR_ARSTANEK:F

(IUSR_ARSTANEK étant chez moi le compte utilisateur utilisé par IIS).

Bref, problème résolu. Cependant si quelqu’un connait le moyen de restaurer les fonctionnalités de la version pro de Windows sur mon pc, je suis toujours preneur :slight_smile:

Salut,

L’installation du SP2 n’enlève rien des propriétés de la version Pro :wink:

Pour faire apparaître l’onglet Sécurité : dans les Options des dossiers, décoche Partage simple des fichiers.

Cette manip est valable pour toute version de XP, du moment où tu as une partition en NTFS.

Argh c’était tout simple en fait…

Merci pour l’astuce :slight_smile: